Unity doesn't mirror its interface for RTL locales

Bug #654988 reported by Haggai Eran on 2010-10-05
218
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Unity
Triaged
Medium
Unassigned
unity-2d
Medium
Alberto Mardegan
unity (Ubuntu)
High
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I noticed that for languages that are written from right to left, the unity interfaces stays the same. This is a little inconsistent with other GNOME apps: the left sidebar with the launchers should be on the right, and the top panel's items should be ordered from right to left. The fact that now the menubar is rendered by unity makes it even more bothering. The menus are rendered in reversed direction, and open to the right instead of to the left.

Freeze Exception Notes:
The exception is only for Unity 2D for which the RTL support is ready. The code impact is fairly small and the user interface for non RTL languages is left entirely untouched.

Related branches

Haggai Eran (haggai-eran) wrote :

Attaching a screenshot demonstrating the problem.

 status confirmed
 importance medium

Mark

Changed in unity:
importance: Undecided → Medium
status: New → Confirmed

I was thinking some discussion is needed for the best solution to this bug. Specifically, how to arrange the top panel. While I would expect the top panel to be mirrored when the desktop is RTL, some applications might not be translated, and use an LTR menu. In this case I suppose that the application menu would need to be drawn from left to right. Perhaps the application title should also move to the left of the menu, but I don't know about the rest of the panel. I think it should remain RTL so that it won't confuse the users.
What do you think? Is this even the right place to discuss this?

Paul Sladen (sladen) wrote :

This is an interesting policy issue; it's possible counter that it should be done by default by users of RtL who have expressed frustration at the mirroring when their muscle memory and mental model is familiar with the window/control layout. ...And particularly in the intermediate case of mixed-translation or partially-translated setups.

I think the principle is sound, though, which suggests that:

 - we should think about mirroring (i.e. if it's implementable, and how,
and when)
 - we could consider mirroring by default for RTL languages, and
 - we could have an override

Mark

David Barth (dbarth) on 2011-01-26
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.6
Changed in unity-2d:
milestone: none → 3.6
status: New → Confirmed
importance: Undecided → Medium
Mark Shuttleworth (sabdfl) wrote :

Whoa, we haven't tested the mirroring at all! So it's not a Natty goal.
Please drop from 3.6 goals.

Mark

Changed in unity-2d:
milestone: 3.6 → none
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → backlog

Hey.. I really don't like to disturb hard work before release over there.. but on RTL locals we are pretty worried - will this be ready until release? or even first updates? THANKS LOTS for any answer right now

Paul Sladen (sladen) wrote :

Hello Lavi. Mirroring, or the policy/logic code for when to activate is unlikely to "be ready for release". We have gone past feature freeze/UI feature feeze without it, which basically means that it's out of the window until the next cycle.

It's probably worth noting that some Arabic/Hebrew users have pointed out that they prefer *not* to have mirroring of the interface, so it's not a case of upsetting 100% of RtL users, but only the proportion of that percentage that would expect mirroring.

tags: added: rtl
Lavi .A (laviams) wrote :

oh well.. Thank you for your answer.. pretty sad to hear so though... The percentage of users that prefers it LtR is mostly UI designers that has to work with mirrored interface (but those users are most likely to have high control in English so they could use English instead), While DAILY working with any OS in RTL language without mirrored interface is pretty much impossible.. text is always aligned to the wrong direction makes it very confusing for mouse work are reading.. I guess RtL locals will have to use classic GNOME / GNOME 3.. for the lack of upcoming support in older environments I guess I'll start using debian (closest thing to ubuntu?) or fedora (might be too hard =/)
Anyway - thank you lots for your answer.. I hope it will be considered at least for the first updates for natty..
I believe it should be considered as a BUG and not a UI feature / design that should be freeze by freezing the UI!
-Lavi .A

Sultan Al-Isaiee (foxoman) wrote :

as Lavi said it's a Bug not a feature .
For me it's OK but I found more people complain about it .
So please Mark and unity team consider this bug to be solved this cycle as possible .

Check this screenshot from a duplicated bug :

http://launchpadlibrarian.net/67296729/Screenshot-2.png

Things looks messy and bizarre

I Knew there is a technical issue with it but you boys can do it :)

Florian Boucault (fboucault) wrote :

@Lavi and foxoman: would it be possible for you to test Unity 2D and report what you think is working/not working regarding LTR support? PPA is available at https://launchpad.net/~unity-2d-team/+archive/unity-2d-daily
Thanks a lot!!

Muhammad Negm (ravingeek) wrote :

@Florian i do use natty
do i need the ppa?

Paul Sladen (sladen) wrote :

Lavi: to answer your specific query. The people who've mentioned preferring a non-mirrored RtL interface were not UI designers… although they were definitely technical users, and so those people more likely to be using a combination of RtL and LtR in their daily work. My memory is that is was the /unpredictability/ of the /mixed/ environment that was the root of the desire not to have an automatic straight mirroring of all interface elements.

(This in no way downgrades the importance of having a working RtL mirroring setup available!).

Lavi .A (laviams) wrote :

@Paul: I'm very very sorry for that but I don't think I fully understand your comment due lingual problems I have (Understanding written texts..). If I did understood you correctly you meant that because mixed (RtL and LtR) interface is unpredictable, RTL mirroring should not be automatic? Again, very sorry I couldn't fully understand you. If this is what you meant then from a little research I made about RtL support in Unity I found on OMG! Ubuntu a comment Mark Shuttleworth left on their review for Unity saying that decision is to keep consistency and mirror Unity interface at some point not mentioned.
(Source comment: "For RTL languages, as discussed in LP and agreed, the interface will be mirrored in a future release. Patches to implement that are welcome, otherwise we'll get to it in due course." http://www.omgubuntu.co.uk/2011/03/unity/)
So as I understand things it's not a question of "if to?" but "when?"?
Everything is already mirrored under RTL languages except for Unity itself - GTK and nautilus are mirrored with or without Unity there! Until now RTL used to have full mirror support (except for default terminal input).
**keep in mind: technical users can easily switch between languages and get an LtR interface while some daily RtL users can not sometimes - it should be human to everyone, in their native language. developers (including me!) can always use all sort of patches daily work does not allow.
Thank you very much for this attention to the subject.. and Again - sorry for my lingual problems I tend to have sometimes.

Haggai Eran (haggai-eran) wrote :

@Paul: I think I agree with Lavi, that most of the confusion is caused when many components of the desktop are mirrored, but Unity itself isn't. For users who choose to use an LtR desktop, they can always choose an LtR locale, and still use RtL languages without any problems, so I don't think there need to be any special support for them in Unity.

Haggai Eran (haggai-eran) wrote :

Hi,

I tried running the current unity-2d on Lucid, and see how LTR support is today. I think that almost nothing have changes since I've opened this bug, except perhaps the order of the app indicators and the direction where their menus open, which is fine.
The app-indicators themselves are still aligned to the right, instead of to the left. The entire top panel should be mirrored.

As for the rest of the desktop it remains the same as in the maverick version. The sidebar is on the left instead of on the right, the menubar is aligned to the left, and the menus themselves open to the right, instead of to the left. You can compare it in the screenshot to Firefox, which does it right.

In the next attachment, I have a window maximized, and you can see how the window's close, minimize and maximize buttons are inconsistant between the windowed version and the top panel version.

There is also another unrelated RTL bug here, as the direction of the back and forward arrows in Nautilus aren't mirrored, but I don't think it belongs in this bug :)

Haggai Eran (haggai-eran) wrote :
Muhammad Negm (ravingeek) wrote :

natty updated unity 2d throw ppa

still nothing

Unity panel and dock should be mirrord

Most of arab users use the arabic UI but i think Natty won't be there choice

should we stick to 10.10 until that is fixed?

Its not only about the launcher, the panel itself should be mirrored which I
think is a more difficult part.

hatul (amiadb) wrote :

It's very disturbing for RTL users that Unity align to left.
 please fix it so urgently.

hatul (amiadb) on 2011-05-05
tags: added: arabic hebrew i18n l10n natty persian
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

Direct link to LtR-ish screenshot as provided by Nawfel above.

Paul Sladen (sladen) wrote :

Direct link to RtL mockup as provided by Nawfel above.

Yaron (sh-yaron) wrote :

All those guys who posted a screenshot of nautilus, please pay attention to the fact that the Back/Forward icons are reversed...

Lavi .A (laviams) wrote :

Will this be ready for 11.10? on 11.04 Mark pushed it to 11.10 (in one of his comments on a duplicate) which will have installed by default Unity only (as much as I know so far..). Using Unity as the default (11.04) without RTL supprt (neither mirror int' nor text on launcher) was a BAD statement as its own - using Unity without even an option (even an old interface) for RTL support will simply mean rejecting RTL-local communities. I know sending comments as this usually just creates unnecessary pressure - but please pay attention to the subject and reconsider its importance. Thank you.
-Lavi .A

Nawfel (b-gh-n) wrote :
Changed in unity-2d:
assignee: nobody → Alberto Mardegan (mardy)
status: Confirmed → In Progress
milestone: none → 4.10
Didier Roche (didrocks) on 2011-09-20
Changed in unity (Ubuntu):
status: Confirmed → New
Changed in unity-2d (Ubuntu):
status: Confirmed → New
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: Confirmed → New
Martin Pitt (pitti) wrote :

We discussed that in #u-desktop. For Oneiric we should ship the feature in the distro, but disable it by default. Then we can send a call for testing and document how to turn it on, so that interested people can test/use it.

For P we should turn it on early, and also get this fixed in 3D, so that the two are consistent.

Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2011-09-22
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 4.10.0-0ubuntu1

---------------
unity-2d (4.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - unity-2d-panel segfault switching between single and dual screens
      (LP: #848944)
    - bad memory leak in unity-2d-panel (LP: #850320)
    - unity-2d-panel crashed with SIGABRT in raise() (LP: #848155)
    - [dash] Dash is shown when pressing and releasing quickly super+KEY
      (LP: #801073)
    - Wallpaper is loaded twice with different alignment by gnome-session and
      nautilus (Oneiric) (LP: #804435)
    - [panel] Maximized window title switches to Arial font (LP: #820274)
    - [panel] graphics corruption in top line of pixels (LP: #846335)
    - Unity-2d no panel after cancel logout due to not responding app
      (LP: #849379)
    - [panel] Indicators are duplicated if unity-panel-service restarts with
      multiple monitors connected (LP: #850000)
    - Unity doesn't mirror its interface for RTL locales. (LP: #654988)
    - [panel] F10 shortcut with dual screens shows menus on both screens
      (LP: #777995)
    - Background wallpaper briefly appears shifted horizontally by around 15
      pixels on startup (LP: #839610)
    - alt+f2 - can type, doing nothing (LP: #842413)
    - Pressing Alt+F2 sometimes opens the Dash instead of opening the 'Run
      command' screen (LP: #847486)
  * debian/control:
    - bump libxi-dev build-dep
 -- Didier Roche <email address hidden> Thu, 22 Sep 2011 09:55:59 +0200

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
David Lahav (dh79f) wrote :

hi

did anybody see this (attached), the letters are coming out of the box.

david

Haggai Eran (haggai-eran) wrote :

David, I think you are talking about bug #834765.

Changed in unity-2d:
status: Fix Released → Fix Committed
Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
status: Fix Committed → Fix Released
Aslam Muhammad (aslamckra) wrote :

Unity 2-d still doesn't mirror panel or launcher for me although it says fix released for 2d. I have unity 4.12 and tested with arabic language.

Haggai Eran (haggai-eran) wrote :

Hi Aslam,

The right-to-left mirroring is only enabled when the translation of the QT_LAYOUT_DIR string in the current locale is "RTL". I understand from https://translations.launchpad.net/ubuntu/oneiric/+source/unity-2d/+pots/unity-2d/ar/10/+translate that it is not translated yet.

Please note that until bug #836498 is fixed, turning on this feature can make the dash almost unusable.

Uri Shabtay (uri.shabtay) wrote :

So - practically - this bug is far from fixed. Or am I wrong ?

Gerry Boland (gerboland) wrote :

Hi Uri,
The bug Haggai mentioned above is fixed in trunk, but unfortunately won't be available in Oneiric.

Haggai made a huge contribution https://code.launchpad.net/~haggai-eran/unity-2d/rtl-rebased/+merge/82151 which we're slowly going to integrate into Unity 2D and improve the RTL experience greatly.

We are also using an automated test system, so that the LTR and RTL experiences are treated equal from a quality perspective. See this as an early example: https://code.launchpad.net/~aacid/unity-2d/unity-2d_tests_for_rtl/+merge/90849

We hope to have excellent RTL support ready for Precise. We will be working on it right up to release. Community feedback will be vital from the Beta1 stage! *hint* :)

Thanks for the update. Any idea if this will be implented within Precise?
בתאריך 2012 2 3 01:46, מאת "Gerry Boland" <email address hidden> :

> Hi Uri,
> The bug Haggai mentioned above is fixed in trunk, but unfortunately won't
> be available in Oneiric.
>
> Haggai made a huge contribution https://code.launchpad.net/~haggai-eran
> /unity-2d/rtl-rebased/+merge/82151 which we're slowly going to integrate
> into Unity 2D and improve the RTL experience greatly.
>
> We are also using an automated test system, so that the LTR and RTL
> experiences are treated equal from a quality perspective. See this as an
> early example: https://code.launchpad.net/~aacid/unity-2d/unity-
> 2d_tests_for_rtl/+merge/90849
>
> We hope to have excellent RTL support ready for Precise. We will be
> working on it right up to release. Community feedback will be vital from
> the Beta1 stage! *hint* :)
>
> --
> You received this bug notification because you are a member of Ubuntu
> RTL, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/654988
>
> Title:
> Unity doesn't mirror its interface for RTL locales.
>
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity-2d” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi,
>
> I noticed that for languages that are written from right to left, the
> unity interfaces stays the same. This is a little inconsistent with
> other GNOME apps: the left sidebar with the launchers should be on the
> right, and the top panel's items should be ordered from right to left.
> The fact that now the menubar is rendered by unity makes it even more
> bothering. The menus are rendered in reversed direction, and open to
> the right instead of to the left.
>
> Freeze Exception Notes:
> The exception is only for Unity 2D for which the RTL support is ready.
> The code impact is fairly small and the user interface for non RTL
> languages is left entirely untouched.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/654988/+subscriptions
>

tags: added: delta-with-2d

Dear ones,

As I've asked in bug #871764 in comment #9:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/871764/comments/9

Please, if RTL in Unity/2D is not ready, make the users fall back to the known working shells.

Blessings,
Shahar

Shahar Or (mightyiam) wrote :

Actually, I must be corrected. The only graphical shells in Ubuntu live images and default install are Unity and Unity 2D.

Unity 2D does RTL mirroring quite OK in precise currently. Thank you Haggai Eran.

And Unity proper doesn't do mirroring.

So the preferred shell for RTL locales users would be Unity 2D until Unity is RTL'ed properly.

First, some screenshots would really make me/us happier, while it's also
useful to see where there's some work to be done. Second, it would be good
to publish them in OMG Ubuntu or Webupd8 to get more help from the community

cheers and thank u all,
Uri
בתאריך 2012 2 18 20:05, מאת "Shahar Or" <email address hidden>:

> Actually, I must be corrected. The only graphical shells in Ubuntu live
> images and default install are Unity and Unity 2D.
>
> Unity 2D does RTL mirroring quite OK in precise currently. Thank you
> Haggai Eran.
>
> And Unity proper doesn't do mirroring.
>
> So the preferred shell for RTL locales users would be Unity 2D until
> Unity is RTL'ed properly.
>
> --
> You received this bug notification because you are a member of Ubuntu
> RTL, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/654988
>
> Title:
> Unity doesn't mirror its interface for RTL locales.
>
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity-2d” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi,
>
> I noticed that for languages that are written from right to left, the
> unity interfaces stays the same. This is a little inconsistent with
> other GNOME apps: the left sidebar with the launchers should be on the
> right, and the top panel's items should be ordered from right to left.
> The fact that now the menubar is rendered by unity makes it even more
> bothering. The menus are rendered in reversed direction, and open to
> the right instead of to the left.
>
> Freeze Exception Notes:
> The exception is only for Unity 2D for which the RTL support is ready.
> The code impact is fairly small and the user interface for non RTL
> languages is left entirely untouched.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/654988/+subscriptions
>

Shahar Or (mightyiam) wrote :

Dear Uri,
Here are screenshots from precise.

Let's talk about the call for help in the Ubuntu-RTL mailing list, ok?

https://lists.ubuntu.com/mailman/listinfo/ubuntu-rtl

Uri Shabtay (uri.shabtay) wrote :

This is stunning. I agree, while we should also mail OMG Webupd8 Editors - that should do some media work.

Yaron (sh-yaron) wrote :

Lenses were translated properly, no untranslated strings should appear now.

Thank you all!

Haggai Eran (haggai-eran) wrote :

Hi all,

I have created a small patch that will cause Unity to fall back to Unity-2d when the current language is written from right-to-left. This could be used as a temporary workaround, until Unity gains better right-to-left support. The patch also allows overriding this behavior by setting an environment variable (UNITY_ALLOW_RTL).

You can find the patch at lp:~haggai-eran/nux/rtl-fallback-to-unity-2d. Comments and responses are welcome.

Regards,
Haggai

David Planella (dpm) wrote :

Hi Haggai,

Thanks a lot for the patch. The DX team folks can give you better advice on this, but as the patch addresses a workaround rather than a fix, it'd probably be better to file a separate bug for it (e.g. "Fall back to Unity 2D for RTL locales").

Omer Akram (om26er) on 2012-03-23
Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → nobody
Shahar Or (mightyiam) wrote :

Dear Friends,

Dear David, as per your suggestion, Bug #963682 was reported and Haggai, your branch was linked there.

Thanks and Blessings,
Shahar

Shahar Or (mightyiam) wrote :

Adding a recent screenshot

Shahar Or (mightyiam) wrote :

Whoopsie

Stefano Rivera (stefanor) wrote :

This doesn't appear to be a current FFe request. Unsubscribing the release team

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
Adolfo Jayme (fitojb) on 2013-04-20
Changed in unity (Ubuntu):
importance: Medium → High

I don't see any progress since April, and the next release of Ubuntu is just a month by now. Will this bug be fixed in the coming release 13.10?

Guess we are going to have another version with the same bug.
I don't see where is the problem with Haggai's branch, can anyone please
point it out?

Yaron Shahrabani

<Hebrew translator>

On Tue, Sep 3, 2013 at 9:28 PM, Abdul-Rahim Nizamani <
<email address hidden>> wrote:

> I don't see any progress since April, and the next release of Ubuntu is
> just a month by now. Will this bug be fixed in the coming release 13.10?
>
> --
> You received this bug notification because you are a member of Ubuntu
> RTL, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/654988
>
> Title:
> Unity doesn't mirror its interface for RTL locales.
>
> Status in Ubuntu Translations:
> New
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity-2d” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi,
>
> I noticed that for languages that are written from right to left, the
> unity interfaces stays the same. This is a little inconsistent with
> other GNOME apps: the left sidebar with the launchers should be on the
> right, and the top panel's items should be ordered from right to left.
> The fact that now the menubar is rendered by unity makes it even more
> bothering. The menus are rendered in reversed direction, and open to
> the right instead of to the left.
>
> Freeze Exception Notes:
> The exception is only for Unity 2D for which the RTL support is ready.
> The code impact is fairly small and the user interface for non RTL
> languages is left entirely untouched.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/654988/+subscriptions
>

@Yaron

Falling back to Unity-2D has not been an option since Unity-2D was dropped from Ubuntu.

Yes, it's true that this bug will not be addressed for Saucy (13.10). Adding proper LtR support to the Unity 7 stack is a large risk that will require several weeks of full-time engineering work and it competes with many other bug for the available resources. I can only offer apologies and say "maybe next cycle."

This list:
http://en.wikipedia.org/wiki/List_of_languages_by_total_number_of_speakers

Shows the following stats:
Arabic in the 5th place with somewhere between 255 to 422 million speakers.
Urdu in the 13th place with 104 million speakers.
Persian in the 25th place with somewhere between 56.6 to 110 million
speakers.

Hebrew (not on this list and much less significant) with 5.3 million native
speakers not including Arab Israelis that use Hebrew on a daily basis.

The numbers are reaching from 400 to 640 million, do whatever you please.

Yaron Shahrabani

<Hebrew translator>

On Sun, Sep 15, 2013 at 3:51 PM, Stephen M. Webb <<email address hidden>
> wrote:

> @Yaron
>
> Falling back to Unity-2D has not been an option since Unity-2D was
> dropped from Ubuntu.
>
> Yes, it's true that this bug will not be addressed for Saucy (13.10).
> Adding proper LtR support to the Unity 7 stack is a large risk that will
> require several weeks of full-time engineering work and it competes with
> many other bug for the available resources. I can only offer apologies
> and say "maybe next cycle."
>
> --
> You received this bug notification because you are a member of Ubuntu
> RTL, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/654988
>
> Title:
> Unity doesn't mirror its interface for RTL locales.
>
> Status in Ubuntu Translations:
> New
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity-2d” package in Ubuntu:
> Fix Released
>
> Bug description:
> Hi,
>
> I noticed that for languages that are written from right to left, the
> unity interfaces stays the same. This is a little inconsistent with
> other GNOME apps: the left sidebar with the launchers should be on the
> right, and the top panel's items should be ordered from right to left.
> The fact that now the menubar is rendered by unity makes it even more
> bothering. The menus are rendered in reversed direction, and open to
> the right instead of to the left.
>
> Freeze Exception Notes:
> The exception is only for Unity 2D for which the RTL support is ready.
> The code impact is fairly small and the user interface for non RTL
> languages is left entirely untouched.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/654988/+subscriptions
>

@Yaron,

The patches in 12.04 were only for Unity-2D. The patches I had for Unity(-3D) were preliminary (libnux only), so they would have required some more work to be used with 12.04. I don't think they will apply to current versions of Unity without significant changes.
However, once Unity(-3D) moves to using Qt, it would benefit from the already existing right-to-left languages support that Qt has, in the same way that Unity-2D did, and it should become easier to support right-to-left languages.

OK, so in this case we'll just give up and wait for the Qt implementation?

Adolfo Jayme (fitojb) on 2014-05-13
no longer affects: ubuntu-translations

4 years ago from reproted this bug...
:(

Haim (haim763) wrote :

pleeeeeeeeeeeas, fix this bug!!!!!!

chinoune (chinoune-mehdi) wrote :

a five years old bug , but no solution
you know why? because it affect only the RTL users.
where is your principle that ubuntu is available for anyone whenever his language.
good job canonical, the most RTL users left the unity desktop and are now using differents desktop because of your ignorance.

Shahar Or (mightyiam) on 2015-08-02
summary: - Unity doesn't mirror its interface for RTL locales.
+ Unity doesn't mirror its interface for RTL locales
Haggai Eran (haggai-eran) wrote :

From what I read, unity 8 is moving to QML. Since Qt and QML bring full RTL, bidi, and UI mirroring support, I expect this bug to be (relatively) easily fixed there.

chinoune (chinoune-mehdi) wrote :

Since Unity is dead this bug is no longer valid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.