migrate_favorites.py crashed with GError in register_new_app()

Bug #652785 reported by jmenand@me.com on 2010-10-01
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

I'm on Archos 10 Ubuntu. The bugs arrives on startup.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: unity 0.2.46-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Fri Oct 1 00:18:26 2010
ExecutablePath: /usr/lib/unity/migrate_favorites.py
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
InterpreterPath: /usr/bin/python2.6
ProcCmdline: /usr/bin/python /usr/lib/unity/migrate_favorites.py
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/lib/unity/migrate_favorites.py']
SourcePackage: unity
Title: migrate_favorites.py crashed with GError in register_new_app()
UserGroups: adm admin audio avahi avahi-autoipd backup bin cdrom couchdb crontab daemon dialout dip disk fax floppy fuse games gdm gnats haldaemon irc kmem libuuid list lp lpadmin mail man messagebus mlocate netdev news ntop ntp operator plugdev proxy pulse pulse-access root rtkit sambashare saned sasl shadow src ssh ssl-cert staff sudo sys syslog tape tty users utempter utmp uucp vboxusers video voice www-data

Related branches

jmenand@me.com (jmenand) wrote :

This crash has the same stack trace characteristics as bug #635156. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: removed: need-duplicate-check
tags: added: regression-retracer
Didier Roche (didrocks) on 2010-10-06
Changed in unity (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Triaged
visibility: private → public
Changed in unity:
importance: Undecided → High
status: New → Fix Committed
Didier Roche (didrocks) on 2010-10-06
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Changed in unity (Ubuntu):
importance: Undecided → High
David Barth (dbarth) on 2010-10-06
Changed in unity:
milestone: none → 0.2-sru
Didier Roche (didrocks) on 2010-11-25
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.0-0ubuntu1

---------------
unity (3.2.0-0ubuntu1) natty; urgency=low

  * New upstream release:
    - Clicking a second time on a menu item does not dismiss it (LP: #661048)
    - FavoriteStore re-ordering support (LP: #676106)
    - Quicklist menu item testing - part 1 (LP: #676030)
    - Base Quicklist Menu Items (LP: #676013)
    - Tooltip launcher don't appear in unity compiz (LP: #675486)
    - The migration script should be migrated to gsettings
      (LP: #680873, #652785, #655175)
    - Launcher clickable-area does not extend to left edge of screen
      (LP: #677573)
    - The ws switcher is always visible if launcher in floating and autohide
      mode (LP: #677554)
    - add application startup notification (LP: #638319)
    - Unity appears on top of gnome-screensaver (LP: #677705)
    - launcher tooltips hover over gnome-screensaver (LP: #652937)
  * debian/control:
    - don't recommend ubuntu-netbook-default-settings anymore
    - change the description
    - bump build-dep on latest nux
    - add libstartup-notification0-dev build-dep
  * debian/rules:
    - try a slighter best solution for netbook-launcher virtual package, thanks
      geser
  * debian/unity.install:
    - no more gconf file to install
  * debian/libunity3.symbols:
    - updated to latest and greatest
 -- Didier Roche <email address hidden> Thu, 25 Nov 2010 19:46:58 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers