navigating between indicator gives focus back to other dialogs during transitions

Bug #637143 reported by Sebastien Bacher on 2010-09-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Neil J. Patel
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Using unity 0.2.36

* run a software having different widget colors when unfocussed, ie firefox with a text entry selected
* click on an indicator and move on the left or right to open other indicators

you can see that the firefox dialog flickers it seems to focus is given back to firefox between indicators, the navigation between indicator feels a bit slow as well which could be a side effect

Related branches

Didier Roche (didrocks) wrote :

easily reproducible with latest unity

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) wrote :

Will be good to check this with latest implementation when ready.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.2.12
status: Confirmed → Triaged
Neil J. Patel (njpatel) on 2010-12-07
Changed in unity:
milestone: 3.2.12 → 3.2.6
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers