Erratic behavior with Wacom tablet

Bug #630193 reported by SnoStorm on 2010-09-04
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Nux
Triaged
Medium
Unassigned
Unity
Triaged
Medium
Unassigned
nux (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity-place-applications

When using a Wacom tablet (Both mouse and pen), the Unity launcher doesn't respond to left mouse clicks. Menus on the panel are also affected; they appear on mousedown, but disappear on mouseup.

Kristoffer Tjærnås (kt-nupi) wrote :

I have the same problem. I'm on a stylistic tablet with wacom digitizer built-in. Stylus is the only input method, but clicking the unity launcher-icons does nothing (only nudges the icon).
Sometimes the very first icon I tap(click) launches the app, but subsequent clicks don't work on any icon.

right-clicking launcher icons work (shows menu)
right-clicking inside any maximised application window only does a quick show-hide of menu.
clicking a menu on the top global-menu-panel only does a show-hide. Like said above - appear on mousedown, disappear on mouseup.
Same "show-hide" effekt on the shutdown-button etc in top panel.

The menu and rightclick problem in applications seem to go away if Maximus is configured with no_maximise, and the menu is on a line of its own (not in top-panel).

I also discussed the problem here:
http://ubuntuforums.org/showthread.php?t=1595331

I also have the same problem on a Thinkpad X200 Tablet with a wacom stylus. Identical behavior as above.

tags: added: unity wacom
Stephanie Sayer (phasemod) wrote :

I'm having the same problem with the ThinkPad X41 Tablet when trying to use the stylus on those buttons. It seems to me that the problem has to do with the fact that the buttons can be dragged and since using the stylus most of the time generates some movement even when just clicking I think the click is being treated as a drag.

I think Unity needs to have a threshold or null zone for this drag function on these buttons for tablets.

Didier Roche (didrocks) on 2011-02-03
affects: unity-place-applications (Ubuntu) → unity (Ubuntu)
Kristoffer Tjærnås (kt-nupi) wrote :

Just making a note that this does not affect unity-2d
And I don't think the click is interpreted as a drag event, because after boot the very first click on any icon correctly launches the application.

Gord Allott (gordallott) wrote :

Hi, thanks for reporting this bug, could you run apport-collect 630193 to collect some detailed information more useful, thanks

Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Confirmed

Architecture: i386
DistroRelease: Ubuntu 10.10
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
Package: unity 0.2.46-0ubuntu5
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Tags: maverick unity-2d ubuntu-une
Uname: Linux 2.6.35-25-generic i686
UserGroups: adm admin audio cdrom lpadmin netdev nopasswdlogin plugdev sambashare video

tags: added: apport-collected

apport information

Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: Confirmed → Triaged
M.Man (goku73-mkm) wrote :

Hi,
Having a very similar, if not the same, issue with my Intuos 4 on Windows 7 64bit. Within the Unity app, left click/drag doesn't register. However, it does seem to work with GUI/2D elements.

Wacom driver version: 6.1.6-7

Example here:
www.vostopia.com

In the "your avatar" section, the stylus has no effect (with a mouse you can drag rotate the view around the avatar), however, the take picture button in the top right works when clicked upon.

M.Man (goku73-mkm) wrote :

Whoops, apologies for posting this in a dedicated Ubuntu forum. Saw the bug title in a search and leapt on it!

taesoo kwon (taesoobear) wrote :

I installed natty by upgrading from 10.10, and having this issue.
I also thought that thigh might be sensitivity issue because Wacom pen cannot click without a few pixel dragging.
I can sometimes click a button though most of the times cannot. This is a common problem for wacom tablets; Docky also has this problem. But gnome-panel and other gnome-buttons work perfectly.

taesoo kwon (taesoobear) wrote :

I test some more. The erratic behavior is more problematic in some buttons than others.
For example, workspace switcher button in the side bar is almost unusable.
(Button-up is either ignored or interpreted as two clicks. So in both cases, I cannot select workspace).
Unity panel and app-menu also has similar problems (though somewhat better than side-bar, incomparably worse than gnome-panel). I really like unity, and would like to help fixing this bug if I can. (I am a programmer who can use debugger and most popular programming languages.)

taesoo kwon (taesoobear) wrote :

I switched to unity 2D. Now, everything works perfectly without noticeable visual difference.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-05-07
Changed in nux:
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in nux (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers