launcher icons are folded when launcher first starts

Bug #601107 reported by Pete Goodall on 2010-07-02
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Gord Allott
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

I login using the "Ubuntu Netbook Edition" session, the screen goes white (bug #601088), the launcher appears and the icons are all white (bug #601093) and all but the first icon are folded as if there was not enough room on the launcher. I only have four icons in the launcher, so there is definitely room. After a second or two they unfold and appear normal.

The icons should unfolded if there is plenty of room on the launcher and should appear much more smoothly. At the moment they just appear and it is rather jarring.

$ sudo lspci -kv -s 00:02.1
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
 Subsystem: Acer Incorporated [ALI] Device 022c
 Flags: bus master, fast devsel, latency 0
 Memory at 56300000 (32-bit, non-prefetchable) [size=512K]
 Capabilities: [d0] Power Management version 2

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.14-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-6.9-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic i686
Architecture: i386
Date: Fri Jul 2 16:10:43 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100602.2)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

Pete Goodall (pgoodall) wrote :

I think this may be deliberate, as part of the subliminal cue to users
that icons *can* fold. I agree the current implementation is jarring (it
all seems to happen haphazardly rather than smoothly). David S should
comment on the desired entry and exit behaviour, and we should make sure
it feels slick, with a flash mockup if needed.

At a minimum, nothing should appear till we can render it fully (no
white placeholder) nor should things feel jaggy or laggy, so we need to
be confident the animation can be smooth if it's specified.

Mark

Neil J. Patel (njpatel) wrote :

This is a bug caused by a race in the animation system, it's sometimes apparent with Maverick's Clutter but more so with the latest Clutter. The launcher has an initial animation to unfold the icons (a visual cue that they can be folded), however it's just getting stuck sometimes.

Changed in unity:
assignee: nobody → Gord Allott (gordallott)
importance: Undecided → High
milestone: none → 2010-07-08
status: New → Triaged
Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Confirmed

The Launcher should never appear folded when there is enough room to show all icons unfolded, even when the session starts. The visual cue that the Launcher icons can fold is that they do fold when necessary; no need to fold them prematurely.

If a stopgap session startup experience is needed, I recommend pre-calculating the eventual static state of the Launcher given the number of tiles it contains, then serially fading those tiles into position from the top. Tiles should fade in at a constant rate (e.g. 20 tiles per second) and not feel jerky, so hide IO wait from the user by sleeping if necessary.

Neil J. Patel (njpatel) on 2010-07-12
Changed in unity:
milestone: 2010-07-08 → 2010-07-15
Neil J. Patel (njpatel) on 2010-07-16
Changed in unity:
milestone: 2010-07-15 → 2010-07-22
David Barth (dbarth) on 2010-07-26
Changed in unity:
milestone: 2010-07-22 → 2010-07-29
Neil J. Patel (njpatel) on 2010-07-28
Changed in unity:
assignee: Gord Allott (gordallott) → Neil J. Patel (njpatel)
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2010-08-02
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.22-0ubuntu1

---------------
unity (0.2.22-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - Add support for window control buttons on the panel (LP: #610014)
    - Create a files group model for downloads (LP: #610370)
    - Fix odd representation of (partially) off-screen windows (LP: #594221)
    - Fix selected category doesn't match the displayed one after a place
      switch (LP: #604949)
    - Move places shortcuts to the launcher (LP: #610015)
    - Fix wrong arrow location in place views (LP: #604800)
    - Launcher icons no more folded when launcher first starts (LP: #601107)
  * debian/control:
    - bump clutk build-dep
  * debian/patches/02_disable_expandable_menu.patch,
    debian/patches/03_strip_underscore_on_quicklist.patch,
    debian/patches/04_fix_scroller_focus_issue.patch,
    debian/patches/05_fix_ws_switching.patch:
    - removed
  * debian/patches/02_i18n_launcher.patch:
    - from trunk, support use localized apps name (LP: #612494)
 -- Didier Roche <email address hidden> Mon, 02 Aug 2010 15:55:16 +0200

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Hernando Torque (htorque) wrote :

This is not fixed for me.

Changed in unity (Ubuntu):
status: Fix Released → New
Omer Akram (om26er) wrote :

confirmed

Changed in unity:
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: New → Triaged
David Barth (dbarth) on 2010-08-03
Changed in unity:
milestone: 2010-07-29 → 2010-08-12
importance: High → Medium
status: Confirmed → New

I think there are serious problems with the code responsible for
deciding the layout of the launcher based on the position of the mouse.
This is just one example. David, can you do a review of the work there?

Mark

Changed in unity:
milestone: 2010-08-12 → 2010-08-19
Neil J. Patel (njpatel) on 2010-08-18
Changed in unity:
assignee: Neil J. Patel (njpatel) → Gord Allott (gordallott)
importance: Medium → High

Same here. Unity 2.28 on Maverick.

Neil J. Patel (njpatel) wrote :

Gord is going to add some code to guard against this. Basically animation timers aren't completing on startup.

Changed in unity:
milestone: 2010-08-19 → 2010-08-26
status: New → Triaged
tags: added: launcher
Gord Allott (gordallott) on 2010-08-26
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Gord Allott (gordallott) on 2010-08-28
Changed in unity:
status: Triaged → Fix Released
jyio (inportb) wrote :

As of now, this no longer seems to be a problem. Thanks for the fix!

Hernando Torque (htorque) wrote :

Is this supposed to be fixed in Maverick? I'm still seeing the icons folded (and white) on session start.

Attaching a short clip showing:

1. Desktop background after GDM
2. White screen (mutter bug 601088)
3. COF button + window buttons
4. Launcher bar with folded white launchers + desktop background
5. Desktop the way I expect it to show up

Didier Roche (didrocks) wrote :

it's fixed. The icons are folded on purpose at start, the bug was having them sticking as folded at start. The other bugs are already reported. Thanks.

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Hernando Torque (htorque) wrote :

Oh, thanks for clearing this up!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers