Search seems completely broken

Bug #600732 reported by Didier Roche on 2010-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Neil J. Patel
unity (Ubuntu)
Medium
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

I get with 01.07.10 release a lot of regression in search:

- in the application places, the match seems only to be done on "Most Used".
- when I remove the last character from the search field, it seems not being reset (I only have the matching to last letter)
- when I make a search matching something, click on the ubuntu icon to switch back to normal mode and switch back to the place then, I still have the match to the search but the Search entry is called "Search"

For "in the application places, the match seems only to be done on "Most Used" it's because we only search for apps in zeitgeist now. In the future we'll query the index of software-center but that requires a fair deal of non-trivial integration work before we can get there... Perhaps a bug on its on.

I created bug #600759 to track the issue with application searching

Mirco Müller (macslow) on 2010-07-02
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Changed in unity (Ubuntu):
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
status: New → Triaged
milestone: none → 2010-07-08
Changed in unity (Ubuntu):
milestone: none → maverick-alpha-3
Neil J. Patel (njpatel) on 2010-07-09
Changed in unity:
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → Neil J. Patel (njpatel)
Neil J. Patel (njpatel) on 2010-07-12
Changed in unity:
milestone: 2010-07-08 → 2010-07-15
Neil J. Patel (njpatel) wrote :

All fixed, the most-used only search is because unity-place-applications needs to seach another index (being tracked by another bug)

Changed in unity:
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2010-07-16
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2010-07-16
Changed in unity (Ubuntu):
assignee: Mikkel Kamstrup Erlandsen (kamstrup) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.4-0ubuntu1

---------------
unity-place-applications (0.2.4-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - add support when search string is empty (LP: #600732)
 -- Didier Roche <email address hidden> Fri, 16 Jul 2010 14:45:42 +0200

Changed in unity-place-applications (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.8-0ubuntu1

---------------
unity-place-files (0.5.8-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - add support when search string is empty (LP: #600732)
 -- Didier Roche <email address hidden> Fri, 16 Jul 2010 14:46:01 +0200

Changed in unity-place-files (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.18-0ubuntu1

---------------
unity (0.2.18-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - can't drag and drop item to last position in launcher (LP: #595819)
    - set a solid color as background (LP: #594232)
    - select a place by default (LP: #601020)
    - Support offline shortcuts in quicklist (LP: #595842)
    - keyboard focus in places should default to the search entry (LP: #599888)
    - fix various search issues in places (LP: #600732, #604964)
    - contracted/expanded feature doesn't take mouse position into account
      (LP: #595878)
    - Use X-GNOME-FullName when available for launcher hover text (LP: #594285)
    - SIGSEGV in _clutter_stage_has_full_redraw_queued (LP: #594209)
  * debian/control:
    - bump libclutk-dev build-dep to latest
    - add libdbusmenu-glib-dev, libgnome-desktop-dev and libgnomeui-dev deps
  * add debian/patches/01_add_dbusmenu_glib_vapi.patch:
    - not distribute yet, small fix in the vapi to make a method return an
      unowned variable instead of an owned one
 -- Didier Roche <email address hidden> Fri, 16 Jul 2010 14:48:14 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers