contracted/expanded feature doesn't take mouse position into account

Bug #595878 reported by Pete Goodall on 2010-06-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Gord Allott
unity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: unity

Observed behaviour:
When there are too many items in the launcher the launchers at the bottom and/or top will "accordion", but when I place my pointer over those items, the bottom most items will go below the bottom of the screen. It seems like unity is not taking into account either the bottom of the screen or the position at which the pointer entered the launcher area.

Expected behaviour:
The bottom should be a hard limit and when the launchers expand the launcher above should push the other icons up. I think this also needs to take into account where the pointer enters the launcher area as that indicates which launchers the user is trying to click. Therefore, if the pointer enters in the middle there is no need to expand the folded icons at the bottom. If the pointer enters at the top, the top should be a hard limit and the folded icons should push the other icons down.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.10-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-4.5-generic 2.6.35-rc3
Uname: Linux 2.6.35-4-generic i686
Architecture: i386
Date: Fri Jun 18 11:11:01 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100602.2)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

Pete Goodall (pgoodall) wrote :
Didier Roche (didrocks) wrote :

confirmed, I was about opening the same bug

Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
Neil J. Patel (njpatel) wrote :

I think this is invalid. If you look at the launcher video that the design team posted, you can see that, upon hover, all the icons are meant to become un-rotated and the user can move towards the top or bottom to scroll the launcher. Could you please have a look at the video here http://design.canonical.com/2010/06/introduction-to-unity-launcher/ and update this bug (whether we aren't meeting the requirement in the video, or if this bug is still valid etc), thanks.

Changed in unity:
assignee: nobody → Gord Allott (gordallott)
status: Triaged → Incomplete
Mark Shuttleworth (sabdfl) wrote :

The icon your mouse entered over should still be the icon your mouse is over after the unfolding is complete. I'm going to mark the bug invalid because the mockup handles this correctly, feel free to file it again if the actual implementation falls short by beta 1.

Changed in unity:
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Triaged → Invalid
Didier Roche (didrocks) wrote :

in the current implementation (0.2.12), it seems to not point the icon your mouse entered over

summary: - accordion feature doesn't take mouse position into account
+ contracted/expanded feature doesn't take mouse position into account
Changed in unity (Ubuntu):
status: Invalid → Triaged
Changed in unity:
status: Invalid → Triaged
Gord Allott (gordallott) on 2010-07-01
Changed in unity:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.14-0ubuntu1

---------------
unity (0.2.14-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - fix wrong window geometry (LP: #578545)
    - fix quicklist items were unresponsive when the mouse was overing over them
      (LP: #598561)
    - fix can't drag and drop item to last position in launcher (LP: #595819)
    - removes/unfavorites apps on drag out, (LP: #592744)
    - fix contracted/expanded feature doesn't take mouse position into account
      (LP: #595878)
    - fix really slow to display place icons (LP: #599901)
    - display files thumbnails (LP: #599896)
  * debian/control:
    - recommend ubuntu-netbook-default-settings as the session file is there
      and a lot of people could install unity without the session file
    - build-dep on last clutk
 -- Didier Roche <email address hidden> Thu, 01 Jul 2010 19:08:22 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Gord Allott (gordallott) on 2010-07-16
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers