Crash when switching to a virtual console

Bug #595452 reported by Hernando Torque on 2010-06-17
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Jason Smith
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

When switching to a virtual console during the "window overview" mode, gdb reports "Program exited with code 0377.". Mutter then restarts every couple of seconds as long as you stay at the virtual console.

Steps to reproduce:
1. Make sure at least one window is open
2. Click on the CoF
3. Press Ctrl+Alt+F1 to change to the virtual console
4. Check the output of 'pgrep mutter' for some seconds

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-3.4-generic 2.6.35-rc3
Uname: Linux 2.6.35-3-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Jun 17 12:27:32 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity

Hernando Torque (htorque) wrote :
Neil J. Patel (njpatel) wrote :

Seriously, I'm loving your bug reports....you seem to have an enviable knack of finding strange issues :) Jason, have fun with this ;)

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
importance: Undecided → Critical
milestone: none → 2010-07-01
status: New → Triaged
Hernando Torque (htorque) wrote :

It's a win-win situation. ;-) Unfortunately I cannot check if those bugs still exist in 0.2.12-0ubuntu1, because I don't know how to initiate the expose/"window overview" mode (clicking the CoF shows the file/app overlay). Any way to do this via a command?

Neil J. Patel (njpatel) wrote :

Hmm, good point, there isn't a direct way to do a full expose now (should probably add that as a command-line option for unity binary). Until then, does this happen if your in the app-expose (right-click on an active launcher's icon).

Hernando Torque (htorque) wrote :

Oh, didn't think of that. Yes, I can still reproduce it:

1.) open gnome-terminal
2.) "pgrep mutter" -> 15360
3.) app-expose
4.) ctrl+alt+f1
5.) "pgrep mutter" -> 15434
6.) ctrl+alt+f7
7.) "pgrep mutter" -> 15434

The only difference is, that mutter doesn't restart every couple of seconds while on the virtual console.

Didier Roche (didrocks) on 2010-06-29
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Mirco Müller (macslow) on 2010-07-02
Changed in unity:
milestone: 2010-07-01 → 2010-07-08
Jason Smith (jassmith) wrote :

I just tried this, it works fine here. Can I have information about your system. Graphics card, drivers, ram configuration and anything else that might be relevant software wise.

Hernando Torque (htorque) wrote :

* 2GB RAM, 128MB VRAM
* VGA compatible controller [0300]: nVidia Corporation NV43 [GeForce 6600 GT] [10de:0140] (rev a2)
* nvidia-current BLOB (256.35)

I can reproduce it with a plain maverick install (+nvidia-current), so any other software installations on my current machine should be irrelevant.

Hernando Torque (htorque) wrote :

Should read "current installation".

Hernando Torque (htorque) wrote :

FWIW: I just realized mutter consuming 95+% CPU after switching to the virtual console (it already has a new pid at that time). Interrupting it via gdb, it is somewhere in /usr/lib/nvidia-current/libnvidia-glcore.so.256.35 - not that I know if that's to be expected or not.

Neil J. Patel (njpatel) on 2010-07-12
Changed in unity:
milestone: 2010-07-08 → 2010-07-15
Hernando Torque (htorque) wrote :

I'm not able to reproduce it with the Nouveau 3D drivers. They don't play nicely together with Unity (desktop looks garbled), however I was able to run the steps to reproduce the crash but it didn't happen.

Neil J. Patel (njpatel) on 2010-07-16
Changed in unity:
milestone: 2010-07-15 → 2010-07-22
Hernando Torque (htorque) wrote :

With unity 0.2.18-0ubuntu1 I no longer need to initiate the expose mode: _every_ switch to the virtual console triggers the crash, mutter then restarts every 2-5 seconds and causes 90-100% CPU load.

I cannot test with Nouveau since the current version combination doesn't seem to work (I can only see white flashes on session start).

David Barth (dbarth) on 2010-07-26
Changed in unity:
milestone: 2010-07-22 → 2010-07-29
Hernando Torque (htorque) wrote :

Nouveau works again with Unity 0.2.20-0ubuntu2 (kinda), and I can confirm #10, so it's maybe a problem with Nvidia's BLOB.

summary: - Crash when switching to a virtual console during "window overview" mode
+ Crash when switching to a virtual console
David Barth (dbarth) on 2010-08-03
Changed in unity:
milestone: 2010-07-29 → 2010-08-05
David Barth (dbarth) on 2010-08-09
Changed in unity:
milestone: 2010-08-05 → 2010-08-12
Changed in unity:
milestone: 2010-08-12 → 2010-08-19
Neil J. Patel (njpatel) on 2010-08-20
tags: added: drivers nvidia
Changed in unity:
milestone: 2010-08-19 → 2010-09-02
David Barth (dbarth) wrote :

Can't reproduce as of the current version of mutter and unity. Tested on Nvidia and GMA945.

Changed in unity:
status: Triaged → Fix Released
David Barth (dbarth) wrote :

Hmm, no, still crashing on nvidia after double-checking

Changed in unity:
status: Fix Released → Triaged
Didier Roche (didrocks) wrote :

tty is not a default experience on ubuntu. Furthemore, the crash makes mutter respawn in the unity session and don't close any opened application.

Changed in unity (Ubuntu):
importance: Critical → Low
Neil J. Patel (njpatel) on 2010-09-05
Changed in unity:
milestone: 2010-09-02 → 2010-09-16
gv (giordano-valloggia) wrote :

I have the same behaviour when switching to a tty and when resuming from a suspend. I use nvidia driver, too.

David Barth (dbarth) wrote :

Re-adjusting the priority, as it's a corner case and affects certain configurations only. Unfortunately, new issues are far more critical.

Changed in unity:
importance: Critical → Medium
Neil J. Patel (njpatel) on 2010-09-16
Changed in unity:
milestone: 2010-09-16 → 2010-09-22
Jason Smith (jassmith) wrote :

Unable to observe crash, running in gdb to try to get a handle on it.

Changed in unity:
status: Triaged → In Progress
Hernando Torque (htorque) wrote :

GDB doesn't spit out more than that -1 exit code here (nvidia-current and beta BLOB from Nvidia's HP), but .xsession-errors shows the following when switching to a virtual terminal:

(mutter:2683): Clutk-WARNING **: [CheckGLError] GL_INVALID_OPERATION error in File ./ctk-arb-asm-private.c at line: 151
(mutter:2683): Clutk-WARNING **: [CheckGLError] OpenGL Error 1282 in File ./ctk-arb-asm-private.c at line: 151

(mutter:2712): Clutk-CRITICAL **: FBO Error: 36061
(mutter:2712): Clutk-CRITICAL **: FBO Error: 36061
(mutter:2712): Clutk-CRITICAL **: Incomplete render target: 36061
(mutter:2712): Clutk-CRITICAL **: Incomplete render target: 36061
(mutter:2712): Clutk-WARNING **: [CheckGLError] UNKNOWN ERROR in File ./ctk-effect-cache.c at line: 298
(mutter:2712): Clutk-WARNING **: [CheckGLError] OpenGL Error 1286 in File ./ctk-effect-cache.c at line: 298

(mutter:2730): Clutk-WARNING **: [CheckGLError] GL_INVALID_OPERATION error in File ./ctk-effect-cache.c at line: 154
(mutter:2730): Clutk-WARNING **: [CheckGLError] OpenGL Error 1282 in File ./ctk-effect-cache.c at line: 154

(mutter:2733): Clutk-WARNING **: [CheckGLError] GL_INVALID_OPERATION error in File ./ctk-effect-cache.c at line: 154
(mutter:2733): Clutk-WARNING **: [CheckGLError] OpenGL Error 1282 in File ./ctk-effect-cache.c at line: 154

(mutter:2737): Clutk-WARNING **: [CheckGLError] GL_INVALID_OPERATION error in File ./ctk-effect-cache.c at line: 154
(mutter:2737): Clutk-WARNING **: [CheckGLError] OpenGL Error 1282 in File ./ctk-effect-cache.c at line: 154

Omer Akram (om26er) wrote :

and it seems the oldest unity(package) bug is fixed with the move to compiz :)

Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Vish (vish) wrote :

\o/ compiz

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers