Unable to set a solid color as background

Bug #594232 reported by Hernando Torque on 2010-06-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Otto Greenslade
Unity
Fix Released
Low
Mirco Müller
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Setting the background to "No Desktop Background" in "Appearance Properties > Background" doesn't work (although I've seen the selected color during a crash right before unity restarted).

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-2.3-generic 2.6.35-rc2
Uname: Linux 2.6.35-2-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Jun 14 18:21:46 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity

Related branches

Hernando Torque (htorque) wrote :
Neil J. Patel (njpatel) wrote :

The Background object should monitor the correct gconf keys and, when a solid colour is chosen, set this colour on the stage and hide it's texture.

Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → Low
milestone: none → 2010-07-01
status: New → Triaged
Didier Roche (didrocks) on 2010-06-29
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Mirco Müller (macslow) on 2010-07-02
Changed in unity:
milestone: 2010-07-01 → 2010-07-08
Jay Taoko (jaytaoko) wrote :

Does the mention "No Desktop Background" means the user is choosing a solid color? If that is the case, I cannot reproduce the problem. When running Unity, the desktop background changes appropriately when a texture or a solid color is selected...

Hernando Torque (htorque) wrote :

Yes, "No Desktop Background" is just the tool-tip of the solid color item. I'm still experiencing the bug with unity version 0.2.14-0ubuntu1 (tested on two installations, one of them just a week old). In addition, the background selection tab in gnome-appearance-properties seems to have problems drawing the image thumbnails (see attached screenshot).

Neil J. Patel (njpatel) wrote :

Hey Jay, there are a few points to this problem, sorry I wasn't descriptive enough earlier:

1. When we get a NULL or "" from the picture_filename key in gconf, we ignore it. It actually means the user wants to only see the coloured background

2. We don't monitor the /desktop/gnome/background/primary_color and ../secondary_color gconf keys, and therefore we currently don't know what the colour values are.

3. Finally, we're not monitoring the /color_shading_type key under the same path, which tells us if the user wants a sold (only primary colour) or horizontal/vertical gradient.

All these three things need to be fixed to support the users options. We also have a separate bug about not actually showing the background correctly too (our zoom isn't the same as gnome-settings-daemon's zoom, for instance, so it looks like the wallpaper has moved when unity starts). For this, could you please chat to didrocks, who once mentioned there is a library that'll give you the correct background for the size you want (applying the users preferences correctly).

Didier Roche (didrocks) wrote :

Hey Neil,

the library is simply libgnome-desktop, which allows you to know those case and use the caching as well (both g-s-d and nautilus) are using them.

Neil J. Patel (njpatel) wrote :

Excellent, thanks Didier! Jay, could you please look into using gnome-desktop to get the desktop background for the Background object. See if it also does the colour-only stuff, that would be useful :-)

In addition to all the things Neil said, we should have a default
fallback colour in case nothing is specified in the gconf keys. Please
make it one of the official aubergine's from the consumer end of the
palette. Otto can provide a value.

Mark

Ted Gould (ted) wrote :

Adding design to confirm the color.

Neil J. Patel (njpatel) on 2010-07-08
Changed in unity:
assignee: Jay Taoko (jaytaoko) → nobody
assignee: nobody → Mirco Müller (macslow)
Mirco Müller (macslow) wrote :

Looks like I've to create the Vala-bindings for GnomeBG (part of libgnome-desktop).

Mirco Müller (macslow) wrote :

At least for gnome_bg_new(), gnome_bg_get_color () and gnome_bg_create_pixmap().

Mirco Müller (macslow) on 2010-07-08
Changed in unity:
status: Triaged → In Progress
Neil J. Patel (njpatel) on 2010-07-12
Changed in unity:
milestone: 2010-07-08 → 2010-07-15
Mirco Müller (macslow) wrote :

I'm still unable to create proper vala-bindings for this. Trying to follow http://live.gnome.org/Vala/Bindings causes all sorts of problems along the way. I do not think writing the bindings from scratch is something to do for somebody so "familiar" with the vala-language/system. Some one with more experience in that domain should tackle the bindings.

Changed in ayatana-design:
status: New → Invalid
status: Invalid → In Progress
assignee: nobody → Otto Greenslade (otto-chaotic)
Otto Greenslade (otto-chaotic) wrote :

As ideal default solid background colours:

For Ambiance - Ubuntu Dark Purple - HEX: #2C001E RGB: 44 0 30
For Radiance - Ubuntu Grey - HEX: #AEA79f RGB: 44 0 30

If we can't define separate colours for Ambiance/Radiance I suggest using the Ambiance colour for both:
Ubuntu Dark Purple - HEX: #2C001E RGB: 44 0 30

Changed in ayatana-design:
status: In Progress → Fix Committed
Otto Greenslade (otto-chaotic) wrote :

UPDATE: There was an error in one of the RGB values from the comment above!

As ideal default solid background colours:

For Ambiance - Ubuntu Dark Purple - HEX: #2C001E RGB: 44 0 30
For Radiance - Ubuntu Grey - HEX: #AEA79f RGB: 173 167 159

If we can't define separate colours for Ambiance/Radiance I suggest using the Ambiance colour for both:
Ubuntu Dark Purple - HEX: #2C001E RGB: 44 0 30

Mirco Müller (macslow) on 2010-07-15
Changed in unity:
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2010-07-16
Changed in unity:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 0.2.18-0ubuntu1

---------------
unity (0.2.18-0ubuntu1) maverick; urgency=low

  * New upstream release.
    - can't drag and drop item to last position in launcher (LP: #595819)
    - set a solid color as background (LP: #594232)
    - select a place by default (LP: #601020)
    - Support offline shortcuts in quicklist (LP: #595842)
    - keyboard focus in places should default to the search entry (LP: #599888)
    - fix various search issues in places (LP: #600732, #604964)
    - contracted/expanded feature doesn't take mouse position into account
      (LP: #595878)
    - Use X-GNOME-FullName when available for launcher hover text (LP: #594285)
    - SIGSEGV in _clutter_stage_has_full_redraw_queued (LP: #594209)
  * debian/control:
    - bump libclutk-dev build-dep to latest
    - add libdbusmenu-glib-dev, libgnome-desktop-dev and libgnomeui-dev deps
  * add debian/patches/01_add_dbusmenu_glib_vapi.patch:
    - not distribute yet, small fix in the vapi to make a method return an
      unowned variable instead of an owned one
 -- Didier Roche <email address hidden> Fri, 16 Jul 2010 14:48:14 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Shubham Rao (cshubhamrao) wrote :

Setting solid colours doesn't work even today

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers