Ubuntu

Items in submenus not working

Reported by Hernando Torque on 2010-06-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Application Menu Indicator
High
Ted Gould
Unity
High
Jason Smith
mutter
Fix Released
Medium
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: indicator-appmenu

Items in submenus don't seem to respond to clicks. Tested with gnome-terminal, gedit, and gimp within a "Ubuntu Netbook Edition" session.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: indicator-appmenu 0.0.5-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-2.3-generic 2.6.35-rc2
Uname: Linux 2.6.35-2-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Jun 12 08:35:41 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-appmenu

Hernando Torque (htorque) wrote :
description: updated
Omer Akram (om26er) on 2010-06-12
Changed in indicator-appmenu (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

btw the problem is only in Unity session.

Hernando Torque (htorque) wrote :

Yes, thanks. Forgot to test that.

iBART (mogio) wrote :

try to remove-reload-add the Applet AppMenu...

Sebastien Bacher (seb128) wrote :

Confirmed gedit is working using the gnome applet, seems specific to unity

Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Low
Ken VanDine (ken-vandine) wrote :

Using unity, gedit submenus are working for me but gnome-terminal submenus are not.

Jorge O. Castro (jorge) on 2010-06-25
Changed in indicator-appmenu (Ubuntu):
importance: Low → High
Changed in indicator-appmenu:
importance: Undecided → High
status: New → Confirmed
David Barth (dbarth) wrote :

By not working do you mean that they are not responding to clicks? or that they are empty?
For empty sub-menus, please see https://bugs.launchpad.net/bugs/594228

For items not responding to clicks, that's a unity implementation issue then.

Changed in unity:
status: New → Incomplete
Changed in indicator-appmenu:
assignee: nobody → Ted Gould (ted)
Hernando Torque (htorque) wrote :

It's in the bug description. :-)

Submenu items don't get highlighted and don't respond to clicks.

Neil J. Patel (njpatel) wrote :

Hernando, does VLC (or any other KDE app) menus work?

Neil J. Patel (njpatel) wrote :

Nevermind, I can reproduce this :/ Not sure what's going on, definitely a Unity/Mutter issue.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 2010-07-01
status: Incomplete → Confirmed
Hernando Torque (htorque) wrote :

Kate and VLC show the same behavior.

This works using the indicator-applet so it must be a unity issue.

  affects indicator-appmenu
  status invalid

  affects ubuntu/indicator-appmenu
  status invalid

Changed in indicator-appmenu:
status: Confirmed → Invalid
Changed in indicator-appmenu (Ubuntu):
status: Confirmed → Invalid
affects: indicator-appmenu (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Invalid → New
Omer Akram (om26er) on 2010-06-29
Changed in unity (Ubuntu):
status: New → Triaged
Mirco Müller (macslow) on 2010-07-02
Changed in unity:
milestone: 2010-07-01 → 2010-07-08
Neil J. Patel (njpatel) on 2010-07-02
Changed in unity:
assignee: Neil J. Patel (njpatel) → Jason Smith (jassmith)
Changed in mutter:
status: Unknown → New
Neil J. Patel (njpatel) on 2010-07-12
Changed in unity:
milestone: 2010-07-08 → 2010-07-15
Neil J. Patel (njpatel) wrote :

Fixed as part of latest Mutter update

Changed in unity:
status: Confirmed → Invalid
status: Invalid → Fix Released
Neil J. Patel (njpatel) wrote :

(mutter update to maverick and lucid ppa)

Didier Roche (didrocks) on 2010-07-16
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in mutter:
status: New → Fix Released
Changed in mutter:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.