Unity crashes during startup

Bug #592920 reported by Taylor "Ripps" LeMasurier-Wren
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Whenever I try to start Unity, I get a large series of GTK warnings, and then it crashes.
Attached is the gdb backtrace.

Here's the terminal output:
(unity:12505): libunity-private-DEBUG: scroller-controller.vala:79: no desktop file for this app

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
(unity:12505): Indicator-Sound-DEBUG: At start-up attempting to set the image to audio-volume-muted-panel

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Clutter-WARNING **: The actor 'UnityPanelHomeButton' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended

(unity:12505): Clutter-WARNING **: The actor 'UnityPanelView' is currently inside an allocation cycle; calling clutter_actor_queue_relayout() is not recommended
(unity:12505): Indicator-Application-DEBUG: Connected to Application Indicator Service.
(unity:12505): Indicator-Application-DEBUG: Setup proxy signals
(unity:12505): Indicator-Application-DEBUG: Connect to them.
(unity:12505): Indicator-Application-DEBUG: Request current apps
(unity:12505): Indicator-Sound-DEBUG: about to connect to the signals

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
(unity:12505): Indicator-Sound-DEBUG: at the indicator start up and the volume percent returned from dbus method is 30.517578
(unity:12505): Indicator-Sound-DEBUG: at the indicator start up and the MUTE returned from dbus method is 0
(unity:12505): Indicator-Sound-DEBUG: IndicatorSound::fetch_sink_availability_from_dbus -> AVAILABILTY returned from dbus method is 1
(unity:12505): Indicator-Application-DEBUG: Building new application entry: :1.128 with icon: bluetooth-active

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
(unity:12505): Indicator-Application-DEBUG: Building new application entry: :1.6 with icon: gnome-power-manager

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
(unity:12505): Indicator-Application-DEBUG: Appending search path: /usr/share/gnome-power-manager/icons

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
** (unity:12505): DEBUG: Updating username label

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'
** (unity:12505): DEBUG: Using user icon for 'Guest Session' from file: (null)
** (unity:12505): DEBUG: Username width 32px
** (unity:12505): DEBUG: Font size 10.000000 pt
** (unity:12505): DEBUG: Screen DPI 96.000000
** (unity:12505): DEBUG: Username width 2.400000em
** (unity:12505): DEBUG: loading avatar from file /home/ripps/.face
(unity:12505): Indicator-Sound-DEBUG: slider parent changed
(unity:12505): Indicator-Sound-DEBUG: Just caught a style change event

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gtk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gtk/gtkstyle.c:1788: widget class `GtkImage' has no property named `x-ayatana-indicator-dynamic'

(unity:12505): Gdk-WARNING **: /build/buildd/gtk+2.0-2.21.2/gdk/x11/gdkdrawable-x11.c:942 drawable is not a native X11 window

Gdk-ERROR **: The program 'unity' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 681 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: unity 0.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-2.3-generic 2.6.35-rc2
Uname: Linux 2.6.35-2-generic i686
Architecture: i386
Date: Fri Jun 11 22:08:12 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: unity

Revision history for this message
Taylor "Ripps" LeMasurier-Wren (ripps818) wrote :
Revision history for this message
Taylor "Ripps" LeMasurier-Wren (ripps818) wrote :

Here's my glxinfo requested by gord on #ubuntu+1

Revision history for this message
Itxaka Serrano (itxaka) wrote :

Also affects me, attached 2 pictures that shows how unity loads but it's completely blank.
Also attached the terminal output and my glxinfo?field.comment=Also affects me, attached 2 pictures that shows how unity loads but it's completely blank.
Also attached the terminal output and my glxinfo

Revision history for this message
Itxaka Serrano (itxaka) wrote :
Revision history for this message
Itxaka Serrano (itxaka) wrote :
Revision history for this message
Itxaka Serrano (itxaka) wrote :

BTW mine crashes randomly. Sometimes gives me the same error as in the bug description, sometimes it launches and gets blank as shown on the screenshots and on the terminal shows the errors attached.

Linux itxaka-laptop 2.6.35-4-generic #5-Ubuntu SMP Wed Jun 16 20:42:35 UTC 2010 x86_64 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu maverick (development branch)
Release: 10.10
Codename: maverick

Revision history for this message
Taylor "Ripps" LeMasurier-Wren (ripps818) wrote :

I know what the problem is, Unity was written to only allow newer gpus to work. My older radeon 9600 pro (r300) doesn't support GL_ARB_texture_non_power_of_two. So I'm probably never going to be to use Unity.
This is kinda annoying, I understand Unity was designed for Netbooks and their GPUs, but it would be nice if other's were able to try the software as well.

Revision history for this message
Didier Roche (didrocks) wrote :

unity now tells if you can't run it at startup and will logout you nicely

Changed in unity (Ubuntu):
status: New → Fix Released
Changed in unity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers