Unity not starting: compiz-config crashes on login

Bug #1758009 reported by Janghou on 2018-03-22
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After login I end up with an empty desktop, just a wallpaper.

- No panel,
- no dash,
- no window decorations.
- keyboard shortcuts not working.

Unity doesn't seem to start.

Feels like Bug #1741447 , but is less severe. At least Low Graphics Mode is working fine.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.5+16.04.20180221-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-37.42~16.04.1-generic 4.13.13
Uname: Linux 4.13.0-37-generic x86_64
.tmp.unity_support_test.0:

.tmp.unity_support_test.1:

ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Mar 22 10:58:11 2018
DistUpgraded: 2016-04-22 18:36:32,349 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Mobile 4 Series Chipset Integrated Graphics Controller [1025:029b]
   Subsystem: Acer Incorporated [ALI] Mobile 4 Series Chipset Integrated Graphics Controller [1025:029b]
InstallationDate: Installed on 2014-04-18 (1433 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Acer Aspire 1810TZ
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-37-generic root=UUID=86d7d9a6-ffc3-47cb-adc4-68cfcbcadcef ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to xenial on 2016-04-22 (698 days ago)
dmi.bios.date: 08/31/2010
dmi.bios.vendor: INSYDE
dmi.bios.version: v1.3314
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: JM11-MS
dmi.board.vendor: Acer
dmi.board.version: Base Board Version
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDE:bvrv1.3314:bd08/31/2010:svnAcer:pnAspire1810TZ:pvrv1.3314:rvnAcer:rnJM11-MS:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.family: Intel_Mobile
dmi.product.name: Aspire 1810TZ
dmi.product.version: v1.3314
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.12.3+16.04.20180221-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.83-1~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.8-0ubuntu0~16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.8-0ubuntu0~16.04.1
version.xserver-xorg-core: xserver-xorg-core N/A
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Thu Mar 22 10:53:09 2018
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.19.5-0ubuntu2~16.04.1
xserver.video_driver: modeset

Janghou (janghou) wrote :
Janghou (janghou) wrote :

FYI
Apparently more people are affected, a high amount of visitors since March 2018 on this Askubuntu page, describing the same symptoms due to a bug January 2018. #1735594

https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults

This bug has the same symptoms, but is less severe and segfaults in libcompizconfig not compiz:
 kernel: [ 554.941900] compiz-config-p[3736]: segfault at 657461746f72 ip 00007fb7a2350d6f sp 00007fffa4bef830 error 4 in libcompizconfig.so.0.0.0[7fb7a2328000+52000]

Workaround: use low graphics mode, see workaround 3 on the Askubuntu page.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Robert Prije (robprije) wrote :

I think I'm getting the same error

I have 2 accounts on this computer.

This morning my wife logged in to hers and immediately received the error "Ubuntu 16.04 has experienced an internal error". It referenced the executable path /usr/lib/x86_64-linux-gnu/unity/compiz-config-profile-setter. Since then her login receives no errors but continues to show only the desktop image with no panel or windows.

I am still able to login and function just fine under my own login.

Attached the associated crash file.

Robert Prije (robprije) wrote :

I resolved the problem for myself.

I searched for compiz related files in my wife's home directory and found .config/compiz-1/compizconfig/config

In there, she had a config resembling the following:

[general_ubuntu]
profile = unity-lowgfx

I, on the other hand, had a config like this:

[general_ubuntu]
profile = unity

I changed her config to match mine and logged her back in and it was fixed.

I note others complaining of similar errors found that switching *to* low GFX fixed the errors for them prior to a patch hitting upstream.

I don't know how my wife got the lowgfx config while I didn't. Neither of us have manually messed with these configs in the past. Both our systems were working fine yesterday (23 March UTC+8).

Janghou (janghou) wrote :

Guest session is also working here in default graphics mode, so it's probably a regression that just occurs with a certain Compiz settings or plugin.

mak berlin (8-mak) wrote :

hi all,
I've the same problem, guest-user is okay, but my profile has the problem.
I
* moved my .config to backup
* upgraded everything (Upgrade: unity-control-center-faces:amd64 (15.04.0+16.04.20170214-0ubuntu2, 15.04.0+16.04.20171130-0ubuntu1), unity-control-center:amd64 (15.04.0+16.04.20170214-0ubuntu2, 15.04.0+16.04.20171130-0ubuntu1), libunity-control-center1:amd64 (15.04.0+16.04.20170214-0ubuntu2, 15.04.0+16.04.20171130-0ubuntu1))
* tested with unity --reset-icons
* test with lowgfx /.config/upstart/lowgfx.conf
* .config/compiz-1/compizconfig/config: profile = unity
* unity-tweak-tool
* ppa: paulo-miguel-dias / pkppa

guestuser and creating new user: no problem
nothing helps...

Janghou (janghou) wrote :

@mak. You mean low -graphics mode is not working for you?

You need to logout/reboot.

mak berlin (8-mak) wrote :

@janghou: yes, i mean low-graphics. and yes: after every step i rebooted the system ;)

Janghou (janghou) wrote :

@mak, strange, I asked because I do wonder whether it's the same bug.

Val (vk1266) wrote :

@robprije: your suggested workaround in your post #5 above has fixed the problem for me. Thank you! I had the same symptoms on my workstation, and here is the relevant error message from syslog:

kernel: [ 1161.995672] compiz-config-p[11373]: segfault at 0 ip 00007fb3e82d6d6f sp 00007ffdb86ee480 error 4 in libcompizconfig.so.0.0.0[7fb3e82ae000+52000]

Momchil Georgiev (m0mchil) wrote :

I can also confirm the workaround in post #5 worked for me. Same symptoms with segfault in libcompizconfig.

Jürgen Gasda (jgasda) wrote :

Post #5 worked for me too.

Janghou (janghou) wrote :

At first solution 5 did not work for me. A prerequisite I guess is that you have to remove lowgfx.conf file before, not just comment it out. Otherwise any change in .config/compiz-1/compizconfig/config will be overwritten back to profile = unity-lowgfx.

rm ~/.config/upstart/lowgfx.conf
sed -i 's/-lowgfx//' ~/.config/compiz-1/compizconfig/config

I guess post #5 is not a workaround but the fix. Thx @robprije.

Working for you @mak?

RadekZ (radekz321) wrote :

Hi all,
I have this problem too but in
.config/compiz-1/compizconfig/config
i have

[general_ubuntu]
profile = unity

and i think i do not have proposal updates, but i'm not sure

Marco F (markfu) wrote :

The (mutually exclusive) solutions lowgfx.conf startup and profile = unity in compizconfig/config did not work for me.

I tried what @8-mak tried and also a bunch more stuff (restart/reinstall ubuntu-desktop and components).

Might be a different bug, but still appeared after the March updates. Launcher and panel only in guest session, still cannot find this different setting in the main admin profile which makes it fail to launch.

Thank you all for your help though.

Janghou (janghou) wrote :

@Marco, #5 did not work for me at first, but it did the later (?!?).

just be sure `profile = unity` just before you reboot, it did change back on my machine.

What I also did: clean/delete ~/.cache directory.

Marco F (markfu) wrote :

Yep,

I had to clean the cache.

Thank you a lot Janghou and everyone else.

mak berlin (8-mak) wrote :

@Janghou: thank you, cleaning the cache helps!

Only doing `mv ~/.config ~/.config-BACK` fixed the issue for me.

nbn (nbnamp) wrote :

h,
steps/workarounds listed on: https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults

did not work for me, I'm using ubuntu 16.04 on virtualbox, my problem was fixed by increasing VM Display setting ( Video Memory ) from 16MB to at least 32MB.

Aurosutru (2fullnesses) wrote :

Post #20 worked for me. Thanks Ruslan. Had to move important config files back into .config later. Nothing else I tried worked after searching forums for hours and trying their suggestions.

Why didn't Ubuntu issue an improvement to the offending software that it provided in a routine update? This sort of major meltdown occurred in 2016 in my 14.04 system, just before 16.04 was to be released. Is there a connection? Are the best developers busy with the new releases, which are supposed to take care of such problems? If so, then the LTS versions are really only good for 2 years, not the stated 5 years.

Carles Ferrer (carlesfp) wrote :

I also tried several of the solutions proposed here and in askubuntu, but only # 20 worked for me.
Indeed, it is not necessary to delete the entire .config directory. Just move the compiz subdirectory: '$ mv ~/.config/compiz-1 backup/'

Thanks everyone for your help.

Had the same issue (after an apt-get dist-upgrade after at least a month since the last time I upgraded). Comment #5 solved the issue for me. Surprisingly, I didn't even need to restart.

Anthony Wong (anthonywong) wrote :

Had this issue, fixed by updating .config/compiz-1/compizconfig as in comment #5.

Cs-gon (cs-gon) wrote :

I think I found the root cause for the compiz-config-profile-setter segfault. The call "ccsFreeContext(context);" in line 218 in compiz_config_profile_setter.c frees the context object while background event processing still uses the object, which then leads to the segfault.

It seems the set_compiz_profile() call returns while a value-changed callback gets called in the background, which then calls ccsObjectGetInterface_() on the context object, but by then the context object already got destroyed.

I think the best way so solve this, would be to wait for the event processing to finish before freeing the context object, but I don't know how to do that properly. But not freeing the context object in compiz_config_profile_setter.c fixes the problem for me (the cssFreeContext() is called right before the compiz-config-profile-setter exits, so I think it doesn't really matter much). So
 with this patch the memory gets freed on exiting of the program after the main loop has stopped.

tags: added: patch

The attachment "compiz-config-profile-setter_segfault.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

To post a comment you must log in.