unity panel service error: system crashes/unresponsive on every panel buttons click

Bug #1746590 reported by Jefferson Ferreira-Ferreira on 2018-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Since more or less a month ago I experienced OS crashes when clicking any panel button (calendar, volume, battery, etc). Only the mouse pointer still moves, but the system becomes totally unresponsive so I have to force power-off. I checked my syslog and the message before the power-off was:

Jan 16 14:13:07 jeco-pc kernel: [18048.538695] unity-panel-ser[1871]: segfault at 1ac32 ip 0000000000406ea9 sp 00007ffeedafe0a0 error 4 in unity-panel-service[400000+12000].

I thought it was a similar issue as reported in https://askubuntu.com/questions/992571/gui-unity-crashing-in-16-04-lts-after-updates-2018-01-04-compiz-segfaults. So I followed instructions and installed libgl1-mesa-dri from xenial-proposed. After that, the system worked well for a few days and then again presented the same problem.

I checked my syslog again and the message was:

Jan 17 09:38:12 jeco-pc kernel: [ 2911.154812] traps: unity-panel-ser[1994] general protection ip:406ea9 sp:7ffc881ee780 error:0 in unity-panel-service[400000+12000].

Following instructions posted in the question #663175 in launchpad, I ran an apt-get dist-upgrade. After that, the system worked well for one day. But now, the problem returned with the log:

Jan 31 15:56:19 jeco-pc kernel: [ 3005.862110] unity-panel-ser[2200]: segfault at 61 ip 0000000000406ea0 sp 00007ffce922d1c0 error 4 in unity-panel-service[400000+12000]

Again, any click on a panel button means a system crash and a forced power-off.

More information can be found in https://pastebin.ubuntu.com/26488967/

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160906-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-112.135-generic 4.4.98
Uname: Linux 4.4.0-112-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Wed Jan 31 17:47:16 2018
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Haswell-ULT Integrated Graphics Controller [1028:0616]
   Subsystem: Dell GK208M [GeForce GT 740M] [1028:0616]
InstallationDate: Installed on 2016-05-16 (624 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: Dell Inc. Vostro 5470
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-112-generic.efi.signed root=UUID=75874219-4115-44d2-9a4b-c423e64f30ff ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/05/2015
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0K0PF0
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd11/05/2015:svnDellInc.:pnVostro5470:pvr:rvnDellInc.:rn0K0PF0:rvrA00:cvnDellInc.:ct8:cvr0.1:
dmi.product.name: Vostro 5470
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.83-1~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu1~16.04.4
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Wed Jan 31 15:58:20 2018
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 4156
 vendor AUO
xserver.version: 2:1.18.4-0ubuntu0.7

To post a comment you must log in.