Alt+Printscreen not working (doesn't generate keypress event)

Bug #1732612 reported by manfreed on 2017-11-16
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Since I have upgraded to Ubuntu 17.10 Alt+PrintScreen doesn't work on my computer. I'm using Unity DE, with default settings.

The problem is not about taking screnshots.

xev recognizes when I press down the alt key, but nothing happens when I press Print Screen with alt being pressed (it does when PrintScreen is pressed by itself)

Here is evtest output when I press Alt+Printscreen:

# Alt pressed down:
Event: time 1510817663.883489, -------------- SYN_REPORT ------------
Event: time 1510817663.923476, type 1 (EV_KEY), code 56 (KEY_LEFTALT), value 2
Event: time 1510817663.923476, -------------- SYN_REPORT ------------
Event: time 1510817663.963479, type 1 (EV_KEY), code 56 (KEY_LEFTALT), value 2
Event: time 1510817663.963479, -------------- SYN_REPORT ------------
Event: time 1510817663.993036, type 4 (EV_MSC), code 4 (MSC_SCAN), value 70046

# Print screen pressed
Event: time 1510817663.993036, -------------- SYN_REPORT ------------
Event: time 1510817664.945032, type 1 (EV_KEY), code 56 (KEY_LEFTALT), value 0

# Alt released
Event: time 1510817664.945032, -------------- SYN_REPORT ------------
Event: time 1510817664.945086, type 1 (EV_KEY), code 56 (KEY_LEFTALT), value 1
Event: time 1510817664.945086, type 1 (EV_KEY), code 99 (KEY_SYSRQ), value 1
Event: time 1510817664.945086, -------------- SYN_REPORT ------------
Event: time 1510817664.945097, type 1 (EV_KEY), code 99 (KEY_SYSRQ), value 0
Event: time 1510817664.945097, type 1 (EV_KEY), code 56 (KEY_LEFTALT), value 0
Event: time 1510817664.945097, -------------- SYN_REPORT ------------

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: udev 234-2ubuntu12.1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
CustomUdevRuleFiles: 67-xorg-wizardpen.rules 99-displaylink.rules 60-vboxdrv.rules 70-snap.core.rules 99-anbox.rules
Date: Thu Nov 16 08:29:46 2017
InstallationDate: Installed on 2017-03-26 (234 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Beta amd64 (20170321)
MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.13.0-16-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
SourcePackage: systemd
UpgradeStatus: Upgraded to artful on 2017-10-23 (23 days ago)
dmi.bios.date: 10/24/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: F1
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z77-HD3
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF1:bd10/24/2012:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ77-HD3:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

manfreed (manfreed) wrote :
Dimitri John Ledkov (xnox) wrote :

Not sure how any of this helps, I would require somebody with graphics/keyboard stack to understand what/where has regressed.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Changed in systemd (Ubuntu):
status: New → Confirmed

On my Unity session on 17.10 printscreen doesn't work, neither does ALT+Printscreen (it triggers HUD), nor CTRL+ALT+T to open terminal. Seems a bunch of them don't work.

affects: gnome-shell (Ubuntu) → unity (Ubuntu)
manfreed (manfreed) wrote :

Alan Pope:

I did have a similar issue where most of the usual hotkeys wouldn't work, but that was caused me screwing around in gnome settings and it was solved by resetting my profile.

I believe this issue is different than that.

Daniel van Vugt (vanvugt) wrote :

@popey, have a look at bug 1707828. It shows Ctrl+Alt+T not working due to DBus timeouts and GSD problems. Quite possibly other key combos like Alt+PrtScn could suffer a similar fate.

Khurshid Alam (khurshid-alam) wrote :

There is also this bug 1683383, not sure if it is related. But lots key shortcuts problems started to arrive after Ubuntu removed 6 year old patch from xorg.

For me, Ctrl+Alt+T works fine though. Only Alt++Fn+Print-screen doesn't work.

ventrical (dale-f-beaudoin) wrote :

@ khurshid

All my 18.04 unity7 installs have Alt+Printscreen comming up with screenshot. Also standalone Printscreen. You just have to hold the key down just a bit longer than usual , then release and screenshot will come up.

Ctrl+alt+T also comes up with terminal . You have to wait and hold the macro down for a bit longer. 1/2 sec? and it will come up. it must be a bug of some sort then.

Also installed mac4mans ppa for nemo and works fine on that also. I am using the ppa from the unity7maintainers page.

Note_ I am using the ISO I built on Nov.23rd/2017 fully updated current.

Khurshid Alam (khurshid-alam) wrote :

Workaround (1):

press and hold Print Screen
press and hold Alt
release Print Screen (and then Alt)

This seemed to work for me, but it shouldn’t be necessary.

Workaround (2) For Laptops if Printscreen is combined with Sysreq:

sudo sysctl -w kernel.sysrq=1 #disables magic sysreq for that session.

Press Alt+Printscreen or Alt+Fn+Printscreen (first Alt, then Fn).

Luis Alberto Pabón (copong) wrote :

This workaround works for me, but years of muscle memory...

Same problem here, and workaround in #10 NOT working.
I confirm the OP's analysis: ALT+PrintScreen does not generate a keyboard event. Other Keystrokes (ALT alone, PrintScreen alone) do.

Addition: This is in Unity. On the GNOME desktop everything seems to work as expected.

Oh, I there's a typo in comment #10:
Workaround (2) should be

sudo sysctl -w kernel.sysrq=0

not =1.

This makes ALT+PrintScreen work for me for this session. So the problem really is that PrintScreen also works as SysReq on Laptops. But strangely, this was never a problem before? What has changed in 17.10?

manfreed (manfreed) wrote :

#14: Thanks, that helped even though I'm not on a laptop. Your question is valid, something must have changed that caused this issue and even though your solution helps a proper fix is still needed.

Luis Alberto Pabón (copong) wrote :

Indeed disabling sysrq seems to fix the problem, but this has worked for donkey's ages so what exactly changed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers