system automatically switched to lower resolution of 800x600 from 1920x1080 and only showing display in this (800x600) resolution after purging nvidia graphics

Bug #1691987 reported by Nikhil Singh on 2017-05-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

First of all, I am not sure whether this is a bug or not, but I tried several times to set addmode (1920x1080) in xrandr. Never happened.

So, I simply tried creating a new mode using 10-monitor.conf and restarted my system, it started showing blank screen.

I checked askubuntu forum and purged nvidia-*, after that it starting showing me display but in 800x600 resolution. I tried adding 1920x1090 again but no luck.

The error while adding mode is `xrandr: Failed to get size of gamma for output default`
and I am not using `sudo xrandr`, I am simply using this command `xrandr --addmode default 1920x1080`

Kindly suggest the resolution.

Thanks

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160906-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
Uname: Linux 4.4.0-78-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.1-0ubuntu2.5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri May 19 15:19:11 2017
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.4.0-71-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-72-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-75-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-78-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation Device [10de:1c03] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:85a4]
GsettingsChanges:
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'snap', 'vpswitch', 'regex', 'grid', 'wall', 'compiztoolbox', 'place', 'mousepoll', 'move', 'copytex', 'workarounds', 'resize', 'imgpng', 'fade', 'session', 'expo', 'unitymtgrabhandles', 'scale', 'ezoom', 'unityshell']"
 b'com.canonical.Unity' b'minimize-count' b'69'
 b'com.ubuntu.user-interface' b'scale-factor' b"{'DVI-D-0': 8, 'default': 8}"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'scaling-factor' b'uint32 1'
InstallationDate: Installed on 2017-03-15 (64 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: MSI MS-7885
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-78-generic root=UUID=3c1d60af-0459-4480-90af-3c95413c402a ro plymouth:debug drm.debug=0xe
Renderer: Software
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/15/2016
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.D0
dmi.board.asset.tag: Default string
dmi.board.name: X99A SLI PLUS(MS-7885)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.D0:bd07/15/2016:svnMSI:pnMS-7885:pvr1.0:rvnMSI:rnX99ASLIPLUS(MS-7885):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7885
dmi.product.version: 1.0
dmi.sys.vendor: MSI
version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.70-1~ubuntu16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 12.0.6-0ubuntu0.16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 12.0.6-0ubuntu0.16.04.1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1.2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Fri May 19 15:08:17 2017
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Logitech USB Keyboard KEYBOARD, id 8
 input Logitech USB Keyboard KEYBOARD, id 9
 input Logitech USB Optical Mouse MOUSE, id 10
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.4-0ubuntu0.2

Nikhil Singh (nikhilsingh) wrote :
To post a comment you must log in.