Heavy corruption in launcher icons on XPS 13 (Dell XPS 13 9350) running Xenial 16.04.1

Bug #1625498 reported by Taihsiang Ho on 2016-09-20
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Dell Sputnik
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Dell XPS 13 9350 - Dino 2 SKL (CID 201508-18805)
Ubuntu 16.04.1

[Steps to Reproduce]
1. Install Ubuntu 16.04.1 by USB on this machine.
2. Installed. Get ready to use the desktop.

[Expected Result]
Unity launcher icons look good.

[Actual Result]
Unity launcher icons broke. They are shown as the screen shot attachment.

However, the behavior of the icons seem to work well when trying to click them.

---------------------------

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160715-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Sep 20 15:53:40 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Sky Lake Integrated Graphics [8086:1926] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Dell Skylake Integrated Graphics [1028:0704]
GsettingsChanges:
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'place', 'vpswitch', 'wall', 'copytex', 'regex', 'grid', 'imgpng', 'resize', 'unitymtgrabhandles', 'compiztoolbox', 'snap', 'mousepoll', 'commands', 'move', 'session', 'animation', 'workarounds', 'fade', 'expo', 'scale', 'ezoom', 'unityshell']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'scaling-factor' b'uint32 1'
InstallationDate: Installed on 2016-09-20 (0 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 0bda:5682 Realtek Semiconductor Corp.
 Bus 001 Device 003: ID 04f3:20d0 Elan Microelectronics Corp.
 Bus 001 Device 002: ID 8087:0a2b Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. XPS 13 9350
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-31-generic.efi.signed root=UUID=c0711644-9aa7-44d6-8c6a-23aea5957fcd ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/08/2016
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.2.3
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.2.3:bd01/08/2016:svnDellInc.:pnXPS139350:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct9:cvr:
dmi.product.name: XPS 13 9350
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Tue Sep 20 15:42:01 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 5194
 vendor SHP
xserver.version: 2:1.18.3-1ubuntu2.2

Taihsiang Ho (taihsiangho) wrote :
Taihsiang Ho (taihsiangho) wrote :

The screen shot of the broken launcher icons.

summary: - Launcher icons broke on XPS 13 running Xenial 16.04.1
+ Launcher icons broke on XPS 13 (Dell XPS 13 9350) running Xenial 16.04.1
description: updated

I updated the system to use kernel 4.4.0-68, and I did not resolve this issue.

Ara Pulido (ara) on 2016-09-21
tags: added: nplusone
summary: - Launcher icons broke on XPS 13 (Dell XPS 13 9350) running Xenial 16.04.1
+ Heavy corruption in launcher icons on XPS 13 (Dell XPS 13 9350) running
+ Xenial 16.04.1
Changed in unity (Ubuntu):
importance: Undecided → High
affects: unity → dell-sputnik

This isn't a Dell-specific issue. It should be a Unity or Intel graphics issue.

Changed in dell-sputnik:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers