Compiz hogging CPU when screen off

Bug #1605180 reported by Michał Sawicz on 2016-07-21
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Andrea Azzarone
Xenial
Undecided
Unassigned

Bug Description

[Impact]
My CPU is constantly hogged @ around 15% by Compiz when the screen is off. Just waking the screen up is enough for the usage to go down again.

[Test case]
1. Lock unity and wait for the screensaver to start
2. log in to your machine using SSH
3. Check the compiz CPU usage using 'top' or similar

[Regression potential]
Lockscreen view could not be updated (damaged) correctly

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160715-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
BootLog: Scanning for Btrfs filesystems
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Thu Jul 21 12:34:21 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus: virtualbox, 5.0.24, 4.4.0-31-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Dell Haswell-ULT Integrated Graphics Controller [1028:05e3]
InstallationDate: Installed on 2016-05-06 (75 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: Dell Inc. XPS 12-9Q33
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-31-generic.efi.signed root=ZFS=/root ro root=ZFS=username-laptop/root quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/15/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: XPS 12-9Q33
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: Not Specified
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd04/15/2014:svnDellInc.:pnXPS12-9Q33:pvrA06:rvnDellInc.:rnXPS12-9Q33:rvrA06:cvnDellInc.:ct8:cvrNotSpecified:
dmi.product.name: XPS 12-9Q33
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.12.2+16.04.20160714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2.1~overlay1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.1~overlay1
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.3~overlay1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Wed Jul 20 11:16:11 2016
xserver.configfile: default
xserver.errors: SynPS/2 Synaptics TouchPad: Read error 19
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 1021
 vendor LGD
xserver.version: 2:1.18.3-1ubuntu2.2

Related branches

Michał Sawicz (saviq) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
tags: added: desktop-trello-import
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
tags: removed: desktop-trello-import
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+16.10.20160727-0ubuntu1

---------------
unity (7.5.0+16.10.20160727-0ubuntu1) yakkety; urgency=medium

  [ Andrea Azzarone ]
  * [LockSceen] Remove numlock warning. (LP: #1526322)
  * Make sure initiate and terminate callbacks are not empty before
    calling them. (LP: #1605012)
  * Properly destroy close_button_ to properly disconnect lambda. (LP:
    #1605010)
  * Use the standard notification-device-eject in the "device eject"
    notification. This allows us to scale it properly on high-dpi
    setups. (LP: #1605231)
  * Add tools to enforce unityshell plugin for the current profile and
    add "move" and "resize" plugins as requirements. (LP: #1506023,
    #1605007)
  * When locked discard damages from windows below lockscreen. (LP:
    #1605180)

  [ Eleni Maria Stea ]
  * DecoratedWindow: Added shadows for shaped windows

  [ Marco Trevisan (Treviño) ]
  * LockScreenAcceleratorController: ensure callbacks are valid before
    calling them (LP: #1605012)
  * DecoratedWindow: Cleanup shadows for shaped windows, reduce
    recomputation

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 27 Jul 2016 10:25:54 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello Michał, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.0+16.04.20160906-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Michał Sawicz (saviq) wrote :

 LANG=C apt policy compiz
compiz:
  Installed: 1:0.9.12.2+16.04.20160823-0ubuntu1

It does seem to fix the issue, thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160906-0ubuntu1

---------------
unity (7.4.0+16.04.20160906-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * SwitcherView: always disable animations when in lowgfx mode (LP:
    #1602784)

  [ Andrea Azzarone ]
  * When locked discard damages from windows below lockscreen. (LP:
    #1605180)
  * DecoratedWindow: display unmaximize button if the window is
    vertically or horizontally maximized (LP: #1608480)
  * Make sure the switcher detail view is properly scaled. Also scale
    the xy_offset to make sure the switcher and launcher do not overlap.
    (LP: #1605256)
  * Close session dialog on first ESC. (LP: #1521116)
  * Filter out scrolling envents for FilterExpanderLabel. (LP: #1604632)
  * Disable menu discovery animation if MenusDiscoveryDuration is 0.
    (LP: #942962)
  * Redraw fake decorations on window resize. (LP: #940470)
  * Use compiz::Window::serverNext instead of compiz::Window::next in
    IsWindowObscured as the latter can be outdated just after
    scale/spread terminates. (LP: #1614116)

  [ Marco Trevisan (Treviño) ]
  * DecoratedWindow: avoid deferencing an invalid shadow texture ptr,
    and split functions (LP: #1608464)
  * DecoratedWindow: display unmaximize button if the window is
    vertically or horizontally maximized (LP: #1608480)
  * DecorationsForceQuitDialog: make CSS selectors work with gtk 3.20
  * UserAuthenticatorPam: ensure pam_handle_ is null initialized and
    don't proceed if not set (LP: #1611668)
  * DecorationStyle: set css name for Gtk 3.20
  * OverlayRenderer: properly decorate launcher/panel when the launcher
    is at the bottom (LP: #1611694)
  * OverlayRenderer: don't use rotated textures, just rotate them at
    rendering time
  * SpreadWidgets: add container for spread filter and new spread
    decorations (LP: #1283314)
  * WindowButton: properly partially unmaximize a window when
    middle/left clicking in the restore button (LP: #1616136)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 06 Sep 2016 23:17:39 +0000

Changed in unity (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers