[Regression] Unity shows blank desktop with software renderer

Bug #1604657 reported by Luke Granlund on 2016-07-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Critical
William Hughes
Xenial
Critical
Unassigned

Bug Description

[Summary]
Ubuntu 16.04 LTS shows blank desktop under software renderer (llvmpipe) after updates to improve low graphics mode. (LP: #1598770)

[Expected]
Unity Desktop

[Actual]
Unity wallpaper and not much else. Launcher and panel missing, windows are immobile, no task switching. Right-click context menu works and can open terminal.

[Additional]
Observed on Ubuntu guest VM running on Windows 10 Pro host (Hyper-V). Resetting unity and compiz settings doesn't seem effective. The problem occurs whether low graphics mode is enabled in CCSM or not.

Problem appeared after completing following update
--------------------------------------------------
Changes for libunity-core-6.0-9 versions:
Installed version: 7.4.0+16.04.20160526.1-0ubuntu1
Available version: 7.4.0+16.04.20160715-0ubuntu1

Changes for unity-settings-daemon versions:
Installed version: 15.04.1+16.04.20160209-0ubuntu2
Available version: 15.04.1+16.04.20160701-0ubuntu1

Changes for libunity-settings-daemon1 versions:
Installed version: 15.04.1+16.04.20160209-0ubuntu2
Available version: 15.04.1+16.04.20160701-0ubuntu1

Changes for unity versions:
Installed version: 7.4.0+16.04.20160526.1-0ubuntu1
Available version: 7.4.0+16.04.20160715-0ubuntu1

Changes for unity-schemas versions:
Installed version: 7.4.0+16.04.20160526.1-0ubuntu1
Available version: 7.4.0+16.04.20160715-0ubuntu1

Changes for unity-services versions:
Installed version: 7.4.0+16.04.20160526.1-0ubuntu1
Available version: 7.4.0+16.04.20160715-0ubuntu1

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160715-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
.tmp.unity_support_test.1:

ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Jul 19 22:35:43 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:

GsettingsChanges:
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'resize', 'compiztoolbox', 'regex', 'move', 'grid', 'place', 'snap', 'wall', 'imgpng', 'copytex', 'mousepoll', 'vpswitch', 'commands', 'animation', 'unitymtgrabhandles', 'expo', 'session', 'fade', 'workarounds', 'ezoom', 'scale', 'unityshell']"
 b'com.canonical.Unity' b'minimize-count' b'19'
 b'com.ubuntu.user-interface' b'scale-factor' b"{'default': 8}"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'scaling-factor' b'uint32 1'
InstallationDate: Installed on 2016-04-25 (85 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
Lspci:

Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: Microsoft Corporation Virtual Machine
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-31-generic.efi.signed root=UUID=8b0b0ff2-67f8-496f-b77b-7a50811fe8bf ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/26/2012
dmi.bios.vendor: Microsoft Corporation
dmi.bios.version: Hyper-V UEFI Release v1.0
dmi.board.asset.tag: None
dmi.board.name: Virtual Machine
dmi.board.vendor: Microsoft Corporation
dmi.board.version: Hyper-V UEFI Release v1.0
dmi.chassis.asset.tag: 3900-4772-8270-5512-4576-1749-75
dmi.chassis.type: 3
dmi.chassis.vendor: Microsoft Corporation
dmi.chassis.version: Hyper-V UEFI Release v1.0
dmi.modalias: dmi:bvnMicrosoftCorporation:bvrHyper-VUEFIReleasev1.0:bd11/26/2012:svnMicrosoftCorporation:pnVirtualMachine:pvrHyper-VUEFIReleasev1.0:rvnMicrosoftCorporation:rnVirtualMachine:rvrHyper-VUEFIReleasev1.0:cvnMicrosoftCorporation:ct3:cvrHyper-VUEFIReleasev1.0:
dmi.product.name: Virtual Machine
dmi.product.version: Hyper-V UEFI Release v1.0
dmi.sys.vendor: Microsoft Corporation
version.compiz: compiz 1:0.9.12.2+16.04.20160526-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Tue Jul 19 22:35:01 2016
xserver.configfile: default
xserver.devices:
 input Microsoft Vmbus HID-compliant Mouse TOUCHSCREEN, id 6
 input AT Translated Set 2 keyboard KEYBOARD, id 7
xserver.errors:
 open /dev/dri/card0: No such file or directory
 AIGLX: reverting to software rendering
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu2.2

Related branches

Luke Granlund (ainamacar) wrote :
description: updated
Steve Langasek (vorlon) on 2016-07-20
Changed in unity (Ubuntu):
importance: Undecided → Critical

It seems unity is not runing at all, isn't it?

Is there anything in /var/crashes/ mentioning compiz?

Also what's in ~/.cache/upstart/unity7.log

Luke Granlund (ainamacar) wrote :

If Unity is running it's being very shy. I have the same problem on a different machine using a VM cloned from this one several weeks ago. A VM with a fresh install of 16.04 LTS works fine with the new packages for me, so perhaps this is a unique configuration issue. However, other than experimenting with launcher placement and turning low graphics on/off I haven't tweaked Unity settings to my recollection. I've noticed that CCSM when run from console (DISPLAY=:0 ccsm &) appears to hang at "Loading icons...", which may point in the right direction.

I have Hyper-V checkpoints immediately before and after installing the packages that break things for me, so I should be able to investigate any before/after question that might help.

To answer your specific questions, there are no dumps in /var/crash. I've attached before (working) and after (non-working) unity7 logs. I've generated them by restarting the VM from the aforementioned states and logging on, so the times in the logs might look inconsistent.

Luke Granlund (ainamacar) wrote :

The after (non-working) log.

Luke Granlund (ainamacar) wrote :

Having a chance to look at things more closely, Unity definitely appears to be running. (By this I mean compiz started with the Unity plugin, and unity-panel-service is running.) Running unity from the command-line stops and restarts everything, but the desktop remains blank.

However, running unity -v (according to the source for unity.cmake this calls compiz with --debug) *does* restore things. I've also gotten a desktop by running compiz --replace. Issues persist upon rebooting, however. As previously mentioned, this includes steps like deleting .cache and .config, resetting things in dconf, and other standard workarounds for blank desktop issues. I also tried purging and reinstalling essentially the entire graphical stack, without success. That suggests the issues might be with the default settings, yet they don't show up on a fresh 16.04 installation on the same platform.

I'm stumped and migrating to fresh VMs. I'll keep a copy of the troublesome VM around for a few months in case the issue is confirmed or someone has a bright idea.

georg (georg-g) wrote :

I can confirm the issue, same happens here:

* Ubuntu 16.04 64 Bit running in a VirtualBox under Windows 7
* after upgrade of libunity-core the launcher and panels are missing
* the unity daemons are running
* it isn't related to any user settings, I also reproduced it with a new user and empty home directory
* starting ``unity -v`` brings back the panel and launcher temporarily

These are the packages after which installation things broke (apt history log):

Upgrade: unity-schemas:amd64 (7.4.0+16.04.20160526.1-0ubuntu1, 7.4.0+16.04.20160715-0ubuntu1), libunity-protocol-private0:amd64 (7.1.4+15.10.20151002-0ubuntu2, 7.1.4+16.04.20160701-0ubuntu1), unity:amd64 (7.4.0+16.04.20160526.1-0ubuntu1, 7.4.0+16.04.20160715-0ubuntu1), unity-services:amd64 (7.4.0+16.04.20160526.1-0ubuntu1, 7.4.0+16.04.20160715-0ubuntu1), libunity-core-6.0-9:amd64 (7.4.0+16.04.20160526.1-0ubuntu1, 7.4.0+16.04.20160715-0ubuntu1), libunity9:amd64 (7.1.4+15.10.20151002-0ubuntu2, 7.1.4+16.04.20160701-0ubuntu1)

Please let me know if you need additional logs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello Luke, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.0+16.04.20160801.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Luke Granlund (ainamacar) wrote :

I have tested the proposed packages with success on VM snapshots from both before and after the issue originally occurred.

I believe I've also tracked down the source of the problem to failing to upgrade Compiz from "1:0.9.12.2+16.04.20160526-0ubuntu1" to "1:0.9.12.2+16.04.20160714-0ubuntu1" when Unity was upgraded to "7.4.0+16.04.20160715-0ubuntu1" (both address low graphics settings) even though they were published simultaneously. This is most likely due to phased updates in Software Updater and the fact that the Unity update doesn't appear to list the Compiz one as a dependency. In fact, http://people.canonical.com/~ubuntu-archive/phased-updates.html reports that this Compiz update is currently being withheld by Software Updater due to crashes, while the Unity update is fully rolled out. This possibly explains why I saw the issue on an existing VM but not on a fresh one.

Proposed packages installed:
libunity-core-6.0-9/xenial-proposed 7.4.0+16.04.20160801.2-0ubuntu1
unity/xenial-proposed 7.4.0+16.04.20160801.2-0ubuntu1
unity-schemas/xenial-proposed 7.4.0+16.04.20160801.2-0ubuntu1
unity-services/xenial-proposed 7.4.0+16.04.20160801.2-0ubuntu1

Here are the sequences of updates I applied in testing.

1. Non-working VM -> Upgrade all packages in xenial-updates with apt-get (still non-working) -> The proposed updates (Working)
Comment: The problem originally appeared after a Unity update in Software updater where unity, but not compiz, was upgraded. Desktop appeared after upgrading to proposed, but I had to re-enable several Unity plugins to avoid annoyances. For example, the "Grid", "Place Windows", and "Snapping Windows" plug-ins, which according to CCSM were all enabled before the proposed update, were disabled after it. There may or may not have been other changes, these were just the ones I noticed, and perhaps this behavior is expected.

2. VM prior to broken update -> Upgrade all packages in xenial-updates with apt-get (working) -> Upgrade to proposed updates (Still working)
Comments: Here unity and compiz are simultaneously upgraded to their mid-July versions and the problem I experienced never occurs in the first place. The proposed update doesn't appear to break anything.

3. VM prior to broken update -> Upgrade unity and compiz (and no other packages) to most recent in xenial-updates (working)
Comments: Basically as 2, but strongly suggests that May compiz package is causing the issue with mid-July unity.

4. Non-working VM -> Upgrade just compiz to most recent package in xenial-updates -> Create new user (works)
Comments: Unity seems to work with a new user, but I wasn't able to repair the existing user's account without installing the proposed packages.

Taken together I think that using Unity 7.4.0+16.04.20160715-0ubuntu1 with Compiz 1:0.9.12.2+16.04.20160526-0ubuntu1 is almost certainly the cause of the issue.

No matter the original cause, the proposed 7.4.0+16.04.20160801.2-0ubuntu1 updates restored functionality (with the minor caveats discussed in point 1) to the non-working VM, and didn't break a working one.

tags: added: verification-done
removed: verification-needed
Changed in unity (Ubuntu Xenial):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160801.2-0ubuntu1

---------------
unity (7.4.0+16.04.20160801.2-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * FileManagerLauncherIcon: Don't trust the Quirk::VISIBLE in the ctor.
    (LP: #1599133)
  * [TrashLauncherIcon] Create GFileMonitor in an idle to avoid blocking
    calls. (LP: #1602720)
  * [LockSceen] Remove numlock warning. (LP: #1526322)
  * Make sure initiate and terminate callbacks are not empty before
    calling them. (LP: #1605012)
  * Properly destroy close_button_ to properly disconnect lambda. (LP:
    #1605010)
  * Use the standard notification-device-eject in the "device eject"
    notification. This allows us to scale it properly on high-dpi
    setups. (LP: #1605231)
  * Add tools to enforce unityshell plugin for the current profile and
    add "move" and "resize" plugins as requirements. (LP: #1506023, LP:
    #1605007, LP: #1604657)

  [ Marco Trevisan (Treviño) ]
  * Unity script: use result from unity_support_test to check the right
    COMPIZ_CONFIG_PROFILE to use (LP: #1602377)
  * LockScreenAcceleratorController: ensure callbacks are valid before
    calling them (LP: #1605012)

  [ Eleni Maria Stea ]
  * DecoratedWindow: Added shadows for shaped windows (LP: 1608418)

  [ Marco Trevisan (Treviño) ]
  * DecoratedWindow: Cleanup shadows for shaped windows, reduce
    recomputation (LP: #1608418)
  * UnityWindowView: don't try to deference close_button_ if its' null

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 01 Aug 2016 13:10:28 +0000

Changed in unity (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

William Hughes (docbill224) wrote :

I have this problem on two different computers. Different brands and video cards. Fresh install of Ubuntu 16.04.01, both updated. No Launcher or Menu bars on screen, just Unity wallpaper/ background. I can left click access terminal and the screen settings menu, but when I run a program, no menu bar for the program and desktop is set to place the menu on the program window.

Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → William Hughes (docbill224)
georg (georg-g) wrote :

@William: I know that doesn't help you, but since the update is released my problems are solved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers