compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()

Bug #1603892 reported by Vaclav Rehak on 2016-07-18
270
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I opened my laptop from sleep and tried to login. I have two keyboard layouts configured (US English and Czech) and the Czech one was active. As I prefer to type my password on US layout, I tried to switch with Alt+Shift and the screen lock disappeared for a second or two (revealing all my open applications - this is security bug btw) and then the screen lock appeared again.

I tried several times and it always crashed. After I type my password on the current (Czech) layout, my session unlocked and I can continue to work as usual.

ProblemType: Crash
DistroRelease: Ubuntu 16.04
Package: compiz-core 1:0.9.12.2+16.04.20160714-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
BootLog: /dev/sda5: clean, 2478450/9805824 files, 34628773/39199232 blocks
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Mon Jul 18 09:59:09 2016
DistUpgraded: 2016-04-29 21:46:51,377 DEBUG icon theme changed, re-reading
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 5.0.24, 4.4.0-30-generic, x86_64: installed
 virtualbox, 5.0.24, 4.4.0-31-generic, x86_64: installed
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21f9]
InstallationDate: Installed on 2014-12-02 (593 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: LENOVO 3460CLG
ProcCmdline: compiz
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-31-generic root=UUID=5a5c3a18-3bbc-4129-90c2-a80b1b4a4f41 ro quiet splash vt.handoff=7
Signal: 6
SourcePackage: compiz
StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 __cxa_throw () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
 void boost::throw_exception<boost::bad_function_call>(boost::bad_function_call const&) () from /usr/lib/x86_64-linux-gnu/compiz/libunityshell.so
Title: compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
UpgradeStatus: Upgraded to xenial on 2016-04-29 (79 days ago)
UserGroups: adm cdrom dip docker lpadmin plugdev sambashare sudo wireshark
dmi.bios.date: 09/16/2014
dmi.bios.vendor: LENOVO
dmi.bios.version: G6ETA9WW (2.69 )
dmi.board.asset.tag: Not Available
dmi.board.name: 3460CLG
dmi.board.vendor: LENOVO
dmi.board.version: 0B98401 Pro
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG6ETA9WW(2.69):bd09/16/2014:svnLENOVO:pn3460CLG:pvrThinkPadX1Carbon:rvnLENOVO:rn3460CLG:rvr0B98401Pro:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 3460CLG
dmi.product.version: ThinkPad X1 Carbon
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.12.2+16.04.20160714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Fri Jul 15 20:56:15 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 898
 vendor LGD
xserver.version: 2:1.18.3-1ubuntu2.2

Vaclav Rehak (vaclav-n) wrote :

StacktraceTop:
 __gnu_cxx::__verbose_terminate_handler () at ../../../../src/libstdc++-v3/libsupc++/vterminate.cc:95
 __cxxabiv1::__terminate (handler=<optimized out>) at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:47
 std::terminate () at ../../../../src/libstdc++-v3/libsupc++/eh_terminate.cc:57
 __cxxabiv1::__cxa_throw (obj=0x2d320e0, tinfo=0x7f2e0adbf488 <typeinfo for boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::bad_function_call> >>, dest=0x7f2de90caac0 <boost::exception_detail::error_info_injector<boost::bad_function_call>::~error_info_injector()+48>) at ../../../../src/libstdc++-v3/libsupc++/eh_throw.cc:87
 clone_impl (this=0x2d320e0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/include/boost/exception/exception.hpp:437

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
information type: Private Security → Public Security
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.