[Regression] Panel/Dash background corruption with multimon

Bug #1602901 reported by Tasos Sahanidis on 2016-07-14
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Eleni Maria Stea

Bug Description

Running Ubuntu 16.04 with the updates repository enabled, using the Nvidia proprietary driver 367.27.

A couple of days ago there was a Unity update (7.4.0+16.04.20160705-0ubuntu1) which includes a commit that causes graphical glitches/corruption on the background of Unity panel in my triple monitor (xrandr) setup.
The result differs depending on which monitor the Panel/Dash is opened on.

Specifically, on one monitor there is a horizontal offset on the background, on the second one there is garbage and on the third one there is no background at all, making Unity completely see-through.
Additionally, when transparent, the top bar is also affected.

After downloading the source code and compiling Unity from different commits, I have reached the conclusion that the commit which introduced the issue is #4145 from trunk (https://bazaar.launchpad.net/~unity-team/unity/trunk/revision/4145).

The following links demonstrate the issue, as well as show the exact point where the regression started occurring.

https://vps.tasossah.com/bugs/9c9f3d255d3c.jpg
https://vps.tasossah.com/bugs/c689e3866fff.jpg
https://vps.tasossah.com/bugs/unity_multimonbug.webm

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2016-07-15
Changed in unity (Ubuntu):
importance: Undecided → High
assignee: nobody → Eleni Maria Stea (hikiko)
status: Confirmed → Triaged
Eleni Maria Stea (hikiko) wrote :

Thank you for taking the time to report this bug, we are working to fix it asap!

cement_head (andorjkiss) wrote :

Yep, Thanks! Only happens on the laptop screen IF there is a second external monitor attached.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+16.10.20160715-0ubuntu1

---------------
unity (7.5.0+16.10.20160715-0ubuntu1) yakkety; urgency=medium

  [ Eleni Maria Stea ]
  * Reverts fix for multimonitor because of problems in nvidia cards
    (see bug: #1602901) (LP: #1602901)

 -- <email address hidden> (<email address hidden>) Fri, 15 Jul 2016 15:13:28 +0000

Changed in unity (Ubuntu):
status: Triaged → Fix Released
cement_head (andorjkiss) wrote :

Will this be backported to Xenial?

Larry Price (larryprice) wrote :

I can confirm this was fixed when I updated my yakkety install this morning. Thank you!

Gilberto Olimpio (golimpio) wrote :

I couldn't test on Xenial, but it's working now on Yakkety. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers