Text invisible in GTK windows when resuming session

Bug #1595366 reported by Pierre Equoy on 2016-06-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Unassigned

Bug Description

At the end of the day, I usually put my laptop to suspend, and in the morning I wake it up and the session resumes.

Some times, though (maybe once every 15 resumes), the windows do not show texts and labels properly. It seems to only affect GTK programs (for instance, Firefox content seems unaffected) as well as Unity panels (for instance the user menu in the attached screenshot).

For some reason, it looks like only the letter 'T' is displayed properly (and to some extent, some labels that contains the uppercase letter T) :)

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160526.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-24.43-generic 4.4.10
Uname: Linux 4.4.0-24-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Jun 23 10:04:14 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] 4th Gen Core Processor Integrated Graphics Controller [1025:0926]
   Subsystem: Acer Incorporated [ALI] GM107M [GeForce GTX 860M] [1025:0926]
InstallationDate: Installed on 2016-04-25 (58 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: Acer Aspire VN7-591G
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-24-generic.efi.signed root=UUID=b53d0268-f116-4e07-bf4c-10b1d501bc0b ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/12/2014
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V1.08
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Aspire VN7-591G
dmi.board.vendor: Acer
dmi.board.version: V1.08
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: V1.08
dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.08:bd09/12/2014:svnAcer:pnAspireVN7-591G:pvrV1.08:rvnAcer:rnAspireVN7-591G:rvrV1.08:cvnChassisManufacturer:ct10:cvrV1.08:
dmi.product.name: Aspire VN7-591G
dmi.product.version: V1.08
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.12.2+16.04.20160526-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Thu Jun 23 10:00:55 2016
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 Unknown chipset: NV117
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 1091
 vendor LGD
xserver.version: 2:1.18.3-1ubuntu2.2

Pierre Equoy (pieq) wrote :
Sebastien Bacher (seb128) wrote :

that's likely a videodriver issue similar to e.g https://bugs.freedesktop.org/show_bug.cgi?id=88584

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
mastier1 (mastier1) wrote :

This must be something specific to Haswell, it happens to my company laptop as well
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

but never happens on Intel 3rd gen at home

Changed in unity (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.