Logout on first attempt fails, killing desktop icons

Bug #1574054 reported by Pulkit Swarup on 2016-04-23
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Unassigned

Bug Description

I've done a fresh install (upgrade) of ubuntu 16.04. When I click on Logout button, all the icons on the desktop disappear, however I donot get logged out. I repeat the process and this time I get logged out.

I tried this multiple times and the problem is consistent. Even tried restarting the system however the problem persists.

Additionally, a few panel indicators also fail to start when I login after the above method of logging out.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.12
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Sat Apr 23 22:00:53 2016
InstallationDate: Installed on 2016-04-23 (0 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: release-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)

Pulkit Swarup (pulkit-swarup) wrote :
affects: ubuntu-release-upgrader (Ubuntu) → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Wayne Stark (wastark-gmail) wrote :

Same problem here. Actually if I wait long enough ie. 2 minutes, it will eventually logout, but initiating a second logout makes it work immediately.

Mark Kilpatrick (makcf07) wrote :

Same problem here.

Wayne Stark (w-stark) wrote :

Just an update. I have found that by removing the app diodon from the panel, logout returns to normal Try disabling any apps in the panel one by one to see if that might resolve the issue.

Changed in unity (Ubuntu):
importance: Undecided → High

I have the same problem (logout on first attempt fails).

I found that disabling Dropbox app in panel (kill process) fix the problem!!!

But this solution is not satisfactory for me, because I need to use dropbox.

Zaphod BIII (maheinmuc) wrote :

Ubuntu 16.04.4 LTS,
Linux kyoko 4.4.0-127-generic #153-Ubuntu SMP Sat May 19 10:58:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I have the same problem.

In my case it is also the Clipboard manager Diodon - as Wayne Stark (w-stark) wrote on 2016-05-08

Workaround: Right mouse click icon "paper clip" (Diodon), select quit and log out will be successful again.

(By the way: Diodon Preferences, if selected, will not appear as the top most window)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers