PrintScreen key autorepeats, probably shouldn't

Bug #1572241 reported by Alan Pope 🍺🐧🐱 🦄 on 2016-04-19
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Andrea Azzarone
compiz (Ubuntu)
Medium
Andrea Azzarone
Nominated for Xenial by Marco Trevisan (Treviño)
Xenial
Undecided
Unassigned
unity (Ubuntu)
Medium
Andrea Azzarone
Nominated for Xenial by Marco Trevisan (Treviño)
Xenial
Undecided
Unassigned

Bug Description

Something (a cat) walked on my keyboard (Thinkpad T450) pressing the printscreen key for an extended period of time (more than a second, less than 5 seconds) and my desktop went black.

Seems we have autorepeat on the PrtSc key and probably shouldn't.

Steps to reproduce:-

Press and hold printscreen key

Expected behaviour:- a screenshot is taken

Actual behaviour:-

* Tens (or more) of gnome screenshot processes are running
* Lots of memory is consumed, computer becomes slow
* Screen is black

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160415-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
Uname: Linux 4.4.0-18-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Apr 19 17:53:48 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:5034]
InstallationDate: Installed on 2016-04-08 (11 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160407)
LightdmDisplayLog: (II) AIGLX: Suspending AIGLX clients for VT switch
LightdmLog:
 [+189148.10s] DEBUG: Seat seat0 changes active session to
 [+189156.52s] DEBUG: Seat seat0 changes active session to c2
 [+189156.52s] DEBUG: Session c2 is already active
MachineType: LENOVO 20BV001BUK
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-18-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/27/2016
dmi.bios.vendor: LENOVO
dmi.bios.version: JBET56WW (1.21 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20BV001BUK
dmi.board.vendor: LENOVO
dmi.board.version: 0B98417 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.modalias: dmi:bvnLENOVO:bvrJBET56WW(1.21):bd01/27/2016:svnLENOVO:pn20BV001BUK:pvrThinkPadT450:rvnLENOVO:rn20BV001BUK:rvr0B98417WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.name: 20BV001BUK
dmi.product.version: ThinkPad T450
dmi.sys.vendor: LENOVO
upstart.unity-panel-service-lockscreen.log:
 (unity-panel-service:17773): GLib-CRITICAL **: Source ID 4294967295 was not found when attempting to remove it

 (unity-panel-service:1621): GLib-CRITICAL **: Source ID 4294967295 was not found when attempting to remove it

 (unity-panel-service:13154): GLib-CRITICAL **: Source ID 4294967295 was not found when attempting to remove it
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Sun Apr 17 09:54:35 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 1030
 vendor LGD
xserver.version: 2:1.18.3-1ubuntu2

Related branches

Will Cooke (willcooke) on 2016-04-19
Changed in unity (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: rls-y-incoming
Dave Morley (davmor2) wrote :

Yay cats find bugs yet another reason to get a cat :)

Dave Morley (davmor2) on 2016-04-19
Changed in gnome-screenshot (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2016-04-20
no longer affects: unity (Ubuntu)
no longer affects: gnome-screenshot (Ubuntu)
Changed in compiz (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) on 2016-04-20
Changed in compiz (Ubuntu):
status: Triaged → In Progress
tags: added: yet-another-cat-triggered-bug
Andrea Azzarone (azzar1) on 2016-04-20
Changed in unity (Ubuntu):
status: New → In Progress
no longer affects: compiz (Ubuntu)
Andrea Azzarone (azzar1) on 2016-04-20
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) on 2016-04-21
Changed in hundredpapercuts:
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Triaged
assignee: Andrea Azzarone (azzar1) → nobody
Changed in hundredpapercuts:
assignee: Andrea Azzarone (azzar1) → nobody
Andrea Azzarone (azzar1) on 2016-04-25
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2016-04-25
Changed in compiz (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) on 2016-04-26
Changed in hundredpapercuts:
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.2+16.10.20160517-0ubuntu1

---------------
compiz (1:0.9.12.2+16.10.20160517-0ubuntu1) yakkety; urgency=medium

  [ Alberts Muktupāvels ]
  * CMake: Remove USE_GSETTINGS option.
  * Fix memory leaks in GWDSettingsStorage.
  * OpenGL: use the number of Opaque windows around to decide whether
    paint the bg or not (LP: #1574866)
  * Remove GWDSettingsStorageInterface.

  [ Andrea Azzarone ]
  * Add an option to notify that a key press is actually an "auto
    repeat" one. (LP: #1572241)

  [ Eleni Maria Stea ]
  * Expo, Scale: add support for bottom offsets (LP: #1573897, #1562346)

  [ Marco Trevisan (Treviño) ]
  * Scale: allow to iterate through windows using Tab key
  * Scale: use the selectedWindow as starting point when focusing a
    window (LP: #1575168)
  * Window: call stateChangeNotify when compiz state changed but before
    changing the WM state (LP: #1521302)

  [ Sam Spilsbury <email address hidden> ]
  * Blur: port the plugin to modern OpenGL

  [ handsome_feng ]
  * Add a YBottomOffset value when stretch maximized windows。 (LP:
    #1562348)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 17 May 2016 02:53:09 +0000

Changed in compiz (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+16.10.20160517-0ubuntu1

---------------
unity (7.5.0+16.10.20160517-0ubuntu1) yakkety; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * Bumping version to 7.5.0, as per 7.4 release

  [ Andrea Azzarone ]
  * Do not reset the shortcut for icons that have their own shortcut.
    (LP: #1562847)
  * Fallback to "background" class in case no background is specified
    for title bars and top panel. (LP: #1575527)
  * GnomeKeyGrabber: do not activate an action if it's a repeated one.
    (LP: #1572241)
  * Properly calculate array indexes to avoid crashes. (LP: #1570843)
  * Properly remove SoftwareCenterLauncherIcon in case of failure. (LP:
    #1553165)
  * Update ExpoLauncherIcon in case the quicklist is used to switch vp.
    (LP: #1525685)

  [ Marco Trevisan (Treviño) ]
  * DashStyle: ensure LazyLoadTexture disconnects from signals on
    destruction (LP: #1580212)
  * Releasing Unity 7.4.0
  * SwitcherController: don't try to get a window from empty selections
    (LP: #1580211)
  * SwitcherView: close the mouse-selected application on middle-click
    (LP: #1574689)
  * UnityScreen, UnityWindow: cleanup a little the code, and ensure
    overridden CompositeWindow functions get actually called

  [ handsome_feng ]
  * Change the x_offset of expo when launcher position changed. (LP:
    #1573897, #1562348)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 17 May 2016 02:56:22 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello Alan, or anyone else affected,

Accepted compiz into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/compiz/1:0.9.12.2+16.04.20160526-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in compiz (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Alan, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.0+16.04.20160526.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Xenial):
status: New → Fix Committed

Installed the following packages:-

compiz_0.9.12.2+16.04.20160526-0ubuntu1_all.deb
compiz-core_0.9.12.2+16.04.20160526-0ubuntu1_amd64.deb
compiz-gnome_0.9.12.2+16.04.20160526-0ubuntu1_amd64.deb
compiz-plugins-default_0.9.12.2+16.04.20160526-0ubuntu1_amd64.deb
libcompizconfig0_0.9.12.2+16.04.20160526-0ubuntu1_amd64.deb
libdecoration0_0.9.12.2+16.04.20160526-0ubuntu1_amd64.deb

Holding printscreen still results in a huge number of gnome-screenshot processes and black screen.

Should I have installed something else?

Alan you should also have new Unity packages.

The issue is resolved for me.

tags: added: verification-done
removed: verification-needed

Yup, waited for -proposed updates, installed and rebooted. All fixed. Thanks so much everyone. My cat can no longer break my laptop!

*meow*

Robert Hooker (sarvatt) wrote :

It seems like this is affecting other keys that it shouldn't as well? Volume up and down on my thinkpad stopped autorepeating so it takes 30 presses to raise the volume or lower the volume fully now.

Amr Ibrahim (amribrahim1987) wrote :

If this regresses volume up and down, then I think the verification failed. I'll wait until someone else tests this.

Changed in hundredpapercuts:
status: In Progress → Fix Released

Confirmed this update broke autorepeat on volume keys.

tags: added: verification-failed
removed: verification-done

Mh, it's a regression for that usecase, but I think that the fix here is more important than the annoyance of pressing a volume key multple times.

Having this fix for only some keys is doable, although it requires whitelisting some keys, which isn't the nicest thing in the world.

However, please open a new bug, since the verification for this fix is there.

tags: added: verification-done
removed: verification-failed
Robert Hooker (sarvatt) wrote :

I did open a new one which I duped to this one just in case- https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1586491, unduping it now

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.12.2+16.04.20160526-0ubuntu1

---------------
compiz (1:0.9.12.2+16.04.20160526-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * Add an option to notify that a key press is actually an "auto
    repeat" one. (LP: #1572241)

  [ Alberts Muktupāvels ]
  * OpenGL: use the number of Opaque windows around to decide whether
    paint the bg or not (LP: #1574866)

  [ Marco Trevisan (Treviño) ]
  * Scale: use the selectedWindow as starting point when focusing a
    window (LP: #1575168)
  * Scale: allow to iterate through windows using Tab key
  * Window: call stateChangeNotify when compiz state changed but before
    changing the WM state (LP: #1521302)

  [ Eleni Maria Stea ]
  * Expo, Scale: add support for bottom offsets (LP: #1562346, LP:
    #1573897)

  [ handsome_feng ]
  * Add a YBottomOffset value when stretch maximized windows。 (LP:
    #1562348)

  [ CI Train Bot ]
  * No-change rebuild.

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 26 May 2016 00:12:16 +0000

Changed in compiz (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for compiz has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160526.1-0ubuntu1

---------------
unity (7.4.0+16.04.20160526.1-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * Releasing Unity 7.4.0

  [ Andrea Azzarone ]
  * Properly remove SoftwareCenterLauncherIcon in case of failure. (LP:
    #1553165)
  * Update ExpoLauncherIcon in case the quicklist is used to switch vp.
    (LP: #1525685)
  * GnomeKeyGrabber: do not activate an action if it's a repeated one.
    (LP: #1572241)
  * Properly calculate array indexes to avoid crashes. (LP: #1570843)
  * Fallback to "background" class in case no background is specified
    for title bars and top panel. (LP: #1575527)
  * Do not reset the shortcut for icons that have their own shortcut.
    (LP: #1562847)

  [ Marco Trevisan (Treviño) ]
  * SwitcherView: close the mouse-selected application on middle-click
    (LP: #1574689)
  * UnityScreen, UnityWindow: cleanup a little the code, and ensure
    overridden CompositeWindow functions get actually called
  * SwitcherController: don't try to get a window from empty selections
    (LP: #1580211)
  * DashStyle: ensure LazyLoadTexture disconnects from signals on
    destruction (LP: #1580212)

  [ handsome_feng ]
  * Change the x_offset of expo when launcher position changed. (LP:
    #1562348, LP: #1573897)

  [ CI Train Bot ]
  * No-change rebuild.

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 26 May 2016 00:03:25 +0000

Changed in unity (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers