[FFe] Add support for launcher at the bottom

Bug #1552630 reported by Anthony Wong on 2016-03-03
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Kylin
unity (Ubuntu)

Bug Description

We are working with Unity team for quite some time on merge proposals so that the launcher can be moved to the bottom of the screen, they are pending review.


Related branches

description: updated
description: updated
Changed in unity (Ubuntu):
importance: Undecided → Medium
Iain Lane (laney) wrote :

2 weeks until beta and 6 weeks until release.

I'm worried that if this proves to be buggy then it's going to distract the developers from the many other Unity fixes that are queued up to be worked on (http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html). It's rare that things are 100% straight away, and Unity has had some late feature additions in the past that have required fixing up. These branches are quite large in terms of LOC delta.

I don't think it's going to be a niche feature - this is something that will be promoted and so people will use it, and it'll need to be properly supported.

Why is adding this feature now in 16.04 LTS worth the risk of other fixes not making it?

> Why is adding this feature now in 16.04 LTS worth the risk of other fixes not making it?

I know we arrived late in requesting the FFe, it's true that this feature is under the works for long time, and actually ready way before the FF.
Unfortunately the decision process in getting this approved took longer, thus we arrived late.

The thing is that this feature will be, in any case, default on Ubuntu Kylin and thus we can expect that both we and the kylin team will be happy to support this and ensure that any eventual bug is addressed before the final freeze, and with SRUs (hoping that this is not needed).

Since our community is also somewhat interested in this, I think that having such feature for an LTS is still something that could add unity some preference and gain back some lost users.

While it's true that the diffs are quite big, the newly added code is really not touching in the vast major part of our existing (default) codepath, and thus I don't expect regressions.
Anyway, I personally will be happy to spend even my extra time to fix issues in the new codepath.

handsome_feng (feng-kylin) wrote :

Hi, lain, I knew your worries, but our team (kylin team) really hope this can be merged into unity
for 1604, we have been working on this for a long time , and we will try our best to support this
and fix issues, thank you !

Iain Lane (laney) wrote :

OK. Go for it.

Feng, please help out if any bugs come up. The Unity team is trying to work on regular bug fixes too and it will be a shame if this ends up dominating everyone's time.

BTW, is someone going to add something into unity-tweak-tool (or elsewhere) to configure this?

> BTW, is someone going to add something into unity-tweak-tool (or elsewhere) to configure this?

Well, it would be nice to have that in unity-control-center as well, I can do a quick branch for that.

Iain Lane (laney) wrote :

Please upload this before the end of the week.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160318-0ubuntu1

unity (7.4.0+16.04.20160318-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * UserPromptView: don't hide local scale property (LP: #1551820)

  [ Sebastien Bacher ]
  * set the gettext domain directly in CMakeLists rather than using
    refering to the project name, the translation template is updated
    during the build by dh_translations which is not clever enough to
    understand the variable (LP: #1557081)

  [ handsome_feng ]
  * Dash: move it down when the launcher is positioned at the bottom.
    (LP: #1552630)
  * Launcher: add Bottom mode, so that the launcher can be positioned
    horisontally (LP: #1552630)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 18 Mar 2016 10:10:42 +0000

Changed in unity (Ubuntu):
status: New → Fix Released
Changed in ubuntukylin:
status: New → Fix Committed
zhangchao (zctgbhu) on 2016-03-30
Changed in ubuntukylin:
milestone: none → xenial-beta2
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers