Unity bugs reported via apport shoud contain more informations

Bug #1508974 reported by Marco Trevisan (Treviño) on 2015-10-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sebastien Bacher
unity (Ubuntu)
Medium
Sebastien Bacher
Xenial
Medium
Sebastien Bacher

Bug Description

It would be nice that bugs against unity would also contain:
 - unity7.log from upstart
 - unity-panel-service.log from upstart
 - unity-panel-service-lockscreen.log from upstart
 - settings from:
    · org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins
    · org.compiz.core:/org/compiz/profiles/unity/plugins/unityshell/ <any>
    · (any active plugin would be nice, but maybe too much)
    · com.canonical.Unity.*
    · com.ubuntu.user-interface scale-factor
    · org.gnome.desktop.interface
    · org.gnome.desktop.lockdown

Related branches

Changed in unity:
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Medium
status: New → Triaged
tags: added: rls-x-incoming
removed: rls-w-incoming
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
milestone: none → 7.4.0
Changed in unity (Ubuntu):
milestone: none → ubuntu-16.04
tags: removed: rls-x-incoming
Changed in unity:
status: In Progress → Confirmed
status: Confirmed → In Progress
tags: added: unity-backlog
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20151211-0ubuntu1

---------------
unity (7.4.0+16.04.20151211-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * unity: ensure we use python3 for the launch script and
    python2.7 for autopilot (LP: #1512909)

  [ Andrea Azzarone ]
  * Places(Overlay)VScrollBar: impelement gtk-like overlay scrollbars
    (LP: #1481706)
  * Properly hide shortcut overlay window to avoid unnecessary redraws.

  [ Bryan Quigley ]
  * debian/control: Remove telepathy from recommends

  [ Eleni Maria Stea ]
  * Replaced deprecated calls in tests to get rid of compiler warnings

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: if a new window opens while spreading,
    spread again with proper match (LP: #1517455)
  * ExpoLauncherIcon: add Quicklist to switch workspace and see the
    selected one (LP: #750497)
  * PanelIndicatorEntryView: Activate menus on click, by drawing them as
    active (LP: #1513523)
  * PanelMenuView: ignore leave events when triggered by feeding nux
    manually (LP: #1513496)
  * Places(Overlay)VScrollBar: impelement gtk-like overlay scrollbars
    (LP: #1481706)
  * SwitcherModel: allow to add/remove icons dynamically and update them
    when they require it (LP: #1512349)
  * SwitcherView: Add support to Alt+Key-right-to-tab to close the
    selected app/window
  * Switcher{View,Controller}: close active selection on Alt+q (LP:
    #1468820)
  * TextInput: show warning also when num lock is enabled
  * XKeyboardUtil: add ability to get keycodes from any relative
    position
  * debian/rules: enable unit tests on arm64 again (LP: #1514538)

  [ Sebastien Bacher ]
  * Updated apport hook to include: the compiz and xorg details, not
    only after asking users if the issue is a graphical one (which is
    weird question) the upstart logs for unity/ups/lockscreen some
    gsettings configurations (LP: #1508974)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 11 Dec 2015 12:46:16 +0000

Changed in unity (Ubuntu Xenial):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers