compiz crashed with SIGSEGV in unity::menu::Manager::Indicators() when trying to switch to full screen game crusader kings II

Bug #1504870 reported by Pauli
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
New
Medium
Marco Trevisan (Treviño)
Xenial
New
Undecided
Unassigned
unity (Ubuntu)
Fix Released
Medium
Marco Trevisan (Treviño)
Xenial
Fix Released
Undecided
Unassigned

Bug Description

[Impact]

I switched away from the fullscreen crusaders king II game (to different workspace).

When I tried to return back to the workspace where I left the game it was minimized.

Switching to the minimized game resulted to a resolution switch to 1024x768 even tough game was originally 1600x900. (The game selected 1024x768 automatically when launched frist time)

During the switching compiz decided to crash.

I had enabled extra indicators in use were time/calendar, sound, battery, messaging, keyboard layout, network (mobile broadband in use), banshee and steam.

[Test case]

1. Use indicators or menus, switching applications
2. Attach / detach monitors, or change resolution
3. Unity should not crash

[Regression potential]

Not known.

ProblemType: CrashDistroRelease: Ubuntu 15.10
Package: unity 7.3.2+15.10.20151002.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-15.18-generic 4.2.3
Uname: Linux 4.2.0-15-generic x86_64
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
CurrentDesktop: Unity
Date: Sun Oct 11 04:12:31 2015
ExecutablePath: /usr/bin/compiz
InstallationDate: Installed on 2011-11-02 (1438 days ago)InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x7f3843382c00 <_ZNK5unity4menu7Manager10IndicatorsEv>: mov 0x280(%rdi),%rax
 PC (0x7f3843382c00) ok
 source "0x280(%rdi)" (0x000002d1) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: unity
StacktraceTop:
 unity::menu::Manager::Indicators() const () from /usr/lib/compiz/libunityshell.so
 unity::panel::PanelView::PanelView(unity::MockableBaseWindow*, std::shared_ptr<unity::menu::Manager> const&, char const*, int) () from /usr/lib/compiz/libunityshell.so
 unity::panel::Controller::Impl::CreatePanel() () from /usr/lib/compiz/libunityshell.so
 unity::panel::Controller::Impl::OnScreenChanged(unsigned int, std::vector<nux::Rect, std::allocator<nux::Rect> > const&) () from /usr/lib/compiz/libunityshell.so
 unity::UScreen::Refresh() () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in unity::menu::Manager::Indicators()
UpgradeStatus: Upgraded to wily on 2015-10-10 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
Pauli (paniemin) wrote :
information type: Private → Public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 unity::menu::Manager::Indicators() const () from /tmp/apport_sandbox_OTInYs/usr/lib/compiz/libunityshell.so
 unity::panel::PanelView::PanelView(unity::MockableBaseWindow*, std::shared_ptr<unity::menu::Manager> const&, char const*, int) () from /tmp/apport_sandbox_OTInYs/usr/lib/compiz/libunityshell.so
 unity::panel::Controller::Impl::CreatePanel() () from /tmp/apport_sandbox_OTInYs/usr/lib/compiz/libunityshell.so
 unity::panel::Controller::Impl::OnScreenChanged(unsigned int, std::vector<nux::Rect, std::allocator<nux::Rect> > const&) () from /tmp/apport_sandbox_OTInYs/usr/lib/compiz/libunityshell.so
 unity::UScreen::Refresh() () from /tmp/apport_sandbox_OTInYs/usr/lib/compiz/libunityshell.so

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in unity:
importance: Undecided → Medium
Revision history for this message
juansebas (jslopezg) wrote :

same problem wen I try to full screen on Frozen-Bubble

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Paul (i41bktob-launchpad-net) wrote :

This still affects 16.04 LTS (nvidia-367), most often when resuming from sleep (about one in ten resumes).

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.5.0+17.10.20170721.1-0ubuntu1

---------------
unity (7.5.0+17.10.20170721.1-0ubuntu1) artful; urgency=medium

  * GLibSignal: allow to block, unblock signals
  * UnitySettings: use glib::Signal blocking for ignoring setting
    changes
  * UnitySettings: listen to compiz profile status in order to set
    low_gfx value
  * Launcher: disable or reduce most icon effects on lowgfx (LP:
    #1700859)
  * PanelController: ensure we disconnect from signals on destruction
    (LP: #1504870)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 21 Jul 2017 08:53:17 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
description: updated
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Pauli, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.5+16.04.20171116 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Pauli, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.5+16.04.20171201.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Ads20000 (ads20000) wrote :

Is there an easy way to trigger this (e.g. a free app or game that will definitely trigger this bug so that I can reproduce the bug)?

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package unity - 7.4.5+16.04.20171201.3

---------------
unity (7.4.5+16.04.20171201.3) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * InputMonitor: add an unity class that monitors XInput2 events and
    converts them to XEvent
  * EdgeBarrierController: use InputMonitor to get the barrier events
    instead of relying on its implementation
  * DecorationsMenuLayout: use input monitor for menu scrubbing (LP:
    #1614597)
  * PanelView: use InputMonitor to track menu events
  * LockScreenPanel: use InputMonitor events instead of mouse polling
    for menu scrubbing
  * MenuManager: add support for mouse trackers with triangle algorithm
    support (LP: #1618405)
  * PanelView: scale gradient refinement properly
  * PanelService: don't allow to deactivate menus if they've been opened
    too shortly
  * LockScreenController: ignore icon_paths_changed signal in
    menumanager for Lockscreen
  * LockScreenController: use InputMonitor to get all the events and
    hide the Blank Window (LP: #1321075)
  * LockScreenController: use input monitor to get the events to switch
    monitor (LP: #1316862)
  * LauncherOptions: use track_obj to manage option changes (LP:
    #1622995)
  * UnityScreen: toggle gestures recognition on lock (LP: #1645507)
  * GnomeSessionManager: add gcancellable to instance and use it for
    calls with temporary proxies
  * BackgroundSettings: use gnome-bg to generate textures with proper
    scaling (LP: #1666359)
  * UnityWindow: safely check validity of UnityWindow from scaled one
    (LP: #1659847)
  * Panel: ensure the menu-manager tracker is updated to match monitor
    (LP: #1671432)
  * compiz-profile-setter: tool to update the current profile and use in
    systemd and Unity settings (LP: #1668950)
  * BGHash, UnityScreen: get desktop averageColor from compiz
  * Launcher: disable or reduce most icon effects on lowgfx (LP:
    #1700859)
  * PanelController: ensure we disconnect from signals on destruction
    (LP: #1504870)
  * tools: add migration script to set the default values for unity-
    lowgfx profile

  [ Andrea Azzarone ]
  * Properly handle the file manager copy dialog in
    FileManagerLauncherIcon and in StorageLauncherIcon. (LP: #1575452,
    LP: #1609845)
  * Correctly position the force quit dialog when scaling is different
    than 1.0 (LP: #1637991)
  * GnomeSession: Retrieve the session id using dbus if $XDG_SESSION_ID
    is not set
  * Round gtk scaling factor to closest integer. (LP: #1649736)
  * Keep the screen locked if rebooting with autologin. (LP: #1600389)
  * Use g_mkdir_with_parents instead of mkdir.
  * Lockscreen: always draw the background-color in the lockscreen (LP:
    #1702701)
  * Refactor the way UserAuthenticator is created and passed around.
    Handle failures to create new threads and fallback to a "Switch to
    greeter..." button in case of failure. (LP: #1311316)
  * Wait until the color buffer is cleared before suspending. (LP:
    #1532508)

  [ Kai-Heng Feng ]
  * UnitySettings: If scale-factor is not set, find and set right scale
    for HiDPI displays.

  [ Eleni Maria Stea ]
  * shouldn't create blur rectangles when there's ...

Read more...

Changed in unity (Ubuntu Xenial):
status: Fix Committed → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote : Update Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers