Cat sitting on keyboard crashes lightdm

Bug #1463112 reported by wastrel
This bug report is a duplicate of:  Bug #1538615: Cat causes login screen to hang. Edit Remove
138
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

14.04, locked screen to go to lunch, upon return from lunch cat was sitting on keyboard, login screen was frozen & unresponsive.

To replicate: In unity hit ctrl-alt-l, place keyboard on chair. Sit on keyboard.

Resolution: Switched to virtual terminal, restarted lightdm, lost all open windows in X session.

What should have happened: lightdm not becoming unresponsive.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
wastrel (wastrel) wrote :

Seems like keyboard input is being buffered and then fed into the password text input slowly, this is blocking other events (menu, esc) in the login screen.

Changed in unity:
status: New → Confirmed
Mathew Hodson (mhodson)
tags: added: trusty
tags: added: lockscreen
Mathew Hodson (mhodson)
Changed in unity (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Rodrigo Lledó (rodhos-hp) wrote :

I have tested this on 15.10 and cannot reproduce it.

Revision history for this message
Andrew Drummond (4ndy) wrote :

>I have tested this on 15.10 and cannot reproduce it.
What type of cat did you use? This may require a certain weight distribution and pawing behaviour to avoid keyboard buffer overflow.

Revision history for this message
Katsiaris Simos (spider623) wrote :

will it also work with a small dog, please some one with a small size dogs test it!

also happened to me with nothing around a few time 15.04, solved by fully stopping lightdm and then starting the service with systemctl

Revision history for this message
Michael Zanetti (mzanetti) wrote :

I've tried to reproduce with this cat but didn't have luck: http://i.imgur.com/DJbXkkV.jpg

Revision history for this message
Thiago Martins (martinx) wrote :

LOLOL

Revision history for this message
Jeremy Kerr (jk-ozlabs) wrote :

Funnily enough, I saw the same issue last night. Also caused by a cat.

The system seemed to be completely unresponsive, but I don't think it had locked completely; after a few minutes of holding down backspace (with no indication in the UI that characters are actually being deleted), I managed to eventually clear the password entry box. Hitting enter (ie, to clear the password box by performing an invalid login) didn't seem to do anything either. It seemed like the excessive chars in the password box was slowing the UI down.

Changing to tty1 and doing a ps didn't show lightdm to be in any unusual state.

I have no idea how long the cat was sitting on the keyboard.

My system details:

  Ubuntu version : 15.10
  Lightdm version: 1.16.4-0ubuntu1
  Cat: black, domestic

Revision history for this message
Xavier Guillot (valeryan-24) wrote :

Does the bug behavior change when we remove the "mouse" from cat ? ;)

Seriously, is this related to the GDM problem, corrected in Gnome ?
https://bugzilla.gnome.org/show_bug.cgi?id=758032

Revision history for this message
Kenneth Cole (cromey64024-6) wrote :

I've had this happen many times. Last time found out that holding the esc key for a couple seconds will usually clear it, at least assuming said cat has moved.

Revision history for this message
Calin Rusu (clnrusu-r) wrote :

I have tried to replicate it on vivid.
Problem is I don't have a cat. I have 3 dogs but none of my dogs had enough patience to sit on the keyboard while I was being away.
So, vivid+dog owner = OK, no problem.

Revision history for this message
Raphaël Jakse (raphael-jakse) wrote :

Hello,

The attachment is an accurate description of the situation.
However, the computer is not showing the lightdm screen at the moment of the picture.

Revision history for this message
Tim Hitchins (timtjtim) wrote :

Hmm,

This issue also affects me. However, I believe the solution is fairly simple.

Just select all the text and remove it with Ctrl + A or with Ctrl + Shift and Left Arrow. Then hit backspace.

Revision history for this message
Colin Watson (cjwatson) wrote :

I've had this a few times with our cats. Today I evidently caught it in time and Shift-Home Backspace was enough to sort it out, although it took a few seconds. Yesterday I gave up after waiting several minutes - there was no response to anything other than mouse movement - and I had to ssh in from my phone and kill compiz, which was using an entire core.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.