windows can be resized from wrong workspace

Bug #1449654 reported by Krister on 2015-04-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone
Trusty
Medium
Unassigned

Bug Description

[Test case]
1. Setup multiple workspaces.
2. Create a window and move it so that the right side of the window is at the right edge of the workspace (but not past the right edge).
3. Move right one workspace.

See that you can grab the window from the workspace to the left and resize it into the current workspace.

I shouldn't be able to grab a window from another workspace.

[Regression potential]
None

ProblemType: BugDistroRelease: Ubuntu 15.04
Package: unity 7.3.2+15.04.20150420-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Tue Apr 28 18:20:44 2015
InstallationDate: Installed on 2014-10-13 (197 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140923)SourcePackage: unity
UpgradeStatus: Upgraded to vivid on 2015-04-25 (3 days ago)

Related branches

Krister (thekswenson) wrote :
Will Cooke (willcooke) on 2015-07-31
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
tags: added: 16.04-hit-list
Andrea Azzarone (azzar1) on 2015-08-05
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Will Cooke (willcooke) on 2015-08-07
tags: added: rls-w-incoming
Andrea Azzarone (azzar1) on 2015-08-07
Changed in unity:
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150819-0ubuntu1

---------------
unity (7.3.2+15.10.20150819-0ubuntu1) wily; urgency=medium

  [ Andrea Azzarone <email address hidden> ]
  * Do not handle events coming from viewports not actually containing
    the window. (LP: #1449654)

  [ Chris Townsend ]
  * Also use the Compiz show() method when forcing an unmapped window to
    be visible when clicking on it's active Launcher icon. (LP: #989588)
  * When using keyboard navigation in the Dash, skip category headers
    that are not expandable. Also, do not highlight the category header
    when the mouse cursor is over it. (LP: #1045933)

  [ Marco Trevisan (Treviño) ]
  * ApplicationManager: rely on windows monitor property changes for
    updating Pips (LP: #1027191)
  * Autopilot: modernize some tests, use stronger methods to ensure
    false positive
  * DecorationsForceQuitDialog: override the background of the window
    with transparent color (LP: #1470292)
  * Launcher: Always unfold an active icon (LP: #1472339)
  * PanelMenuView: ensure that we connect to window signals as soon as
    the AppManager knows it (LP: #1472326)
  * PlacesGroup: connect to view changes using a function instead of a
    lambda (LP: #1470298)
  * SessionButton: set button opacity to 75% when pressed (LP: #1301655)

 -- CI Train Bot <email address hidden> Wed, 19 Aug 2015 14:45:18 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
milestone: none → 7.3.3
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello Krister, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium
Krister (thekswenson) wrote :

Is it just me, or have these updated packages not yet been included in wily-proposed?

@krister The 𝑼𝒏𝒊𝒕𝒚 7.3 package in 15.10 𝒘𝒊𝒍𝒚 already got fixed. As you can see from https://launchpad.net/ubuntu/+source/unity 𝒘𝒊𝒍𝒚 shipped Unity v7.3.2+15.10.20151016-0ubuntu1, newer than the one where bug was fixed - 7.3.2+15.10.20150819-0ubuntu1.

This bug report is now for verifying the backported fix on 𝐔𝐛𝐮𝐧𝐭𝐮 𝟏𝟒.𝟎𝟒𝐋𝐓𝐒 "Trusty Tahr"'s 𝑼𝒏𝒊𝒕𝒚 7.2. This'll enable Ubuntu 14.04LTS to get bugfixed Unity through SRU updates.

Installed and tested all 3 packages from 𝐔𝐧𝐢𝐭𝐲 𝟕 version 7.2.6+14.04.20151021-0ubuntu1 packages on 𝐔𝐛𝐮𝐧𝐭𝐮 𝟏𝟒.𝟎𝟒𝐋𝐓𝐒 "Trusty". I did the testcase with 4 workspaces, autohid Unity Launcher, tried the test from left workspace to right, right to left and from bottom to top too. Since the new Unity passed the test case in all possible combinations, I guess it's verified for inclusion in SRU.

tags: added: trusty verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Andrea Azzarone (azzar1) on 2017-10-13
no longer affects: unity/7.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers