Duplicate processes started after Resume of amd64 bit

Bug #1427785 reported by apjjr on 2015-03-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Docky
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

$ uname -a
Linux ajsc855 3.13.0-46-generic #76-Ubuntu SMP Thu Feb 26 18:52:13 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.2 LTS"

Toshiba Satellite C855, 4GB RAM, 720GB HD

I typically run Thunderbird, Firefox, a terminal or two, Gthumb, Gimp, Qcad, Gedit, Libreoffice, Inkscape, Document Viewer and occasionally Virtualbox.

I just noticed this a couple of weeks ago, so I am guessing a recent update started it.

It seems to me that there are quite a few duplicate copies of some processes populating memory after suspending/resuming a session for a few days. Namely, dbus-daemon, gvfsd and gconfd-2. The more I suspend/resume the session, the more of these processes appear. After a while they start using up a significant amount of memory and system response seems to slow down.

Logging out and back in did not alleviate the problem. Rebooting did. But, I will have to reboot again in a week to free up the memory used by these duplicate processes.

The example session used to get the following results was probably well over a week in use.

Before rebooting:
$ ps -ef >prereboot.txt
$ grep -i dbus-daemon <prereboot.txt|wc -l
40
$ grep -i gvfsd <prereboot.txt|wc -l
78
$ grep -i gconfd-2 <prereboot.txt|wc -l
37

After rebooting:
$ ps -ef >postreboot.txt
$ grep -i dbus-daemon <postreboot.txt|wc -l
4
$ grep -i gvfsd <postreboot.txt|wc -l
5
$ grep -i gconfd-2 <postreboot.txt|wc -l
1

apjjr (alex-ourwoods) on 2015-03-04
affects: gnome-terminal (Ubuntu) → meta-gnome3 (Ubuntu)
apjjr (alex-ourwoods) wrote :

I have just spent the last hour or so trying to track down an app that causes the extra processes, using system monitor and found none of the user programs I normally run are responsible. I did, however, close the lid on my laptop and waited for the system to suspend. When I woke it up by raising the lid, logged in and checked the system monitor, there were 3 new instances of dbus-daemon, gconfd-2, gvfsd and gvfsd-trash. I did this again and the same thing happened again. Now there are 7 instances of each.
Anyone got a clue?

apjjr (alex-ourwoods) wrote :

Just for kicks, I suspended again as in comment #3 and now I have 10 instances of the afforementioned processes.

apjjr (alex-ourwoods) wrote :

Also, 3 instances of bash appear with the first suspend/wakeup cycle and I don't have a terminal running.

apjjr (alex-ourwoods) wrote :

The system does the same upon booting from hibernation. The only way to avoid this is to shutdown and reboot. This behavior is not apparent in the 32 bit version, which makes me think I might switch back until this bug is fixed.

apjjr (alex-ourwoods) on 2015-03-08
summary: - Too many instances of processes left running in 64 bit version
+ Dupicate processes started after Resume of amd64 bit
description: updated
apjjr (alex-ourwoods) on 2015-03-08
summary: - Dupicate processes started after Resume of amd64 bit
+ Duplicate processes started after Resume of amd64 bit
description: updated
apjjr (alex-ourwoods) on 2015-03-08
description: updated
apjjr (alex-ourwoods) wrote :

Can anyone duplicate this problem, or is it just me?

apjjr (alex-ourwoods) wrote :

Maybe I should just reinstall and see if the problem goes away. I feel like I'm talking to myself.

affects: meta-gnome3 (Ubuntu) → unity (Ubuntu)
Stephen M. Webb (bregma) wrote :

Most of the processes you're seeing are run by the session upstart. Try 'ps fax' to see the process tree. You also get to see what state these processes are in that way.

Still, this has nothing to do with Unity, which neither handles system power states nor session process control. You might want ot check logs in /var/log/upstart or ~/.cache/upstart for more clues.

apjjr (alex-ourwoods) wrote :
Download full text (4.9 KiB)

Ok. I have no idea what I'm looking for. I see messages in a lot of the upstart log files that look like errors. See below.

How am I supposed to know what package this 'bug' belongs to? I'm not a linux systems guy. How would I figure that out? I'd be glad to classify this better if I knew how.
All I know is what I said in my first remark about this.
I've been using Ubuntu since 5.04 and have never seen duplicate processes get started like this before. They just keep building up until I start to see performance degradation. Then I reboot and all is well until they build up again.
Thanks for your help.

Here's part of the output of ps fax:
7011 ? Ss 0:00 \_ bash -c dbus-launch /usr/bin/docky >/dev/null -
 7012 ? Sl 0:02 \_ mono /usr/lib/docky/Docky.exe
 6715 ? S 0:00 su apjjr - -c dbus-launch /usr/bin/docky >/dev/null
 7016 ? Ss 0:00 \_ bash -c dbus-launch /usr/bin/docky >/dev/null -
 7017 ? Sl 0:02 \_ mono /usr/lib/docky/Docky.exe
 6872 ? S 0:00 su apjjr - -c dbus-launch /usr/bin/docky >/dev/null
 7019 ? Ss 0:00 \_ bash -c dbus-launch /usr/bin/docky >/dev/null -
 7021 ? Sl 0:02 \_ mono /usr/lib/docky/Docky.exe
 6910 ? S 0:00 su apjjr - -c dbus-launch /usr/bin/docky >/dev/null
 7022 ? Ss 0:00 \_ bash -c dbus-launch /usr/bin/docky >/dev/null -
 7026 ? Sl 0:02 \_ mono /usr/lib/docky/Docky.exe

I wonder why so many instances of Docky?

I'd appreciate any help I can get. If I need to reinstall because somethngs gotten screwed up, I'll do that.

Following are the upstart log files I think are indicating some error:

cups.log
cupsd failed to create /var/run/cups/cups.sock, skipping automatic printer configuration
cupsd failed to create /var/run/cups/cups.sock, skipping automatic printer configuration

gpu-manager.log
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
/etc/modprobe.d is not a file
update-alternatives: error: no alternatives for x86_64-linux-gnu_gfxcore_conf

kmod.log
modprobe: FATAL: Module rtc not found.
modprobe: FATAL: Module rtc not found.

network-manager.log

(NetworkManager:861): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Key file does not have group 'connectivity'

(NetworkManager:879): GLib-WARNING **: GError set over the top of a previous GError or uninitialized memory.
This indicates a bug in someone's code. You must ensure an error is NULL before it's set.
The overwriting error message was: Key file does not have group 'connectivity'

ureadahead.log
ureadahead:/var/lib/NetworkManager/dhclient-wlan0.conf: No such file or directory
ureadahead:/var/lib/NetworkManager/dhclient-wlan0.conf: No such file or directory

ureadahead-other.log
ureadahead:/home/apjjr/.cache/upstart/i...

Read more...

apjjr (alex-ourwoods) wrote :

I just resumed from stand-by mode and counted 17 instances of dbus-daemon running. It's been in and out of suspend mode a few times today.

apjjr (alex-ourwoods) wrote :

I take it nobody else can reproduce this condition? If so, sounds like I have a botched installation, huh?

Will Cooke (willcooke) wrote :

Sorry to say that I think this a problem isolated to your install. It could be that Docky is what is launching the extra processes. Did you perhaps add something to your session startup script, perhaps there are some scripts in /etc/pm/sleep.d?
Marking this as invalid, it's not an issue with Unity.

Changed in unity:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
apjjr (alex-ourwoods) wrote :

willcooke,
Thanks for the tip. I uninstalled docky and removed the docky scripts from /etc/pm/sleep.d. The problem is gone, now. I liked docky, but not enough to put up with that. I'll look for where to post this bug in docky.

apjjr (alex-ourwoods) wrote :

Thanks to Will Cooke, this problem was tracked down to docky.

affects: unity → docky
Changed in docky:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers