Unity requires restart after enabling "always-show-menus" or LIM

Bug #1411620 reported by Alin Andrei on 2015-01-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Andrea Azzarone
unity (Ubuntu)
Critical
Andrea Azzarone

Bug Description

Unity requires restart after enabling "always-show-menus" or LIM. When I first tested the "always-show-menus" (about 3-4 weeks ago, by using Marco's branch), I don't remember it requiring a restart.

Also, enabling LIM in Ubuntu 14.04 and 14.10 doesn't require restarting Unity but it does with the latest Unity in Ubuntu 15.04 Vivid Vervet.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: unity 7.3.1+15.04.20150115-0ubuntu1
ProcVersionSignature: Ubuntu 3.18.0-9.10-generic 3.18.2
Uname: Linux 3.18.0-9-generic i686
ApportVersion: 2.15.1-0ubuntu2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Fri Jan 16 13:23:00 2015
InstallationDate: Installed on 2015-01-16 (0 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha i386 (20150116)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Alin Andrei (nilarimogard) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → Critical

Are those the only affected options?

As I can't see how things changed in this area.

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

I just checked the show desktop, workspaces and the launcher autohide and they work.

However it looks like the scaling factor stopped working. It works for me only after Unity restart.

Alin Andrei (nilarimogard) wrote :

@Marco: what other features would you like me to test? I can't think of anything else that would require a restart (besides the scaling factor, already tested by Mateusz).

Also, note that I tested this in VirtualBox.

Andrea Azzarone (azzar1) on 2015-01-29
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: New → In Progress
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Critical
milestone: none → 7.3.1
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20150205-0ubuntu1

---------------
unity (7.3.1+15.04.20150205-0ubuntu1) vivid; urgency=medium

  [ Brandon Schaefer ]
  * Try to set the folder permission otherwise Handle permission error.
    (LP: #1418255)

  [ Andrea Azzarone ]
  * Actually connect to changed::* signal in MenuManager.cpp. (LP:
    #1411620)
  * Actually connect to changed::* signal in UnitySettings.cpp. (LP:
    #1408212)
 -- Ubuntu daily release <email address hidden> Thu, 05 Feb 2015 17:27:47 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.2 → 7.3.1
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers