After going to lock screen - sometimes can't log back in as not prompted for password - maybe not a unity bug (and icons can go missing in dash)

Bug #1378919 reported by Páll Haraldsson on 2014-10-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Expected:

Under my name on login screen I should see the field to put in my password. [I took a picture, but probably not to helpful?]

[Just a guess, could it be malloc not returning memory if memory tight?]

uptime
 16:12:36 up 9 days

I update all that matters when I reset. At least unity:
2014-09-29 08:19:43 status installed unity:amd64 7.2.3+14.04.20140826-0ubuntu1
/var/log/dpkg.log.1:2014-09-26 13:50:09 status installed libglib2.0-0:amd64 2.40.2-0ubuntu1
/var/log/dpkg.log.1:2014-09-26 13:50:10 status installed libglib2.0-bin:amd64 2.40.2-0ubuntu1
/var/log/dpkg.log.1:2014-09-29 08:19:42 status installed libglib2.0-0:amd64 2.40.2-0ubuntu1

There are exections that I do not think matters:

See: https://bugs.launchpad.net/unity/+bug/1378879
for bug that I manually submitted. [Then I couldn't run "ubuntu-bug unity" after pressing Win-start button. I still haven't reset machine and still can't but noticed I could from a shell.]

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.3+14.04.20140826-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-37.64-generic 3.13.11.7
Uname: Linux 3.13.0-37-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Wed Oct 8 16:00:40 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-36-generic, x86_64: installed
 bbswitch, 0.7, 3.13.0-37-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-36-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-37-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GF108GL [Quadro 600] [10de:0df8] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:0835]
InstallationDate: Installed on 2014-08-26 (43 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: Dell Inc. Precision T1650
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-37-generic root=UUID=b342558f-2de5-4795-857d-67d51db3a726 ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/31/2013
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A12
dmi.board.name: 0X9M3X
dmi.board.vendor: Dell Inc.
dmi.board.version: A04
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA12:bd01/31/2013:svnDellInc.:pnPrecisionT1650:pvr01:rvnDellInc.:rn0X9M3X:rvrA04:cvnDellInc.:ct6:cvr:
dmi.product.name: Precision T1650
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Mon Sep 29 08:35:11 2014
xserver.configfile: default
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2.1

I'm not sure what all the auto-generated info is telling - supposedly should be saying what I was running and what config when I hit the bug. I assume however it's really telling what I'm runnig at bug-submit? I may have installed libraries but not restarted and then still using older libraries? Note I think that doesn't apply to unity but not sure what unity/compiz used directly or indirectly. Anyway I restarted recently and it's either a current bug or one fixed in last 9 days and can't see that from changelogs of stuff I haven't installed. Can't see changelog (in update-manager) for stuff I've installed after reset of machine but may not have been running when hitting the bug.

Note what I said (including in previous bug submittion) that I restarted unity (and compiz) after the bug and before "ubuntu-bug unity".

I have several packages with this version and that version available (all with this changelog):

Changes for libgbm1 versions:
Installed version: 10.1.3-0ubuntu0.1
Available version: 10.1.3-0ubuntu0.2

Version 10.1.3-0ubuntu0.2:

  [ Timo Aaltonen ]
  * Drop fix-kwin.diff hack, as 10.1.3 has 0380ec467d78f40 which
    fixes the issue properly.

  [ Maarten Lankhorst ]
  * Add fix-svga-ioctl.patch (LP: #1365490)

Possibly suggesting this was memory related (not what follows is after restart):

As I said AFTER restarting Unity I couldn't switch between windows (or so I thought). ALT-TAB didn't pop up the switcher. I later discovered that I the keybord shortcuts to switch seemed to work, just didn't see "what I was doing".

Then after initiating quit in Firefox and while it was shutting down (I guess it was slowly freeing up memory) I COULD switch WITH the graphics and see e.g. my Firefox windows and in the end one and one of them disappearing.

CTRL-ALT-T to start terminal didn't however work - even afterwards and the panel was there with no info on the right or way to reboot. I had to use the virtual console.

I would say this bug is critical for users - to possibly get locked out and - even with a workaround most would not know - not be able to recover.

Note, if the box to input password doesn't appear because memory is low, one possibility would be to try to allocate enough memory before locking the screen. That could however be dangourous and change this bug into a security one if done wrong. If memory runs out BEFORE locking, what would happen? Would the screen then not lock?

summary: - After going to lock screen can't login as not prompted for password -
- maybe not a unity bug
+ After going to lock screen - sometimes can't log back in as not prompted
+ for password - maybe not a unity bug
Changed in unity (Ubuntu):
status: New → Confirmed
Download full text (7.4 KiB)

This might be a "different" bug but I highly doubt it as the original bug behaviour followed:

In the dash (right? When pressing Win-start) all icons suddenly stopped appearing. What had happened just before:

I closed firefox (that had gotten slow) and updated firefox and more:

2014-10-16 14:30:47 upgrade firefox:amd64 34.0~b1+build1-0ubuntu0.14.04.1~ricotz1 34.0~b1+build2-0ubuntu0.14.04.1~ricotz1
2014-10-16 14:30:52 upgrade firefox-locale-en:amd64 34.0~b1+build1-0ubuntu0.14.04.1~ricotz1 34.0~b1+build2-0ubuntu0.14.04.1~ricotz1

2014-10-16 14:30:54 status installed man-db:amd64 2.6.7.1-1ubuntu1
2014-10-16 14:30:54 status installed gnome-menus:amd64 3.10.1-0ubuntu2
2014-10-16 14:30:55 status installed desktop-file-utils:amd64 0.22-1ubuntu1
2014-10-16 14:30:55 status installed bamfdaemon:amd64 0.5.1+14.04.20140409-0ubuntu1
2014-10-16 14:30:56 status installed mime-support:all 3.54ubuntu1
2014-10-16 14:30:59 status installed firefox:amd64 34.0~b1+build2-0ubuntu0.14.04.1~ricotz1
2014-10-16 14:30:59 status installed firefox-locale-en:amd64 34.0~b1+build2-0ubuntu0.14.04.1~ricotz1

Note the icons did not appear afterwards even though firefox was not running - memory may mave been limitted before when firefox was running but should have freed up when I closed it; nothing much else was running so it should not - still - be a problem in the dash. That is, it should not have happened, but in case it did, should have recovered.

[I highly doubt the firefox update or others have anything to do with the icons gone as everything worked after a restart.]

just preceded but is probably really just a coincidence except may have eaten up memory

Then I reopened (the just updated) firefox that worked fine and had to lock the screen. There it was again, no entry field for the password. All was well after a restart before updating anything more. And also after fully updating (I believe these should have prevented the bug if installed according to their changelogs):

2014-10-16 15:08:29 upgrade thunderbird:amd64 1:31.1.2+build1-0ubuntu0.14.04.1 1:31.2.0+build2-0ubuntu0.14.04.1
2014-10-16 15:08:33 upgrade thunderbird-gnome-support:amd64 1:31.1.2+build1-0ubuntu0.14.04.1 1:31.2.0+build2-0ubuntu0.14.04.1
2014-10-16 15:17:15 upgrade bash:amd64 4.3-7ubuntu1.4 4.3-7ubuntu1.5
2014-10-16 15:17:19 upgrade libgl1-mesa-dri:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:21 upgrade libgbm1:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:21 upgrade libgles2-mesa:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:22 upgrade libgl1-mesa-glx:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:23 upgrade libwayland-egl1-mesa:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:23 upgrade libegl1-mesa-drivers:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:24 upgrade libglapi-mesa:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:25 upgrade libopenvg1-mesa:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:26 upgrade libegl1-mesa:amd64 10.1.3-0ubuntu0.1 10.1.3-0ubuntu0.2
2014-10-16 15:17:27 upgrade libvncserver0:amd64 0.9.9+dfsg-1ubuntu1 0.9.9+dfsg-1ubuntu1.1
2014-10-16 15:17:27 upgrade libxatracker2:amd64 10.1.3...

Read more...

I'm not even sure if the lock-screen and dash are the same program (unity?), in case they are different and I just happened to trigger two bugs at once then memory being low (or low in the past) very probably is the common cause. I do not care too much about the dash (file bug separatly?) but the lockscreen is a critical one. I do not know how to flag is as such.

summary: After going to lock screen - sometimes can't log back in as not prompted
- for password - maybe not a unity bug
+ for password - maybe not a unity bug (and icons can go missing in dash)
Changed in unity:
status: New → Confirmed
To post a comment you must log in.