Unable to load entry point in libxpathselect

Bug #1345296 reported by Michael Heuberger on 2014-07-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Stephen M. Webb
unity (Ubuntu)
Low
Unassigned

Bug Description

Hello

When restarting unity I get this error message and it looks like it's related to lightdm. At the moment I cannot select my windows at all and can only use the command line :(

ERROR 2014-07-20 13:19:20 unity.debug.interface DebugDBusInterface.cpp:216 Unable to load entry point in libxpathselect: libxpathselect.so.1.4: cannot open shared object file: No such file or directory

I did a very recent apt-get update && apt-get upgrade with the latest Ubuntu 14 kernel/

Related branches

Sebastien Bacher (seb128) wrote :

thank you for your bug report, what's the output of "dpkg -l | grep libxpathselect" on your installation? do you have any local version installed that could take over the system one?

Changed in lightdm (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

Here you go:

# michael.heuberger at M1 in ~ [19:31:24]
$ dpkg -l | grep libxpathselect

# michael.heuberger at M1 in ~ [19:31:28]

Looks like I didn't have one installed at all. So I installed it manually with `$ sudo apt-get install libxpathselect1.4` ...

Sebastien Bacher (seb128) wrote :

Does installing it resolves your issue? Not sure why unity is not working without that for you, that shouldn't be required

affects: lightdm (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Incomplete → New

I really have no idea. The compiz log is weird. And Unity, LightDM + Compiz all together behave weird sometimes. Diffcult to say.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

This should not be fatal, this library is only needed if unity-autopilot has to be ran.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
Stephen M. Webb (bregma) wrote :

The log message needs to be downgraded to a warning rather than an error.

This bug is reporting two separate and unrelated problems.

(1) Unity is not running on login for the reporter

(2) an error is being reported for a condition that only merits a warning, adding unnecessary noise to the log when attempting to diagnose the first problem.

Neither of these problems is invalid. I will use this bug as reported to track the second problem (changing the severity of the reported problem in the log). Please open a separate new bug if the other problem (Unity does not start) if that problem persists.

Changed in unity (Ubuntu):
status: Invalid → Triaged
Changed in unity:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Stephen M. Webb (bregma)
status: Triaged → In Progress
milestone: none → 7.3.2

The reason why the class this message was set to error was to make sure it would have shown also in standard run, anyway I don't consider this a bug.

In order to get the reason why unity doens't start (and submit a different bug), please, follow the guide in https://wiki.ubuntu.com/Unity/FilingBugs#Getting_a_stack_trace

To get a proper stacktrace

Thanks so much guys, your comments help me a lot. Will follow that guide next time it's happening.

By the way, I removed my old NVIDIA driver and installed a much newer one. Looks like my system is behaving much better now.

There were no hints at all that my NVIDIA driver was outdated. You should add some notification in the OS to tell me to update the graphic drivers!

Changed in unity:
milestone: 7.3.2 → 7.3.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+14.10.20140811-0ubuntu1

---------------
unity (7.3.1+14.10.20140811-0ubuntu1) utopic; urgency=medium

  [ Michal Hruby ]
  * Split out dconf schemas into separate package

  [ Brandon Schaefer ]
  * Make sure we check if the Quicklist or Alt+F1 key nav is open (so we
    can close them) Bore checking if something as a WM grab. As we cant
    open the hud is in Quicklist or KeyNav anymore. (LP: #1353167)

  [ Stephen M. Webb ]
  * Changed log message on failure to open xpathselect library from an
    error to a warning. The xpathselect library is used for
    introspection during automated test runs. It is not an error for
    this library to be unavailable in normal successful operating
    conditions. (LP: #1345296)

  [ Andrea Azzarone ]
  * Add an arrow activator in the lockscreen. (LP: #1332509)
  * Allow a distinct pam config file for greeter and for lock-screen.
    (LP: #1305440)

  [ Marco Trevisan (Treviño) ]
  * Autopilot, Switcher: use correct right/left scroll buttons for
    next/prev mouse selection (LP: #1353383)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor Get monitor position based on absolute
    coordinates, ignoring the pre-multipled scaling factor that Gdk
    applies to all the monitor sizes. In this way we get the proper
    monitor index for absolute coordinates, independently from the
    scaling factor. (LP: #1351591)
  * ApplicationLauncherIcon: make sure we close the dash if DnD is
    accepted And we're about to focus the application window(s) (LP:
    #1350331)
 -- Ubuntu daily release <email address hidden> Mon, 11 Aug 2014 12:31:11 +0000

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Dimitri John Ledkov (xnox) wrote :

Will this be included in trusty?

Stephen M. Webb (bregma) wrote :

I'm not sure if changing the text of a log message from 'ERROR' to 'WARNING' justifies the risk and effort of SRUing into a Ubtunu LTS release.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers