scaling doesn't affect firefox and thunderbird

Bug #1333158 reported by rubo77 on 2014-06-23
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
Undecided
Unassigned
thunderbird (Ubuntu)
Undecided
Unassigned
ubufox (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

If you use "Scale for menu and title bars" in the Displays Tab, this doesn't affect Firefox.

please add this to the Unity Desktop Integration:

about:config in Firefox and search for
layout.css.devPixelsPerPx
set this value to the same scale factor as in unity-control-center

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mozilla-firefox (Ubuntu):
status: New → Confirmed
Changed in mozilla-thunderbird (Ubuntu):
status: New → Confirmed
Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-webapps (Ubuntu):
status: New → Confirmed
affects: mozilla-firefox (Ubuntu) → firefox (Ubuntu)
affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)
affects: unity-control-center (Ubuntu) → unity (Ubuntu)
affects: unity-webapps (Ubuntu) → ubufox (Ubuntu)
Changed in firefox (Ubuntu):
status: Confirmed → Fix Released
Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in ubufox (Ubuntu):
status: Confirmed → Invalid
Changed in firefox:
importance: Unknown → Medium
status: Unknown → Fix Released
Kai Mast (kai-mast) wrote :

Was this fix ever released? This is totally broken for me in wily!!

Kai Mast (kai-mast) wrote :

Also broken for Thunderbird. Could we please reopen this bug?

Kai Mast (kai-mast) wrote :

Oh seems i have to set layout.css.devPixelsPerPx to -1 manually?

Also, doesn't seem to affect the scrollbar.

Kai Mast (kai-mast) wrote :

Can somebody tell me how to get this to work for Thunderbird? I have set layout.css.devPixelsPerPx to -1 but it doesn't change anything...

rubo77 (rubo77) wrote :

A workaround as mentioned further up here in https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1333158/comments/2

see http://askubuntu.com/a/487033/34298

manually open a new tab about:config in Firefox and search for layout.css.devPixelsPerPx set this value to 2 or 1.5 as you wish to adjust the size of the icons

Eugene Romanenko (eros2) wrote :

In unity-control-center I use value of 1.25, and looks like Firefox doesn't respect such value in layout.css.devPixelsPerPx. So I use 1.5 for Firefox.

Anmar Oueja (anmar) wrote :

Isn't there a firefox extension to do that automatically

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.