Unity launcher auto hide fails on screen unlock using "Super+L"

Bug #1320438 reported by Vanamali on 2014-05-17
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
7.2
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone
Trusty
Undecided
Unassigned

Bug Description

[Impact]
The launcher is not properly auto-hidden when locking the screen using Super+L keybinding

[Test case]
1. From Unity Control Center -> Appearance -> Behavior enable the launcher auto-hiding
2. Press Super+L in order to lock the screen
3. Unlock the screen, now the launcher should be hidden

[Regression potential]
Unity might hang when locking the screen (due to the sync compiz call to screen->getCurrentTime() that in some very-rare cases in the past demonstrated to be prone to some race conditions). No case has been recorded so far in this scenario, though.

-----

I use a Compaq cq40 running Trusty. If I lock the screen using the "Super+L" hotkey, upon unlocking the unity launcher bar appears on the screen. I'll have to press "Super" key twice to hide it again (Hitting once brings up the dash home, hitting once again hides the launcher). This is not observed if use the "Ctrl+Alt+L" hotkey. The following are the system details:

@Enigma:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty

@Enigma:~$ uname -a
Linux Enigma 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686 i686 i686 GNU/Linux

@Enigma:~$ sudo apt-cache policy unity
unity:
  Installed: 7.2.0+14.04.20140423-0ubuntu1.2
  Candidate: 7.2.0+14.04.20140423-0ubuntu1.2
  Version table:
 *** 7.2.0+14.04.20140423-0ubuntu1.2 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main i386 Packages
        100 /var/lib/dpkg/status
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

Auto hide is enabled for unity launcher. Is there a way to resolve this annoying behaviour? Thanks!

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1320438/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → unity (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) wrote :

Note: the super key has to be held down long enough for the Launcher to appear: a quick tap of Super-L will lock the screen without invoking the Launcher.

Changed in unity (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity:
importance: Undecided → Medium
milestone: none → 7.3.0
status: New → Triaged
Andrea Azzarone (azzar1) on 2014-05-20
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
tags: added: lockscreen
Andrea Azzarone (azzar1) on 2014-05-20
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140607-0ubuntu1

---------------
unity (7.2.0+14.10.20140607-0ubuntu1) utopic; urgency=low

  [ Chris Townsend ]
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)

  [ Marco Trevisan (Treviño) ]
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general. (LP:
    #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)
 -- Ubuntu daily release <email address hidden> Sat, 07 Jun 2014 16:27:46 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
description: updated

Hello Vanamali, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Vanamali (vanamalishastry) wrote :

Hi everyone

I upgraded the unity package using "sudo apt-get --only-upgrade install unity" (with trusty-proposed source enabled) and restarted the system. The fix passes TEST CASE mentioned. The bug is now fixed! Thank you. Here is the version details of unity:

Enigma:~$ sudo apt-cache policy unity
unity:
  Installed: 7.2.2+14.04.20140714-0ubuntu1
  Candidate: 7.2.2+14.04.20140714-0ubuntu1
  Version table:
 *** 7.2.2+14.04.20140714-0ubuntu1 0
        100 /var/lib/dpkg/status
     7.2.1+14.04.20140513-0ubuntu2 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty-updates/main i386 Packages
     7.2.0+14.04.20140423-0ubuntu1.2 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main i386 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ trusty/main i386 Packages

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
pabouk (pabouk) wrote :

I do not see unity (7.2.2+14.04.20140714-0ubuntu1) neither in trusty-proposed nor in trusty.

$ grep proposed /etc/apt/sources.list
deb http://cz.archive.ubuntu.com/ubuntu/ trusty-proposed universe restricted multiverse main # archive.ubuntu.com tested too

$ sudo apt-get update
...
Reading package lists... Done

$ sudo apt-cache policy unity
unity:
  Installed: 7.2.1+14.04.20140513-0ubuntu2
  Candidate: 7.2.1+14.04.20140513-0ubuntu2
  Version table:
 *** 7.2.1+14.04.20140513-0ubuntu2 0
        500 http://cz.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     7.2.0+14.04.20140423-0ubuntu1.2 0
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://cz.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

$ sudo apt-get -sV install unity/trusty-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'trusty-proposed' for 'unity' was not found

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers