Maximized Window's Title Bar Does Not Merge into Menu Bar after Performing Super+W (window spread) filtering

Bug #1316265 reported by Malcolm Greaves on 2014-05-05
114
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
7.2
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned

Bug Description

[ Impact ]

A maximized application's title bar does not merge into the menu bar once a user has performed Super + W (window slide). Note that if one does not do Super+E, then the bars to merge together. However, once Super+E has been performed, this bug persists for the lifetime of the windowed application. If the application is restarted after doing Super+E, then the bug is gone. Thus, it seems like Super+E introduces this bug for the lifetime of the windowed application.

Expected behavior: Maximized window's title bar is merged into menu bar.
Observed: Does not occur after Super+W is performed.

[ Test Case ]

(1) Open one or more Terminals, place one in maximized mode (eg. by using control-super-up or clicking the embiggen button).
(2) use super-W to enter the spread mode
(3) select the maximized terminal window
(4) lookee lookee, separate title bars without the fix!

[ Regression Potential ]

Any change to the Unity desktop shell could potentially introduce a new crash or hangup.

[ Additional Info ]

The Unity SRU fix for Ubuntu 14.04 LTS was cherry-picked from upstream Unity where it has been a part of the Ubuntu "Vivid Vervet" dev release for some time now and has demonstrated no regressions.

Related branches

I noticed that this does not effect google-chrome. Though, that might have more to do with the fact that google-chrome doesn't have a proper title bar...

So, this actually kinda worked itself out. After rebooting my computer, I no longer have this maximization problem.

Daniel (internalkernel) wrote :

I can confirm this behaviour on a fresh install of 14.04 - although "Window Spread" doesn't seem to trigger it in my setup. It seems to just happen at certain points, and closing the window and reopening solves the issue temporarily.

summary: Maximized Window's Title Bar Does Not Merge into Menu Bar after
- Performing Super+E (window spread)
+ Performing Super+W (window spread)
description: updated
Changed in unity (Ubuntu):
status: New → Confirmed
summary: Maximized Window's Title Bar Does Not Merge into Menu Bar after
- Performing Super+W (window spread)
+ Performing Super+W (window spread) filtering
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.2.1
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Charl P. Botha (cpbotha) wrote :

On my Ubuntu 14.04 setup I am definitely seeing an interaction between using the spread function and whether windows maximize correctly or not.

However, it is slightly different from the OP.

It very often happens that a window shows the incorrect behaviour (i.e. maximizing does NOT merge its menubar with the main menubar). If I then activate spread, and then select THAT misbehaving window, it will maximize correctly. After this, other windows then show correct or incorrect behaviour, but I've not been able to find a pattern in that.

Jooj (jooj) wrote :

Same thing here. The important thing to consider to reproduce the bug is to use the Keyboard only. When I select my windows in spread mode with the mouse, there is no problem at all.

The problem comes only when I use the "type to select" new feature. The selected windows is ok, but all the other are not maximized correctly anymore (but it can be seen only with Alt-Tab, if I use the mouse OR the "type to select" feature, the new windows selected is ok).

Adolfo Jayme (fitojb) on 2014-06-18
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Lars Schütze (lschuetze) wrote :

I git the same problem. It behaves exactly as #6 describes. Using Super+W again and select the bugging application makes the title bar merge with the top bar as intented.

Bruno Nova (brunonova) wrote :

Same problem here.

I have seen the same behavior described in #7.
The title bar problem occurs when I use spread (Super+W), type something until only 1 window appears, and select it (using either keyboard or mouse).
This breaks the title bar integration with the top panel for all windows (even those not maximized, visible when I then try to maximize them) EXCEPT for the window that I selected in spread mode.

This happens with both global menu and locally integrated menus.

The fix is easy for me, though. Just open the spread mode (Super+W) and select any window or press Escape, and the problem is fixed for all windows.

Also, I've seen the title in the top bar sometimes appear below the close/minimize/maximize (with locally integrated menus, at least) after using the spread mode. But it's not very consistent (and it's probably a different bug).

Changed in unity:
milestone: 7.2.2 → 7.2.3
Changed in unity:
milestone: 7.2.3 → 7.3.1
Adis (adis-osmonov) wrote :

I have the same issue. First it was with Google Chrome, but today it happened with skype window.

Its solved when I do `super + w` on problem window.

Tito (tito-webtito) wrote :

I'm still having this issue in Utopic 14.10, Unity 7.3.1

The only fix I've found is deactivating Spread in Unity Tweaks.

Andrea Azzarone (azzar1) on 2014-10-22
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Ali Najafi (alinajafi) wrote :

Comments #7 and #9 are describing a different bug related to using keyboard on window spread:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1386714

This bug occurs for me when I disabled and re-enabled window spread in Unity Tweak Tool. I could solve the problem in a strange way:
1. selected Restore Settings of window spread on Unity Tweak Tool;
2. disabled and re-enabled the window spread on Unity Tweak Tool;
Suddenly Ubuntu Unity Plugin got disabled and I lost window decorations and indicators.
3. I opened a Terminal, enter `ccsm` to open CompizConfig Settings Manager;
4. noticed "Gnome Compatibility" and "Window Decorations" are enabled, both of which conflict with Unity Plugin;
5. enabled Unity Plugin and resolve conflicts with those two.

Now I can use window spread without problem except the type-to-search which I've described in lp: 1386714.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.1+15.04.20141128-0ubuntu1

---------------
unity (7.3.1+15.04.20141128-0ubuntu1) vivid; urgency=low

  [ Andrea Azzarone ]
  * Unmap all windows during shutdown. (LP: #1370017, #1375271)
  * Make sure GetScreenGeometry returns the correct value. (LP:
    #1374785)

  [ Marco Trevisan (Treviño) ]
  * Decorated Window: still paint decorations if on transformated
    windows in different workspaces (LP: #1383468)
  * DecoratedWindow: make sure we always set a _NET_FRAME_EXTENTS for
    windows that requested it
  * UnityScreen: when filtering out windows in spread, make sure we
    unscale them (LP: #1316265)
  * PanelMenuView: ensure that proper window tiles and buttons are shown
    at the right place (LP: #1384958, #1384910, #1385285)
  * PanelService: inject special key events back to the root window when
    a menu is opened
  * PanelService: use gdbus to notfy upstart of service start/stop
 -- Ubuntu daily release <email address hidden> Fri, 28 Nov 2014 12:56:28 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Bruno Nova (brunonova) wrote :

Great! I hope these fixes will be backported to Trusty and Utopic!

Hello Malcolm, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.4+14.04.20141217-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Bruno Nova (brunonova) wrote :

I've tested the trusty-proposed update in a VirtualBox virtual machine (version 7.2.4+14.04.20141217-0ubuntu1).

The update fixes the issue.
Now when I press Super+W, type something until only 1 window is shown (filter) and select the window, the title bars of all of the maximized windows are correctly merged with the top bar.
It also works when the windows are spread through multiple workspaces and I use Super+Shift+W to view all of the windows.
And it works both with the global menu and with locally integrated menus.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.4+14.04.20141217-0ubuntu1

---------------
unity (7.2.4+14.04.20141217-0ubuntu1) trusty; urgency=medium

  [ Andrea Azzarone ]
  * Share lockscreen password between screens (lp: #1308540)
  * Allow a distinct pam config file for greeter and for lock-screen.
    (lp: #1305440)
  * Add an arrow activator in the lockscreen. (lp: #1332509)
  * Make sure GetScreenGeometry returns the correct value (lp: #1374785).
  * unmapped all windows prior to shutdown (lp: #1370017) (lp: #1375271)

  [ Brandon Schaefer ]
  * fix tooltip for the "Show Desktop / Restore Windows" icon in the Alt-Tab
    switcher (lp: #1237132)
  * Use CONFIG instead of CACHE to store the first_run.stamp (lp: #1328677)

  [ Eleni Maria Stea ]
  * LayoutSystem: make sure the exposed open windows are displayed in the
    preserved order (lp: #1349281).

  [ handsome_feng ]
  * added support for getting the distro name from /etc/os-release
    (lp: #1329584)

  [ Iain Lane ]
  * When grabbing keys, try prefixing "XF86" if the key isn't found. GNOME
    gives us unprefixed keys sometimes (lp: #1302885).

  [ Marco Trevisan (Treviño) ]
  * make the Launcher icon count badge width depend on the text value width
    and scaling (lp: #1353070) (lp: #1354498) (lp: #796527) (lp: #1066971)
    (lp: #1361713)
  * DecoratedWindow: make edges independent from borders and properly update
    them on actions change (lp: #1276177), (lp: #1299741), (lp: #1301776),
    (lp: #1324104), (lp: #1364225), (lp: #1373695)
  * Lockscreen: scale the UI elements based on current monitor scaling
    (lp: #1292218)
  * UnityScreen: when filtering out windows in spread, make sure we unscale
    them (lp: #1316265).
  * PanelMenuView: ensure that proper window tiles and buttons are shown at
    the right place (lp: #1384910) (lp: #1384958) (lp: #1385285)
  * SearchBar, ActionButtons, IconRenderer: include the font scaling when
    scaling textual items (lp: #1332947) (lp: #1361751) (lp: #1362162)
    (lp: #1362346).
  * ApplicationLauncherIcon: make sure we close the dash if DnD is accepted
    and the application window is about to be focused (lp: #1350331).
  * SwitcherView: set progress on icon render args (lp: #1361679).
  * LockScreenController: wait for the primary shield to get the grab
    before setting the session locked (lp: #1368427) (lp: #1371764).
  * added decorations to windows in non-focused workspaces (lp: #1383468)

  [ Stephen M. Webb ]
  * updated the unity(1) manpage to match the actual command (lp: #1059275)
  * bumped package version to match upstream

  [ Marco Trevisan (Treviño) ]
  * Preparing for unity 7.2.4
 -- Ubuntu daily release <email address hidden> Wed, 17 Dec 2014 20:52:10 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
tags: added: rls-w-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers