Full screen terminal sometimes allows "click-through" which shouldn't happen

Bug #1313895 reported by LGB [Gábor Lénárt] on 2014-04-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I work with terminal windows (gnome-terminal) a lot. I have 8 workspaces and multiple terminals on each of them. Sometimes I need to focus on a more complicated issue eg with a server I am logged on via ssh on a terminal, in this case I use full screen mode. Initially it works. However especially when I switch away from that workspace and then back I often have the situation that everything looks totally OK, but if I try to select text on the top of my terminal window (which needs a click first) the panel rises over as somehow it gets the click it seems (even if I see the full screen window which covers all of the screen). It can be seen even before the click as the text cursor changes into pointer where the panel is (at the top of the screen). Sometimes even the side launcher can be seen (it's configured to auto hide in my case) to come up (since window is configured to be somewhat transparent so I can see what's behind) if I move the mouse at the left edge of the screen.

Maybe related but I am not sure: if I have a full screen terminal window which has the focus (so covers all the screen) but another (non-fullscreen) terminal window behind, and I switch workspace away then back, sometimes I see the background window raised over the full screen one, and I don't know why as the fullscreen window was on the top before.

Sorry, it's not so easy to describe the problem especially not in a language not native for me. Also it's not happens always, but quite frequently.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140423-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Mon Apr 28 21:49:58 2014
DistUpgraded: 2013-10-18 20:44:53,416 DEBUG enabling apt cron job
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.3.10, 3.13.0-23-generic, i686: installed
 virtualbox, 4.3.10, 3.13.0-24-generic, i686: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21dd]
InstallationDate: Installed on 2012-03-03 (786 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
Lsusb:
 Bus 002 Device 003: ID 04f2:b228 Chicony Electronics Co., Ltd
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 5016NW6
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=8df578aa-47e3-483f-b694-bf7effd24b7d ro i915.semaphores=0 quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to trusty on 2013-10-18 (192 days ago)
dmi.bios.date: 11/04/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8GET38WW (1.15 )
dmi.board.name: 5016NW6
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8GET38WW(1.15):bd11/04/2011:svnLENOVO:pn5016NW6:pvrThinkPadL520:rvnLENOVO:rn5016NW6:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 5016NW6
dmi.product.version: ThinkPad L520
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11+14.04.20140423-0ubuntu1
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Mon Apr 28 18:49:01 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 9196
 vendor AUO
xserver.version: 2:1.15.1-0ubuntu2

LGB [Gábor Lénárt] (lgb) wrote :
To post a comment you must log in.