Fullscreen window set to "Always on Top" in single-monitor will hide the lockscreen

Bug #1313280 reported by Michael Aquilina on 2014-04-27
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
7.2
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)
Trusty
Undecided
Unassigned

Bug Description

[Impact]
A fullscreen window set to "always on top" hides the lockscreem.

[Test Case]
(1) Open a video in Totem
(2) Right-click on the titlebar and set Totem to "Always on Top"
(3) Make Totem full screen (eg. with the F11 key or clicking on the control)
(4) Manually Lock the screen using Super+L

(5) The lockscreen should go above the Totem window now.

If you don't lock it manually and just pause the video and let it lock automatically this will show the same behavior.

The same behavior occurs with any application that can enter full screen mode.

[Regression Potential]Two cases may potentially source regressions.
(1) windows that need to appear above the lockscreen, such as on-screen keyboards,(2) applications presenting fullscreen windows using unusual or non-standard toolkits.It is unlikely that regressions in either of these cases would be introduced by this bug fix, but rather would be pre-existing problems not fixed here.
(3) Indicator menus might be not being drawn

Related branches

description: updated
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. I can't confirm that issue here though

tags: added: lockscreen
Changed in unity (Ubuntu):
importance: Undecided → Low

Neither do I.

I'll try get a video of the bug in action when im home. Is there any other information that could be useful to provide?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

I was able to reproduce that bug with Totem, VLC and Chrome. I didn't test other programs.

The key to reproduce is the "Always on Top" setting. You have to right click the window decoration and check that setting and then just go to fullscreen and lock the screen. You will see the video or webpage and other things in a bleed through mode and no elements of the lock screen.

Typing the password unlocks screen.

I don't confirm the problem occuring when the screen locks automatically after timeout. I couldn't reproduce that part of Bug Description.

Ok, same seems to happen with youtube flash videos... The reason way I wasn't getting this is becasue it doesn't seem to happen in multi-monitor mode.

Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 7.2.1
summary: - Fullscreen window set to "Always on Top" will hide the lockscreen
+ Fullscreen window set to "Always on Top" in single-monitor will hide the
+ lockscreen
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress

I believe this bug affects me as well. Here's what happened when I locked a flash video in fullscreen:

http://i.imgur.com/u2iFs3G.jpg

Stephen M. Webb (bregma) on 2014-05-07
description: updated
description: updated
Stephen M. Webb (bregma) on 2014-05-07
Changed in unity:
milestone: 7.2.1 → 7.3.0
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140512.4-0ubuntu1

---------------
unity (7.2.0+14.10.20140512.4-0ubuntu1) utopic; urgency=low

  [ Stephen M. Webb ]
  * lockscreen/LockScreenAccelerators.h: added required header for
    std:vector definition
  * disabled precompiled headers on arm64 Ubuntu package builds (LP:
    #1317276)

  [ Brandon Schaefer ]
  * Set the max width, so our static text wraps. So we don't end up
    rendering text out of the view area. (LP: #1312749)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: toggle activation of all the unity compiz actions when
    locking the screen Also, make sure that the lockscreen views are
    treated as "always-on-front" windows by nux (and this applies to
    both visibility and events).
  * PanelService: emit an invalid EntryActivated signal if the menu
    hasn't actually been shown In addition, if the menu is not visible
    after the first popup call, try to show a menu without keyboard
    focus. This will make possible to see menus also when there's a key-
    grab (although they will be without keyboard support). Finally,
    reset the menu state, if that failed.
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * UnityScreen: don't try to show Dash/Hud if the screen is grabbed
    Also move the dash opening out from LauncherController, and get rid
    of UBus as first initialization source, as it can only slow things
    down here. (LP: #741869)
  * PluginAdapter: make sure we don't try to call an invalid
    initiate/terminate callback function (LP: #1221673)
  * DebugDBusInterface: match properties if they are in the AP array
    form [<type>, <value>] (LP: #1307748)

  [ William Hua ]
  * Add proper support for modifier-only shortcuts on the lock screen.
    (LP: #1291461)

  [ Jinkyu Yi ]
  * Dash: Fix problem at checking blacklisted unicode range (LP:
    #1251193)

  [ Andrea Azzarone ]
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)
 -- Ubuntu daily release <email address hidden> Mon, 12 May 2014 22:03:27 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello KillaW0lf04, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

Just installed the from the proposed repository and made sure that the bug fix was included within the updates.

I restarted my laptop and repeated the same steps stated in the test case.

It seems to be solved in some cases but there are quite a few times where it still occurs for me. In particular I am testing this out on totem in fullscreen with it set to "Always On Top".

tags: added: verification-failed
removed: verification-needed

I confirm that the bug isn't fixed.

I was able to reproduce it with Google Chrome, Totem and VLC (I didn't test others) fullscreen windows set to "Always on Top" with single monitor.

Sorry, I've just noticed that for some reason this fix has not been included in the SRU package that just landed in unity proposed, so the fact it fails the verification is normal.

Removing the verification-failed/needed since the fix for this bug mistakingly missed getting in the SRU. The next SRU will contain this fix. Sorry about the confusion.

tags: removed: verification-failed
Changed in unity (Ubuntu Trusty):
status: Fix Committed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Sebastien Bacher (seb128) wrote :

setting as verification-done so the SRU gets validated, we can untag/reopen the bug once it's copied to updates

tags: added: verification-done
Sebastien Bacher (seb128) wrote :

the SRU got copied, untagging

tags: removed: verification-done
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
description: updated
Chris J Arges (arges) wrote :

Hello KillaW0lf04, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

Packages from trusty-proposed resolve this bug.

I've checked with Totem, VLC, Firefox and Opera-developer. Also the indicators were drawn in lockscreen.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers