After locking screen there is no input field to type password for unlock

Bug #1311316 reported by LGB [Gábor Lénárt] on 2014-04-22
896
This bug affects 173 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
7.2
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone
Nominated for Trusty by Marco Trevisan (Treviño)
Nominated for Xenial by Marco Trevisan (Treviño)
Xenial
Undecided
Unassigned

Bug Description

*** IMPORTANT **

*** The fix is not included in TRUSTY. Will be included with next SRU. ***

If you can reproduce this bug please be sure to provide the following info:
1. Do you use a multi-head setup? If yes, using just one monitor fixes the issue?
2. Can you reproduce all the time?
3. Do you use ldap? If yes, using gnome-screensaver fix the issue (see comment #115) can you still reproduce that?
4. Please consider posting /var/log/auth.log (at least part of it, should not contain sensitive information)
5. Please specify the unity version
*** END IMPORTANT **

[Impact]

Sometimes (but not always) after locking the screen there is the situation not having any input field where I can type the password to unlock the session again. The shaded gray area simply does not have the input field. I can't do anything, I have to switch to text console and stop/start lightdm service to cure the problem loosing all of my session :(

[Test case]

1. Lock/unlock the screen multiple times
2. Expect the lockscreen password input field stay there

[Regression Potential]

Lockscreen shield isn't properly shown. Or fails to login.

ProblemType: BugDistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140416-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
ApportVersion: 2.14.1-0ubuntu3
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Tue Apr 22 22:17:57 2014
InstallationDate: Installed on 2012-03-03 (780 days ago)InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)SourcePackage: unity
UpgradeStatus: Upgraded to trusty on 2013-10-18 (186 days ago)

Related branches

LGB [Gábor Lénárt] (lgb) wrote :
LGB [Gábor Lénárt] (lgb) wrote :

Here is a quite bad quality photo (taken by cellphone) to demonstrate the problem.

LGB [Gábor Lénárt] (lgb) wrote :

The whole screen in case of problem.

Andrea Azzarone (azzar1) wrote :

Looks like there is some problem with your pam configuration. Did you play with it?

LGB [Gábor Lénárt] (lgb) wrote :

I don't think so, at least not recently but this install is quite old and was upgraged during the time to newer and newer releases. However what made me thinking is the fact that it does not always happens only sometimes. Also, it's the situation only since some days it didn't happened before, so some kind of upgrade since then can cause it (and I am sure there was no "pam game" since then at least).

tags: added: lockscreen
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
LGB [Gábor Lénárt] (lgb) wrote :

Just noticed: sometimes (if the problem occurs) I see the screen I've posted after locking the screen (ctrl-alt-l). If I don't touch the keyboard and mouse the screen fades into black and after some seconds I see the login screen presented with full bright again where I can unlock the session. I don't know too well the new features of the unity desktop, but I guess the first (problematic) screen may be the unity-locker and only that have the problem. Moreover, it's kinda strange for me that I lock my computer (notebook) so I expect that it should save power to turn off display, fade to black etc, but after it happens I get the login screen where I can unlock my session but it's not faded etc. I try to adjust settings in gnome control center and unity control center (I am not sure they are some or not) but I couldn't figure out what settings affect these exactly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)

@LGB [Gábor Lénárt] that you don't see input field doesn't mean that you can't type password and unlock the screen.

I was trying to reproduce a bug that some people described about fullscreen YouTube videos showing on top of Unity lock screen. I managed to get once a screen locked which would flash and without text input field visible just like on your screenshot but I just typed my password and unlock normally.

theghost (theghost) wrote :

Also affected randomly. For me its impossible to unlock again. Even if I type my password blindly.

Joan CiberSheep (cibersheep) wrote :

I just noticed two things:
 - If focus is on a text file when Unity locks, when you type the password is been typed in the text file (even if it's not visible until you manage to unlock clicking on top menu and clicking again in the password area)

 - Sometimes, visualizing a fullscreen video, system lock but it keeps showing one of the frames of the video making dificult to unlock. The way I found to unlock is to press ctrl+alt+L to lock and type the password

Dan Kegel (dank) wrote :

I had this with 14.04. Seemed to get better after I installed the proprietary nvidia drivers?

Margarita Manterola (marga-9) wrote :

I'm having this issue as well. It's not very frequent but it has happens once in a while.

I have a machine with an NVIDIA card, using proprietary nvidia drivers, dual monitor display. Since it's not very often, I haven't yet been able to correlate it with any specific event.

My pam configuration is customized, but I don't believe it's related at all, since most of the time it works fine.

Vojtěch Látal (vojtik) wrote :

I'm also affected. It was not acceptable for me to loose my work, so I was looking for workaround. And I have found it:
What I did:
0) Switch to VT1 using Ctrl + Alt + F1, logged in
1) killall light-locker
2) killall gnome-screensaver
3) killall /usr/lib/unity/unity-panel-service
4) /usr/lib/unity/unity-panel-service --inhibit logout
5) unity --replace

I think number five (number 0 prepended) solves the problem, but in order to be sure, I have added another tries.

Evan Powell (evanjpowell) wrote :

I work around this in the same way vojtik does:

0) Switch to VT1 using Ctrl + Alt + F1, logged in
5) unity --replace

I am running an AMD card in a dual-screen configuration on a new 14.04 install.

Vojtěch Látal (vojtik) wrote :

Evan is right.

If you find top panel missing icons and/or menu-in-window-header missing, try following command:
compiz --replace

I have found somewhere this command prepended by 'setsid ', but don't know if it changes anything.

Luis Alberto Pabón (copong) wrote :

Same here, 14.04 64bit, dual monitors.

Alexander Kops (alexkops) wrote :

Here as well, fresh install of 14.04 on a Dell Latitude notebook (Intel graphics) with the internal screen and two external screens being in use.
Happens randomly as it seems.
Only one time I didn't get password field but at least the cogwheel icon on the top right, so I could select "switch user".
But most of the time there are no user interaction elements whatsover.

Mark Russell (marrusl) wrote :

I've had this about 3 or 4 times as well. Also dual monitors (nvidia binary driver, 64bit).

Henry Weismann (henryweismann) wrote :

I get this once every couple days. Always from the lock screen. I also have a dual monitor setup. (Intel HD Graphics 4000) System 76 Gazelle Professional ( gazp8 )

I've had this happen twice. Each time was slightly different.

I have dual monitors and the first time it happened, I moved my mouse to the other screen. When the user login box switched to the screen my cursor was on, the password field appeared. When I moved my mouse back to the second monitor, this time, the password field was there.

 The second time it happened, both screens were the same with no password field. Moving the cursor back and forth never reloaded the password field and I had to take other measures to log in.

ubuntu-tester (ubuntu-tester1) wrote :

I also get this once every couple days. Always from the lock screen.

Tested on DELL OptiPlex 755 with :
- 01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV610 [Radeon HD 2400 PRO/XT] [1002:94c1] : free radeon driver with dual screen,
- 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107GL [Quadro K2000] [10de:0ffe] (rev a1) : nvidia proprietary driver 331.79 with dual screen.

It's an important bug to deploy Ubuntu 14.04.

ubuntu-tester (ubuntu-tester1) wrote :

I get this issue once every couple days so if you need specific information or if you need me to perform tests, don't hesitate to contact me.

Andrew Shaffer (darawk) wrote :

I am also having this issue. Dual monitor setup, nvidia card.

I've also noticed that it seems to happen pretty often if my screen locks when I have a chrome PDF-viewer window open on one or both of my screens.

Michael (mikhail-w) wrote :

I am also having this issue yesterday second time. Use VirtualBox. I have only one monitor and Intel integrated videocard.

Michael (mikhail-w) wrote :

And I have a ploblem, when VirtualBox window is active, I lock screen. When I want to type my password, it doesn't type in password field, it types in VirtualBox.

Changed in unity:
status: New → Triaged
LGB [Gábor Lénárt] (lgb) wrote :

Another observation: in case of problem also shutdown does not work sometimes, it simply doesn't do anything, even if try multiple times. The only solution then: switch to text console, log in, give command "init 0" as root.

nvrmndr (nvrmndr) wrote :

Affects me as well. Dual monitors, nVidia GT640.

Andrew Fry (afry308) wrote :

Same issue here. The solution posted above get's my logged in:

0) Switch to VT1 using Ctrl + Alt + F1, logged in
5) unity --replace

This one isn't helping me get the "top" menu back:
compiz --replace

Thomas (9-ubuntu-g) wrote :

I've also encountered this issue with a dual monitor setup.
I only seem to trigger it when locking my Dell Latitude E6530 (NVIDIA Corporation GF108GLM [NVS 5200M]) with Ubuntu 14.04.1. Sadly I cannot reproduce it reliably, but I trigger it in maybe 5% of the cases.

Kostas Ubuntoulis (rondinos) wrote :

I have the same issue here, Ubuntu 14.04.1 64bit (3.13.0-33-generic) with Unity, using Dual screen and NVS 300, Nvidia proprietory drivers v 340.24.

Sometimes in the past I was able to get the input password box to appear when I was moving the mouse around from one screen to another. This was causing the login box to change screens and sometimes the input would come back. Lately this doesn't work for me any more, and the only work around is the unity --replace command from a terminal. I also noticed that when I come back to my session my gnome-terminal is completely lost in the background and if it was minimized I cannot bring it back. I don't know if this is related.

John Hoare (jhoare) wrote :

I am also having this issue. I attempted the "unity --replace" workaround, and it appeared to kill my existing session.

I'd also like to note that I use VMWare workstation (my machine with the problem is the host) and if I leave my cursor in my vmware window the screensaver doesn't activate until I move my mouse out of VMware. This may be unreleated but I wanted to mention it in case it is meaningful to others.

HP EliteBook 8770w, Ubuntu 14.04.1 64bit, Nvidia Proprietary drivers: 331.38.

kovinet (borut-kovacec) wrote :

It also affects me. Dual monitors, 64 bit, Graphics: Intel® Ivybridge Desktop - also only every now and then, not always.

When I can't login and try with 'unity --replace' in console (pressing Ctrl + Alt + F1) I can login again but top menu is missing in all applications, but 'compiz --replace' doesn't work (it prints some lines one of them being: Fatal error: Coulnd't open display).

But if I do Ctrl + Alt + F1 and run 'unity --replace', then go back to unity with Ctrl + Alt + F7, then I can login - and after I am logged in in unity and open a Terminal there and run 'compiz --replace' then also top menu comes back.

Margarita Manterola (marga-9) wrote :

This is happening much more often since the latest Unity releases. There were several changes done to the lockscreen and it seems that these changes made this problem more frequent.

It seems to be particularly frequent when the machine is under heavy load (i.e. compiling stuff), which seems to point to some kind of race condition that is made worse when things are going slow.

Alex Krass (alexkrass) wrote :

This happen sometimes to me.
Dual monitors, 64 bit.

Ermolin Ilya (ermolinis) wrote :

Same thing.
Dual monitors, ivi brige + nvidia (open source driver).

There is many people with such defect affected - we can add debug for some component to triangulate this bug?

Jeffrey Nappi (spamage) wrote :

I am also experiencing this every couple days.

Dual Monitors on Intel HD Graphics 4000 (Lenovo Thinkpad T530 w/ dock)

I am affected as well. Dual monitors, Intel graphics, Chrome was open. Happens randomly. Sometime the password box is still visible on one screen, but not on the other. When it disappears on both screens, only the unity --replace and compiz --replace methods mentioned above will allow me to get back to my desktop.

Sebastian (sebnozzi) wrote :

Also affected. Running on dual monitors.
Intel graphics, Lenovo X230. Ubuntu 14.04.
Unity 7.2.2+14.04.20140714-0ubuntu1.1

Matt Zuba (matt-mattzuba) wrote :

Let me add a small twist to this...

I have a triple-screen setup on an ATI card. I have the same issue above, but I also have another...

Sometimes when I come to my computer in the morning for work, one screen will not have the input field, but two others will. If I mis-type my password in one of the working screens, the input field then disappears. If I type it incorrectly in the other window, the input field disappears on that one as well. Then I'm back to the issue in this bug. But if I do type it correctly on either of the working monitors, then sometimes I'll get another lock screen, and sometimes I'll get my desktop.

Additionally, if I do end up in a spot where I have visible fields, if I restart lightdm and then login, then I get the lock screen again after logging in and have to enter my password again.

The Unity Lockscreen has been a huge nightmare for me...

Changed in unity:
assignee: Andrea Azzarone (andyrock) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.3.1
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Committed
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2014-12-05
Changed in unity:
status: Fix Committed → Confirmed
Andrea Azzarone (azzar1) on 2014-12-09
description: updated
Andrea Azzarone (azzar1) on 2014-12-11
description: updated
Andrea Azzarone (azzar1) on 2014-12-11
description: updated
Changed in unity:
status: Confirmed → Fix Committed
Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
status: Fix Committed → Fix Released
tags: added: rls-w-incoming
Klemen (klemenk) on 2017-07-29
information type: Public → Public Security
167 comments hidden view all 247 comments
Rael Gugelmin Cunha (rael-gc) wrote :

1. Yes, multi-head setup.
2. It appears to happen always when I have users switching and locking screen (my wife and kids uses my machine and I see this happen when they start to use).
3. Never used ldap in this machine.
4. /var/log/auth.log:

Jul 24 11:36:10 rael-m3800 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 24 11:36:10 rael-m3800 lightdm: PAM adding faulty module: pam_kwallet.so
Jul 24 11:36:10 rael-m3800 lightdm: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jul 24 11:36:10 rael-m3800 lightdm: PAM adding faulty module: pam_kwallet5.so
Jul 24 11:36:10 rael-m3800 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "gabriel"
Jul 24 11:36:10 rael-m3800 lightdm: pam_unix(lightdm:auth): conversation failed
Jul 24 11:36:10 rael-m3800 lightdm: pam_unix(lightdm:auth): auth could not identify password for [gabriel]

5. unity 7.4.0

Andrea Azzarone (azzar1) wrote :

Hi all,

can you please tell me if when this happens the top panel (in the lockscreen) is correctly displayed with all the indicators like in the attached screenshot. I'm trying to understand if this is a rendering issue or a PAM one.

Thanks!

information type: Public Security → Public
Mark Elston (melston1777) wrote :

I'm seeing the issue as well and I see the top panel shows up like in your screenshot.

Rael Gugelmin Cunha (rael-gc) wrote :

@Andrea, yes, indicators are properly displayed. The only missing item in the screen is the field to input the password.

Andrea Azzarone (azzar1) wrote :

@rael-gc what about username as per screenshot? I'm trying to understand if somehow unity fails to start the pam auth flow.

Mark Elston (melston1777) wrote :

My lock screen simply shows the system name. Not the user name.

Mark Elston (melston1777) wrote :

Here is a capture of the top row of the lock screen.

And, it seems that neither the `compiz --replace` nor the `unity --replace` works for me. I get back my desktop but can't interact with it.

Download full text (4.4 KiB)

can you post a capture of the full lockscreen?

El 30 jul. 2017 4:20, "Mark Elston" <email address hidden> escribió:

> Here is a capture of the top row of the lock screen.
>
> And, it seems that neither the `compiz --replace` nor the `unity
> --replace` works for me. I get back my desktop but can't interact with
> it.
>
> ** Attachment added: "Top row of lock screen"
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/
> 1311316/+attachment/4924108/+files/login-top.png
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1311316
>
> Title:
> After locking screen there is no input field to type password for
> unlock
>
> Status in Unity:
> Fix Released
> Status in Unity 7.2 series:
> Fix Released
> Status in unity package in Ubuntu:
> Fix Released
>
> Bug description:
> *** IMPORTANT **
>
> *** The fix is not included in TRUSTY. Will be included with next SRU.
> ***
>
> If you can reproduce this bug please be sure to provide the following
> info:
> 1. Do you use a multi-head setup? If yes, using just one monitor fixes
> the issue?
> 2. Can you reproduce all the time?
> 3. Do you use ldap? If yes, using gnome-screensaver fix the issue (see
> comment #115) can you still reproduce that?
> 4. Please consider posting /var/log/auth.log (at least part of it,
> should not contain sensitive information)
> 5. Please specify the unity version
> *** END IMPORTANT **
>
> Sometimes (but not always) after locking the screen there is the
> situation not having any input field where I can type the password to
> unlock the session again. The shaded gray area simply does not have
> the input field. I can't do anything, I have to switch to text console
> and stop/start lightdm service to cure the problem loosing all of my
> session :(
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.2.0+14.04.20140416-0ubuntu1
> ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
> Uname: Linux 3.13.0-24-generic i686
> ApportVersion: 2.14.1-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/
> screen0/options/active_plugins'
> CurrentDesktop: Unity
> Date: Tue Apr 22 22:17:57 2014
> InstallationDate: Installed on 2012-03-03 (780 days ago)
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-10-18 (186 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1311316/+subscriptions
>
> Launchpad-Notification-Type: bug
> Launchpad-Bug: product=unity; milestone=7.3.1; status=Fix Released;
> importance=High; <email address hidden>;
> Launchpad-Bug: product=unity; productseries=7.2; status=Fix Released;
> importance=High; <email address hidden>;
> Launchpad-Bug: distribution=ubuntu; sourcepackage=unity;
> component=universe; status=Fix Released; importance=High; assignee=
> <email address hidden>;
> Launchpad-Bug-Tags: apport-bug i386 lockscreen rls-w-incoming trusty
> Launchpad-Bug-Information-Type: Public
> Laun...

Read more...

Rael Gugelmin Cunha (rael-gc) wrote :

@Andrea, yes, the username is properly displayed above the missing password input field.

@Mark, you have to:

1. go to a TTY (press Ctrl + Alt + F1 to open it) and run this command: sudo loginctl unlock-sessions
2. get back to X.org (press Ctrl + Alt + F7)
3. now restart compiz with: compiz --replace

Rael Gugelmin Cunha (rael-gc) wrote :

@Andrea, sure, as soon as I face this issue I'll capture it.

Rael Gugelmin Cunha (rael-gc) wrote :

@Andrea, sorry, just now I got able to take a shot from the screen using my mobile. And you were right: no icons in indicators.

Yesterday, several users logged in my machine, then, during the night, screenlock was activated.

Andrea Azzarone (azzar1) wrote :

The lack of indicators might indicate a problem on the upstart user session. This upstart failure can confuse PAM as well. I'm going to propose a branch that will allow the system to lock if there are such types of failures.

Rael Gugelmin Cunha (rael-gc) wrote :

Not sure if this is important, but I can notice the following: if I switch to the second (or any other than me) logged user (Ctrl + Alt + F8), it works normally. I can, then, in second Xorg session, select my user from indicators and then log in.

And, I'm not sure if this is related, but appears that all the times this happens, Unity dash launcher don't display icons for any application (see attached screenshot).

Mark Elston (melston1777) wrote :

Well, I did an update this weekend and now I am not seeing the problem any longer. I'm not sure what got updated or how it fixed it but I am able to move the mouse and the login screen comes back and I am up and working again.

Andrea Azzarone (azzar1) wrote :
Download full text (4.8 KiB)

Hi, I pushed on this ppa [1] a modified unity7 with more debugging. Can you
please:
1. $ sudo add-apt-repository ppa:azzar1/unity7-testing
2. $ sudo apt-update
3. $ sudo apt upgrade (make sure unity is updated)
4. $ unity

Lock the system, after the problem happens write somewhere at what time the
problem happened (hour and minutes please). Then send at
<email address hidden> the content of ~/.cache/upstart/unity7.log.
Please in the email specify at what time the problem happened. Thanks.

[1] https://code.launchpad.net/~azzar1/+archive/ubuntu/unity7-testing

On Mon, Jul 31, 2017 at 6:30 PM, Mark Elston <email address hidden>
wrote:

> Well, I did an update this weekend and now I am not seeing the problem
> any longer. I'm not sure what got updated or how it fixed it but I am
> able to move the mouse and the login screen comes back and I am up and
> working again.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1311316
>
> Title:
> After locking screen there is no input field to type password for
> unlock
>
> Status in Unity:
> Fix Released
> Status in Unity 7.2 series:
> Fix Released
> Status in unity package in Ubuntu:
> Fix Released
>
> Bug description:
> *** IMPORTANT **
>
> *** The fix is not included in TRUSTY. Will be included with next SRU.
> ***
>
> If you can reproduce this bug please be sure to provide the following
> info:
> 1. Do you use a multi-head setup? If yes, using just one monitor fixes
> the issue?
> 2. Can you reproduce all the time?
> 3. Do you use ldap? If yes, using gnome-screensaver fix the issue (see
> comment #115) can you still reproduce that?
> 4. Please consider posting /var/log/auth.log (at least part of it,
> should not contain sensitive information)
> 5. Please specify the unity version
> *** END IMPORTANT **
>
> Sometimes (but not always) after locking the screen there is the
> situation not having any input field where I can type the password to
> unlock the session again. The shaded gray area simply does not have
> the input field. I can't do anything, I have to switch to text console
> and stop/start lightdm service to cure the problem loosing all of my
> session :(
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: unity 7.2.0+14.04.20140416-0ubuntu1
> ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
> Uname: Linux 3.13.0-24-generic i686
> ApportVersion: 2.14.1-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/
> screen0/options/active_plugins'
> CurrentDesktop: Unity
> Date: Tue Apr 22 22:17:57 2014
> InstallationDate: Installed on 2012-03-03 (780 days ago)
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)
> SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-10-18 (186 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1311316/+subscriptions
>
> Launchpad-Notification-Type: bug
> Launchpad-Bug: product=unity; milestone=7.3.1; status=Fix Released;
> importance=High; <email address hidden>;
> Launch...

Read more...

Rael Gugelmin Cunha (rael-gc) wrote :

@Andrea: is a restart required or a `compiz --replace &` is enough?

Andrea Azzarone (azzar1) wrote :

I would suggest one of the following options:
1. $ unity
2. login/logout
3. reboot

compiz --repalce will fail because compiz will not be started by upstart and logging will be send to stderr/stdout

Sylwester (ubuntulinux-org) wrote :

This has been bugging me for some time. Out family of 3 switch users and it happens randomly for some users while others still work.

The only workaround I got is that I made a dummy user that I always login on terminal 7. When any in the family gets this problem they hit CTRL+ALT+F7 to that user lockscreen and use its fast user switch to pick their own name. Then you get login prompt and can access your session. Once in the session you get the same problem if you lock the screen so its just to be able to save your work, close appications and kill the screem with AltGr+SysRq+k since the logout will show a logout button that will not work.

Once logged in again though the lock screen is normal for a random duration of unlocks before the same happens again.

It beats loosing data but a fix would be nice.

Sylwester (ubuntulinux-org) wrote :

And the "fix" doesn't work as I'm using Unity 7.4 on Xenial LTS patched up with the newest fixes.

Rael Gugelmin Cunha (rael-gc) wrote :

@azzar1: I faced today again this issue, after install the modified Unity from the PPA. I resumed after suspend. Yesterday all the family logged in.

Unfortunately, the content of ~/.cache/upstart/unity7.log is a single line:

ATTENTION: default value of option force_s3tc_enable overridden by environment.

Klemen (klemenk) wrote :

This is getting wores.. The workaround mentioned above "@Klemen, as a work around I make sure that a second user is logged in (most of the time one of my children). If I am locked out, I can switch to a different X-session (ctrl-alt-f8 or so) and then switch to my user with the menu in the top left corner. Then I can enter my password." is not working anymore. When I switch X-session the screen in that session just keeps flickering and blinking and there is no way I can switch to my user with the menu...

Will this be fixed or should we abandon Ubuntu as a GUI option for Linux? Should I switch to KDE? Any other recommendations?

description: updated

Hello LGB, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.5+16.04.20171116 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Klemen (klemenk) wrote :

I wanted to install proposed package but there seems to be an issue of dependencies I can not resolve (see below). Please provide a novice instructions how to install this. Thanks.

username@username-G501JW:~$ sudo apt-get install unity/xenial-proposedReading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '7.4.5+16.04.20171116' (Ubuntu:16.04/xenial-proposed [amd64]) for 'unity'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity : Depends: compiz-core-abiversion-20170630
E: Unable to correct problems, you have held broken packages.

Łukasz Zemczak (sil2100) wrote :

Hello LGB, or anyone else affected,

Accepted unity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.4.5+16.04.20171201.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Markus Birth (mbirth) wrote :

Just for the record: I had Ubuntu 17.10 (upgraded from 17.04 which was upgraded from 16.10) running on my HP Spectre x360 just fine with GDM3 and Unity and when the screensaver kicked in or I locked the screen, it turned to the GDM3 greeter.

A few days ago, I cleared my SSD and installed 17.10 from scratch. But now, when I lock the screen, I see what looks like the LightDM greeter with a red "Authentication failed" message and "Switch to greeter..." where the password input should be. I then have to Ctrl+Alt+F1 to the GDM3 greeter and unlock from there. Why is that?

Using the "Switch to greeter..." button you should be able to login without any Ctrl+Alt+F1 press, isn't it?

Andrea might help more here, though.

Markus Birth (mbirth) wrote :

A few reboots later, I'm now able to unlock the notebook from the LightDM lockscreen. There's no "switch to greeter" anymore, but a real password entry field which works. However, I still don't know why I had the GDM3 lockscreen before.

Andrea Azzarone (azzar1) wrote :

@Markus do you get it all the times?

ventrical (dale-f-beaudoin) wrote :

works just fine here on my lenovo lappy.

Markus Birth (mbirth) wrote :

@Andrea: Yes, no "switch to greeter" for me anymore. But still I get the LightDM lock screen (with working password field) instead of GDM3.

Download full text (4.8 KiB)

Can you check the output of "cat /etc/pam.d/unity" ?

On Mon, Jan 8, 2018 at 10:03 PM, Markus Birth <email address hidden>
wrote:

> @Andrea: Yes, no "switch to greeter" for me anymore. But still I get the
> LightDM lock screen (with working password field) instead of GDM3.
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1311316
>
> Title:
> After locking screen there is no input field to type password for
> unlock
>
> Status in Unity:
> Fix Released
> Status in Unity 7.2 series:
> Fix Released
> Status in unity package in Ubuntu:
> Fix Released
> Status in unity source package in Xenial:
> Fix Committed
>
> Bug description:
> *** IMPORTANT **
>
> *** The fix is not included in TRUSTY. Will be included with next SRU.
> ***
>
> If you can reproduce this bug please be sure to provide the following
> info:
> 1. Do you use a multi-head setup? If yes, using just one monitor fixes
> the issue?
> 2. Can you reproduce all the time?
> 3. Do you use ldap? If yes, using gnome-screensaver fix the issue (see
> comment #115) can you still reproduce that?
> 4. Please consider posting /var/log/auth.log (at least part of it,
> should not contain sensitive information)
> 5. Please specify the unity version
> *** END IMPORTANT **
>
>
> [Impact]
>
> Sometimes (but not always) after locking the screen there is the
> situation not having any input field where I can type the password to
> unlock the session again. The shaded gray area simply does not have
> the input field. I can't do anything, I have to switch to text console
> and stop/start lightdm service to cure the problem loosing all of my
> session :(
>
> [Test case]
>
> 1. Lock/unlock the screen multiple times
> 2. Expect the lockscreen password input field stay there
>
> [Regression Potential]
>
> Lockscreen shield isn't properly shown. Or fails to login.
>
>
> ProblemType: BugDistroRelease: Ubuntu 14.04
> Package: unity 7.2.0+14.04.20140416-0ubuntu1
> ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
> Uname: Linux 3.13.0-24-generic i686
> ApportVersion: 2.14.1-0ubuntu3
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/
> screen0/options/active_plugins'
> CurrentDesktop: Unity
> Date: Tue Apr 22 22:17:57 2014
> InstallationDate: Installed on 2012-03-03 (780 days
> ago)InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)SourcePackage: unity
> UpgradeStatus: Upgraded to trusty on 2013-10-18 (186 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1311316/+subscriptions
>
> Launchpad-Notification-Type: bug
> Launchpad-Bug: product=unity; milestone=7.3.1; status=Fix Released;
> importance=High; <email address hidden>;
> Launchpad-Bug: product=unity; productseries=7.2; status=Fix Released;
> importance=High; <email address hidden>;
> Launchpad-Bug: distribution=ubuntu; sourcepackage=unity;
> component=universe; status=Fix Released; importance=High; assignee=
> <email address hidden>;
> Launchpad-Bug: distribution=ubuntu;...

Read more...

Markus Birth (mbirth) wrote :

@Andrea:

    @include common-auth
    auth optional pam_gnome_keyring.so

Ads20000 (ads20000) wrote :

Unable to reproduce the bug (in VirtualBox - low graphics mode, single monitor) so I can't verify the fix. Unable to switch to non-lowgfx because I get 'No such key 'lowgfx'' when trying to run `gsettings set com.canonical.Unity lowgfx false`.

=/ I'm also facing this issue. The curious part is that the issue happens more if I take a while to reboot the machine. I mean, if I don't reboot and just put the machine to sleep this issue start to happens more and more. I also realized that when I use two different users in the machine it also implies to happen more.
Sometimes just type ctrl+alt+f7 a couple of times works to bring the entry field back, but not always (as today), though, typing unity --replace in the user I had the GUI start it works. Last time I have this issue I was with two users logged in, so I just pkill -9 -u <user2> and the login entry screens backs to user1. Also happens to the login screen stay black just with the mouse pointer working.

I'm using 16.04 with this kernel 4.13.0-26-generic and this unity version: 7.4.0+16.04.20160906-0ubuntu1

I can't reproduce the issue, but for sure this fix doesn't bring any regression, while we didn't get any report of this happening with unity 7.4.5+16.04.20171201.3, so we can safely mark this as verified.

Feel free to reopen in case.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package unity - 7.4.5+16.04.20171201.3

---------------
unity (7.4.5+16.04.20171201.3) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * InputMonitor: add an unity class that monitors XInput2 events and
    converts them to XEvent
  * EdgeBarrierController: use InputMonitor to get the barrier events
    instead of relying on its implementation
  * DecorationsMenuLayout: use input monitor for menu scrubbing (LP:
    #1614597)
  * PanelView: use InputMonitor to track menu events
  * LockScreenPanel: use InputMonitor events instead of mouse polling
    for menu scrubbing
  * MenuManager: add support for mouse trackers with triangle algorithm
    support (LP: #1618405)
  * PanelView: scale gradient refinement properly
  * PanelService: don't allow to deactivate menus if they've been opened
    too shortly
  * LockScreenController: ignore icon_paths_changed signal in
    menumanager for Lockscreen
  * LockScreenController: use InputMonitor to get all the events and
    hide the Blank Window (LP: #1321075)
  * LockScreenController: use input monitor to get the events to switch
    monitor (LP: #1316862)
  * LauncherOptions: use track_obj to manage option changes (LP:
    #1622995)
  * UnityScreen: toggle gestures recognition on lock (LP: #1645507)
  * GnomeSessionManager: add gcancellable to instance and use it for
    calls with temporary proxies
  * BackgroundSettings: use gnome-bg to generate textures with proper
    scaling (LP: #1666359)
  * UnityWindow: safely check validity of UnityWindow from scaled one
    (LP: #1659847)
  * Panel: ensure the menu-manager tracker is updated to match monitor
    (LP: #1671432)
  * compiz-profile-setter: tool to update the current profile and use in
    systemd and Unity settings (LP: #1668950)
  * BGHash, UnityScreen: get desktop averageColor from compiz
  * Launcher: disable or reduce most icon effects on lowgfx (LP:
    #1700859)
  * PanelController: ensure we disconnect from signals on destruction
    (LP: #1504870)
  * tools: add migration script to set the default values for unity-
    lowgfx profile

  [ Andrea Azzarone ]
  * Properly handle the file manager copy dialog in
    FileManagerLauncherIcon and in StorageLauncherIcon. (LP: #1575452,
    LP: #1609845)
  * Correctly position the force quit dialog when scaling is different
    than 1.0 (LP: #1637991)
  * GnomeSession: Retrieve the session id using dbus if $XDG_SESSION_ID
    is not set
  * Round gtk scaling factor to closest integer. (LP: #1649736)
  * Keep the screen locked if rebooting with autologin. (LP: #1600389)
  * Use g_mkdir_with_parents instead of mkdir.
  * Lockscreen: always draw the background-color in the lockscreen (LP:
    #1702701)
  * Refactor the way UserAuthenticator is created and passed around.
    Handle failures to create new threads and fallback to a "Switch to
    greeter..." button in case of failure. (LP: #1311316)
  * Wait until the color buffer is cleared before suspending. (LP:
    #1532508)

  [ Kai-Heng Feng ]
  * UnitySettings: If scale-factor is not set, find and set right scale
    for HiDPI displays.

  [ Eleni Maria Stea ]
  * shouldn't create blur rectangles when there's ...

Read more...

Changed in unity (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Rael Gugelmin Cunha (rael-gc) wrote :

Well, we have a bug related to this: Now everytime second user get logged, we're seeing "Authentication Failure: Switch to greeter" https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1733557

Displaying first 40 and last 40 comments. View all 247 comments or add a comment.