Text scaling factor changing unexpectedly

Bug #1310316 reported by Nicolas Baillard on 2014-04-20
326
This bug affects 69 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I have a MacBook pro with a Retina display. I have set the "Scale for menu and title bars" setting (into Settings > Displays) to 1.5 to make the UI looks good on my screen. That works very well. But sometimes, usually after logging, all the fonts of the UI become much bigger.

When that happen I open unity tweat tool and notice that the text scaling factor changed to 2.25. If I reset it to 1 the all the fonts go back to normal.

The problem does not happen all the time. I would say it happen one time out of three logging. It may also happen when installing applications from the software center. I have yet to find a procedure to reproduce it all the times.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140416-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 331.38 Wed Jan 8 19:32:30 PST 2014
 GCC version: gcc version 4.8.2 (Ubuntu 4.8.2-19ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Sun Apr 20 18:21:02 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.7, 3.13.0-24-generic, x86_64: installed
 bcmwl, 6.30.223.141+bdcom, 3.13.0-24-generic, x86_64: installed
 nvidia-331, 331.38, 3.13.0-24-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GK107M [GeForce GT 650M Mac Edition] [10de:0fd5] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Apple Inc. Device [106b:00f2]
InstallationDate: Installed on 2014-04-19 (1 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64+mac (20140417)
MachineType: Apple Inc. MacBookPro10,1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=3d5a4115-5e15-4eca-bd1c-0bee2543a1cb ro quiet splash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/21/2012
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP101.88Z.00EE.B03.1212211437
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-C3EC7CD22292981F
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookPro10,1
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-C3EC7CD22292981F
dmi.modalias: dmi:bvnAppleInc.:bvrMBP101.88Z.00EE.B03.1212211437:bd12/21/2012:svnAppleInc.:pnMacBookPro10,1:pvr1.0:rvnAppleInc.:rnMac-C3EC7CD22292981F:rvrMacBookPro10,1:cvnAppleInc.:ct10:cvrMac-C3EC7CD22292981F:
dmi.product.name: MacBookPro10,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.11+14.04.20140409-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-4ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-4ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sun Apr 20 18:04:05 2014
xserver.configfile: default
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2

dani (de-dani) wrote :

I have the same issue:
scaling factor in "gnome-tweak-tool" and scale for menu and title bars in "Screen Display" seems to interfere.
font size changes after newly logging in.

Dani, could you please tell me if you installed any mail notifier application (or any application that does notification) ?

I believe (but I'm not sure yet) that my issue was caused by a mail notifier application I installed from the software center. I can't tell which one yet since I've been trying them all. But the problem started happening when I installed them and since I uninstalled them it didn't happen again.

Since this problem happen somewhat randomly I need more time to pin down the exact cause.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Pawel Kalamajski (pkalamajski) wrote :

Unfortunately I'm experiencing the same issue. I believe email notifier has nothing to do with it since I don't have any. The only trigger seems to be changing default scale for menu and title bars setting.

Ben Romer (bromer) wrote :

I have the same issue on a Vaio with a 1920x1080 screen at 15". Setting the text scale to 1.25 seems to sometimes boot up with the scaling being again and all of the text appearing too large.

Also, the mouse cursors are incorrectly scaled in GTK2 applications, varying between controls from a 1.25-scaled cursor to the 1-scale cursor used by GTK3 apps. Most notably, pop-up menus will have the mouse scale change when the pop-up is clicked and when the mouse is moved into the pop-up.

Rainer (r-e-l) wrote :

Hi together,

this problem affects me too. I take a look at my system and found:
Under unity-tweak-tool the scaling fonts the scaling factor was reduced to 0.86. and I reset it to 1. After reboot it was again 0.86 and after further reboots it decreases further.

Then I found that und system sesttings display the scale for menus and title bars was set to 0.86.

I reset both to 1 and the problem disapear.

This lead me to the sentence: the unity-tweak-tool the scaling fonts scaling factor is reduced y each boot with the system sesttings display scale for menus and title bars.

Hope this help to circumvent the problem for all who had this problem and for the solver to find the bug.

Rgeards Rainer

Enes UNAL (aenesunal) wrote :

I have similar but different issue with my Ubuntu 14.04.

After I change the ratio, the scale ratio, to 0.75, all was well. However after I login back, there was only texts scaled, there was no scaled graphic items. When I scale again to back 1.0, all graphic items got like 1.25 scaling.

I couldn't found a solution yet, but this scaling issues really harmful for my eyes now.

Hope this help to find bug easily.

Regards,
Enes.

Enes UNAL (aenesunal) wrote :

Hello again,

I resolve my problem by;

- Scale to max.
- Logout
- Login
- Scale to 1.0
- Logout
- Login

Now, there is no problem. I want to add a patch to resolve this issues but new @launchpad. After some experience I would love to do.

Regards,
Enes.

Casper Bruun (n-launchpad-c) wrote :

I too expereince system fonts suddenly being displayed at a much lower scaling factor than the 0,9 I have set.

I suspect that this could have happen when I take the laptop in and out of its docking station changing between the laptop screen and a monitor with a higher resolution.

Also I observe strange behaviour when I try to reset the scaling factor in gnome-tweak-tool. Usually the scale factor have been set to something like 0.5. Using the plus button to increase the scale factor I observe that the value I set is immediately reduced back to the smaller value without my intervention.

markus haider (markus.haider) wrote :

I experience the same problem. I have a MAC with retina display and therefore want to use a font size of 1.5 but after logging in again, font size is 2.25 (1.5*1.5?).

Alex (akusumajaya82-b) wrote :

i also experience the same problem on vaio duo 1920x1080, every time i restart it set the scalling to 2.36. Is there any work arround for this problem?

bananenkasper (bananenkasper) wrote :

Same problem here, on a Dell XPS13 9333 Ubuntu 14.04.

Please add me to this bug. With each logon, Ubunt tweak keeps changing my text scaling factor to a larger size. When I open system settings, and view Display, the scale menu option has NOT changed, but for some reason Ubuntu tweak keeps taking over and changes the scaling factor, making the fonts ugly large. I am using Lenovo ThinkPad T430 64bit, 8gb ram.

Changed in unity:
status: New → Confirmed
dkotrada (dkotrada) wrote :

For me on IBM T400 it scalls from 1 to 0.6

gianfilippo (gianfi) wrote :

Same issue here, on a Acer Aspire S7-191 using ubuntu 14.04 , text scaling factor changes randomly at any reboot

daemonkor (dkorobchuk) wrote :

Hello,
Have same issue with HP EliteBook 6930p. Bug has occured after 'Scaling for menu and title bars' applying.

Abz (warmicing) wrote :

I also have this problem.

It seems to persist the multiplication on every logout so the increase/decrease continues to be reapplied making it exponentially bigger/smaller each time - it's not random.

For people suffering with this issue, set the slider to the value you like, then log out and in, until it is the desired size. Then set it back to 1 and it will stay at that size.

I'm on a Dell XPS 13.

herbaman (fat-b) wrote :

This also affects or maybe affected me. I think the problem appears because the x server does not set the right dpi value - and for some reason the text-scale factor keeps to be reseted from time to time, maybe because of an update.

I manually set the correct dpi value of my screen (122dpi) in /etc/lightdm/lightdm.conf with adding this line:
xserver-command=X -dpi 122

and restartet the x-server.
Xorg.0.log now says: [ 3033.310] (++) intel(0): DPI set to (122, 122) <- this was (96, 96) before
The Text-scale factor has been set to a usable value after that.

Maybe some of you can try this as well (with your individual dpi settings for your monitor) to see if this really fixes the problem.

asala (asala) wrote :

Maybe the bug is in some "tweak tool"? I have both "Ubuntu Tweak" and "unity tweak tool" installed, and I'm indeed affected (XPS13).

asala (asala) wrote :

Further info on my previous comment: If I set scaling to "1" in both "unity tweak tool" and "Display" settings, then logging on several times does NOT increase the scaling.
If, from that starting conditions, I modify on the "displays" ("monitores" in Spanish) settings (native Ubuntu) then the scaling keeps constant between logons, and you see the same value in "unity tweak tool" and "Display" controls.

However, ifstarting with the same (but different from 1) setting in displays and tweak tool, then you change the setting in "unity tweak tool" then it does NOT change in the display one, and actually the one in Unity Tweak Tool at next logon seems to be the product of both... and, as commented in #18, it leads to an exponential increase.

A variation of workaround #18. setting the "Display" setting to one and keeping it different from one in "unity tweak tool" does work for me.

SO, it seems that interferences mentioned in #2 and #7 can be confirmed and perhaps the bug is in "unity-tweak-tool".

Although I am not a developer, it would be nice to confirm if some of you suffers the bug without unity-tweak-tool installed.
As the maintainer of "unity-tweak-tool" is Barneedhar Vigneshwar, I subscribed him to this bug.

Jose Canciani (u-ubuctu-b) wrote :

My workaround until this is fix, add a startup application that runs this script:

$ cat ~/bin/restoreTextScalingFactor.sh
#!/bin/bash

gsettings set org.gnome.desktop.interface text-scaling-factor '1.0'

Regards!
Jose

Alex Armstrong (alehandrof) wrote :

I am also experiencing this on a Toshiba Z30t-A. The 1920x1080 is a bit too much for a 13.3" laptop. I've been tinkering with dconf and narrowed down my desired settings to:

gsettings reset org.gnome.desktop.interface scaling-factor # same as '1.0'
gsettings set com.canonical.Unity.Interface text-scale-factor 1.25
gsettings set org.gnome.desktop.interface text-scaling-factor 1.25
gsettings set com.ubuntu.user-interface scale-factor "{'eDP1': 10}"

But I can't figure out how to make them stick from session to session. I created a startup script as #22 suggests but font sizes are still all over the place. (Even if I only tweak the two text-scaling settings and leave UI scale-factors alone.)

A temporary fix for nailing down the settings would be much appreciated. As others have pointed out it's GNOME's text scaling setting that seems to be wonky. (I believe that's the technical term :)

Stephen M. Webb (bregma) wrote :

I believe this is a duplicate of bug #1332947 (which has a fix in progress). Please check if the Large Text setting is enabled under Universal Access in the System Settings and confirm if that's the case.

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Sean Smith (seansith) wrote :

No HIDPI hardware here: Inspiron 5521 (1366x768) and I regularly have problems. Large text is not currently enabled.

Alex Armstrong (alehandrof) wrote :

There may be more than issue here. But the suggestion that the Large Text option is causeing the issue seems promising for my case. The option gets flipped on when I change the fonts, e.g. via ubuntu-tweak or dconf and presumably is at the cause of the exponential increase in font size.

Alex Armstrong (alehandrof) wrote :

I can confirm that #24 resolved the issue for me. As long as I only use the slider in `Settings > Display` to scale the UI and make sure that `Universal Access > Large Text` is off, the font sizes remain stable from session to session.

I wanted the fonts to be a little larger so I adjust them (via either dconf or unity-tweak).

The trick is not to use the option to scale the fonts (via dconf or unity-tweak), because that would flip on Large Text and I'd go back to the behavior where the font sizes changed from session to session.

HTH

Iain Elder (iainelder) wrote :

A few months ago I installed the Unity Tweak Tool to experiment with different font sizes.

In the end I decided that the default 1.0 size was fine.

Now I occasionally suffer from tiny (0.5) fonts at startup.

Something truly weird happens when I use Tweak to reset the correct value (1.0). It's as if Tweak is fighting my changes.

When I use the mouse to to click on the button to increment the font size, the Tweak tool immediately undoes my change. It's impossible to fix the font size using the mouse.

The only way to force the change is to use the keyboard to type '1.1' into the box. Tweak decrements this to 1.0, the correct value.

Everything is normal again if I immediately quit Tweak after this, until the next boot that shrinks the fonts.

Iain Elder (iainelder) wrote :

@bregma: the 'Large Text' option is already set to 'Off' for me.

rebroad (rebroad) wrote :

I don't have the tweak tool installed. I'm using HiDPI hardware. I set the scale to 1.12 in the display preferences option, and each time I start unity (or run "setsid unity") the font increases in size. It seems that in the display preferences, it needs to be set to 1.0 for the constant font size changing to not occur. I've therefore set this back to 1.0, and instead set up a start-up script to "gsettings set com.ubuntu.user-interface scale-factor "{'eDP1': 10}"" instead.

I'm having problems with this one too. I have no third party tweak tools installed, but i do use xorg.conf, to modify the screen resolution. I don't know if that could have an impact.

Mr.Gosh (mr-gosh) wrote :

for me - all proposed solutions doesnt seem to scale the "menu font size".... :(

really anoying on a yoga 2 pro with 3200 x 1800 resolution

Sean Martz (martzy13) wrote :

Hello,

Also having this issue on a Lenovo g50.
I log in one day its .88
Next day the its down to .56

Any one have any luck???

Sean Martz (martzy13) wrote :

Addendum to #33

I am using Unity Tweak Tool

P.S.

not sure if this is a related bug or not but with unity tweak tool whenver this happens - my hot corners stop working although they are toggled to the on positon. If I untoggle and then retoggle back on then my corners get toasty again! ;)

Andreas Ritter (eddie8) wrote :

Also affected, mostly scaling factor goes up to 3, try to change with gnome-tweak-tool or unity-tweak-tool without any afford.

Ubuntu 14.04, beside Google Chrome no extra PPAs
MSI Adora22 (Intel Core i3 4100M, Intel HD-Grafik 4600)

Here you can find a workaround:
http://askubuntu.com/questions/469515/adjust-text-scaling-factor-for-all-users

But this is no solution at all, there must be a bug somewhere.

GiGurra (kjolhede) wrote :

Yes, I'm experiencing the same issue. I switched from using win7 to ubuntu 14.04 lts on my laptop the other night but am having big trouble with the scaling. I'm not using unity tweak tool but just tried to lower text size in the system settings->display window. Initially I lowered it from 1.0->0.75.

But after a few logins the menu bar text suddently became extremely small. The setting is still 0.75, but the menu bar text is now unreadable :/.

Creating a new user account brings the scalign back to normal, but, hey, I can't create a new account efter few reboots on my laptop :P.

GiGurra (kjolhede) wrote :

I can confirm that this workaround works: gsettings set org.gnome.desktop.interface text-scaling-factor '1.0'

Glad I found this thread :)

JustinKim (splash16-16) wrote :

Had the same issue and was so frustrated with this for the last 1.30hours. I fixed it by going and setting "system settings->screen display->scale for menu and title bars" to 1. Also set your text scaling factor in fonts to 1. Log out and log in to test.

John (bobjohnbob) wrote :

This happened to me after running 'unity --replace' to workaround another bug(#1311316). It has happened to me several times before. I attached the full console output here is an excerpt:

$ unity --replace
....

WARN 2015-03-26 15:09:47 unityo (appinfo2) <unknown>:0 g_settings_set_value: value for key 'text-scaling-factor' in schema 'org.gnome.desktop.interface' is outside of valid range
WARN 2015-03-26 15:09:48 unityo (appinfo2) <unknown>:0 g_settings_set_value: value for key 'text-scaling-factor' in schema 'org.gnome.desktop.interface' is outside of valid range

....

Neve Nincs (nincs-neve-0) wrote :

"gsettings set org.gnome.desktop.interface text-scaling-factor '1.0'"

Yes, this is a workaround, but it does not allow you to use font scaling. In case one wants to use a different scaling factor, like me, because I have sight problems and I want to put as little stress on my eyes as possible, this is not the solution.

I did not give up and finally I have found a solution to permanently disable this bug:

"gsettings set com.canonical.Unity.Interface.app-fallback-to-maximum-scale-factor false"

I don't think this is the final fix for the bug, it just disables it from being triggered again when I reboot my Ubuntu.

Neve Nincs (nincs-neve-0) wrote :

Sorry, there is an error is the command I posted above, so, here it is:

gsettings set com.canonical.Unity.Interface app-fallback-to-maximum-scale-factor false

Regards.

Seán Ó Séaghdha (seanos) wrote :

For me this problem is caused by both Unity Tweak Tool and Gnome Tweak Tool toggling Large Text on when you change the scaling. If I go to Universal Access and turn Large Text off or only change scaling in Screen Display it all works properly.

This suggests some kind of connection with bug #1332947.

Will Cooke (willcooke) on 2015-08-18
tags: added: rls-w-incoming
Randy (rlsage) wrote :

Unstable Font Scaling bug.

Same problem; every time I log in,
scaling has been reduced to smaller,
as have menu and title bars.
It started after a recent update. (No idea which one.)
Getting tired of "Lilliputian Font size 02."
I was having to reset font scaling every morning on login.

Dual monitors, Ubuntu 16.04 lts.

A fix:

Be sure to set EVERY scaling factor to 1.0.

First: Settings / Displays / Scale for menu and title bars,
set 1.0 for both monitors, by clicking on each monitor identified.

Then set font scaling to 1.0 using Unity Tweak Tool.

So far, this fix has worked. Stable scaling at 1.0 on login.

To post a comment you must log in.