Shutdown/reboot/login/logout dialogs not scaled after toggling UI scale Edit

Bug #1308323 reported by Bruce.Ma on 2014-04-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
Trusty
Undecided
Unassigned
Unity
Fix Released
Medium
Brandon Schaefer
7.2
Fix Released
Medium
Brandon Schaefer
unity (Ubuntu)
Medium
Brandon Schaefer
Trusty
Undecided
Unassigned

Bug Description

1. Install Ubuntu-trusty image and boot into OS
2. Go to System settings > Display
3. Toggle UI scale up or down
4. Press power button to launch poweroff notification prompt
5. Check if the contents of the prompt is also scaled in accordance to the UI scale settings

[Expected results]
Contents of the poweroff notification prompt should be scaled in accordance to the UI scale settings

[Actual results]
Contents of the poweroff notification prompt is not scaled

[Inpact]
When Caps lock was active the icon did not render a tooltip if you moused over the icon. This can be consfusing if the user has no clue what the icon means.

[Test case]
1) Go to System Settings -> Display
2) Change the DPI scale to a noticable size.
3) Then select Shutdown to bring up the Dialog.

Expected Result:
  The shutdown dialog scaled correctly.

[Regression potential]
Low. Worse case we just dont scale, the changes are pretty isolated to the number changing game.

Related branches

Bruce.Ma (bruce.ma) wrote :
affects: ubiquity (Ubuntu) → unity (Ubuntu)
Ara Pulido (ara) on 2014-04-22
Changed in unity (Ubuntu):
assignee: nobody → Stephen M. Webb (bregma)
Andrea Azzarone (azzar1) on 2014-04-23
summary: - Shutdown/reboot/login/logout notification prompts not scaled after
- toggling UI scale Edit
+ Shutdown/reboot/login/logout dialogs not scaled after toggling UI scale
+ Edit
Ara Pulido (ara) on 2014-04-23
Changed in oem-priority:
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: Stephen M. Webb (bregma) → Brandon Schaefer (brandontschaefer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140606.1-0ubuntu1

---------------
unity (7.2.0+14.10.20140606.1-0ubuntu1) utopic; urgency=low

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
 -- Ubuntu daily release <email address hidden> Fri, 06 Jun 2014 13:55:32 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2014-06-06
Changed in unity:
milestone: none → 7.3.0
status: In Progress → Fix Committed
Changed in unity (Ubuntu Trusty):
status: New → In Progress
Ara Pulido (ara) on 2014-06-11
Changed in oem-priority:
status: Triaged → In Progress
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
description: updated

Hello Bruce.Ma, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Sami Jaktholm (sjakthol) wrote :

Version from trusty-proposed scales the dialog correcly.

tags: added: verification-done
removed: verification-needed
Bruce.Ma (bruce.ma) wrote :

@Chris J Arges, Thank you.
I will test this ASAP and put the result over here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
Ara Pulido (ara) on 2014-07-30
Changed in oem-priority:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments