First password letter not registered in lockscreen if screen off

Bug #1308265 reported by Michał Sawicz on 2014-04-15
122
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Andrea Azzarone
7.2
Fix Committed
Medium
Unassigned
unity (Ubuntu)
Medium
Andrea Azzarone
Nominated for Trusty by Christopher Townsend
Trusty
Medium
Andrea Azzarone

Bug Description

[ Impact ]

Not having the first character registered when trying to unlock the lockscreen can most definitely lead to frustration and thus, poor user experience.

[ Test Case ]

1. Lock the screen and let the monitor blank as well.
2. Try unlocking the screen by typing your password.
3. Observe lockscreen unlocks.

[ Regression Potential ]

None observed.

Debdiff of the SRU is found here: https://bugs.launchpad.net/unity/+bug/886478/+attachment/4401967/+files/unity.7.2.5.debdiff

-----------------------------------------------------------------------------

Original Description:

With the new lockscreen, if my screen is off, I just start typing, every time my password is too short. It looks like the first key only triggers the screen on and does not go to the input field.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.0+14.04.20140414.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Tue Apr 15 23:59:08 2014
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michał Sawicz (saviq) wrote :
tags: added: lockscreen
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2014-04-17
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
milestone: none → 7.2.1
Jan Prieser (jan-prieser) wrote :

this bug was introduced in unity=7.2.0+14.04.20140410-0ubuntu1

last working version is 7.2.0+14.04.20140404-0ubuntu1

I couldn't reproduce that today with fully updated 14.04 LTS.

$ apt-cache policy unity
unity:
  Zainstalowana: 7.2.0+14.04.20140423-0ubuntu1.2
  Kandydująca: 7.2.0+14.04.20140423-0ubuntu1.2
  Tabela wersji:
 *** 7.2.0+14.04.20140423-0ubuntu1.2 0
        500 http://ftp.vectranet.pl/ubuntu/ trusty-updates/main amd64 Packages
        500 http://ftp.vectranet.pl/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     7.2.0+14.04.20140416-0ubuntu1 0
        500 http://ftp.vectranet.pl/ubuntu/ trusty/main amd64 Packages

My password starts with big letter so I use Shift and then the letter key and screen unlocked without any problems.

On 01.05.2014 18:59, Mateusz Stachowski wrote:
> My password starts with big letter so I use Shift and then the letter
> key and screen unlocked without any problems.

That's probably why it works for you - shift pressed wakes the screen,
the next event is the letter key press and is registered fine.

It's been a hit'n'miss for me in utopic, with a lowercase first password
letter.

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
milestone: 7.2.1 → 7.3.0
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
milestone: 7.3.0 → 7.3.1
Margarita Manterola (marga-9) wrote :

This is very easy to reproduce, you don't even need to type your real password:
1 - Lock the screen with Ctrl-Alt-L
2 - Wait until it turns completely black (aprox. 15 seconds)
3 - Start typing, it doesn't need to be your password, you can count your chars and see that the amount on the screen (when it wakes up) doesn't match. e.g. I tried typing 1234 and only three stars appeared.

Although this is not a security concern, it's a pretty annoying regression, so I hope the fix gets backported to trusty. Thanks!

Changed in unity (Ubuntu):
importance: Undecided → Medium
Regular User (dot.ru) wrote :

Actually, I'm a fully updated 14.04 and I still get this bug. I think the reason why it worked for #4 it's because of the shift thing, not because the bug isn't present on 14.04.

Gotiniens (gotiniens) wrote :

I'm Also updated, and also experience the bug. Ridiculous that this is not
fixed yet. I experience this bug 10-20 times a day...

On Tue, Nov 25, 2014 at 4:05 PM, rpgmaker <email address hidden>
wrote:

> Actually, I'm a fully updated 14.04 and I still get this bug. I think
> the reason why it worked for #4 it's because of the shift thing, not
> because the bug isn't present on 14.04.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1308265
>
> Title:
> First password letter not registered in lockscreen if screen off
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/1308265/+subscriptions
>

Olivier Febwin (febcrash) wrote :

and this bug is still present on ubuntu 14.10

tags: added: utopic
Olivier Febwin (febcrash) wrote :

unity 7.3.1+14.10.20141016-0ubuntu1 amd64

Mike Doherty (doherty) wrote :

Is this actually being worked on? The regression has been there a while now, and is still present in the most recent release.

Mike Doherty (doherty) wrote :

When combined with bug 138654, this gets super annoying, so it is worth fixing.

Stephen M. Webb (bregma) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Andrea Azzarone (azzar1) on 2015-03-24
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (azzar1)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Andrea Azzarone (azzar1)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.04.20150330-0ubuntu1

---------------
unity (7.3.2+15.04.20150330-0ubuntu1) vivid; urgency=medium

  [ Andrea Azzarone ]
  * Do not restore focus if a quicklist is opened during launcher key
    navigation. (LP: #932486)
  * Forward first key event that happens on top of the blank window to
    the lockscreen. (LP: #1308265)
  * Hide launcher to avoid damaging window when not needed. Also make
    sure that pressure effect works fine (previous fix has been reverted
    because of this!). (LP: #1301394)
  * Make sure scope_views_[filter.id] exists before using operator[] on
    it. (LP: #926979)
  * Make sure that signals are auto-desconnected when
    XdndStartStopNotifierImp is destroyed. (LP: #1432231)
  * Release pointer barrier if launcher is in lock_hide state. (LP:
    #1029114)

  [ Sebastien Bacher ]
  * use the new nautilus .desktop name (LP: #1436297)

  [ Stephen M. Webb ]
  * AP tests: accounted for arbitrarily-raised exceptions in checking
    scaled windows (LP: #1436095)
 -- CI Train Bot <email address hidden> Mon, 30 Mar 2015 15:48:47 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) on 2015-03-30
Changed in unity:
status: In Progress → Fix Committed
Olivier Febwin (febcrash) wrote :

Yeah!!!

Changed in unity (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (azzar1)
description: updated
description: updated

Hello Michał, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.5+14.04.20150521.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

This no longer occurs with Unity from -proposed. Marking verification-done.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.5+14.04.20150521.1-0ubuntu1

---------------
unity (7.2.5+14.04.20150521.1-0ubuntu1) trusty; urgency=medium

  [ Chris Townsend ]
  * Releasing 7.2.5.
  * Bump version to 7.2.5.
  * Use a 2 second delay before showing the first run shortcut hints to
    workaround a race condition on input handling. (LP: #1313597)

  [ Andrea Azzarone ]
  * Add the possibility to specify the font size and the font weight
    without chaning the default font name. (LP: #886478)
  * Do not restore focus if a quicklist is opened during launcher key
    navigation. (LP: #932486)
  * Draw osk above unity shell. (LP: #1413165)
  * Forward first key event that happens on top of the blank window to
    the lockscreen. (LP: #1308265)
  * Make sure scope_views_[filter.id] exists before using operator[] on
    it. (LP: #926979)
  * Release pointer barrier if launcher is in lock_hide state. (LP:
    #1029114)

  [ Brandon Schaefer ]
  * When we quit the quicklist it would check if the mouse was over the
    launcher, if it wasn't it would fold the launcher. We don't need to
    check this if we are in keynav as we want all the icons to be
    unfolded. (LP: #1246891)

  [ CI Train Bot ]
  * New rebuild forced.

  [ Stephen M. Webb ]
  * AP tests: accounted for arbitrarily-raised exceptions in checking
    scaled windows (LP: #1436095)

 -- CI Train Bot <email address hidden> Thu, 21 May 2015 15:07:15 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers