14.04 daily build (2014-02-21): unity desktop crashes on every application start

Bug #1283671 reported by Jens on 2014-02-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Unassigned
unity (Ubuntu)
Critical
Unassigned

Bug Description

I installed the 14.04 daily build from a CD image yesterday to help testing. Unfortunately, I cannot test anything because right upon booting, when the desktop appears, every app I start causes about a minute of freezing (even the mouse pointer freezes) and then a restart (or complete crash) of the unity top menubar and sidebar.

The only thing in the desktop I customized was the Unity sidebar button size (in the settings app - to 16 pixels first, then to 24 pixels). But even the settings app caused this crash before I could use it to change the settings.

I am writing this in a 640x480 Firefox window without window manager from within the crashed Unity desktop.

Is this a known bug? I sure hope so. ;)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20140220-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Sun Feb 23 09:58:45 2014
InstallationDate: Installed on 2014-02-22 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140222)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Jens (jens-launchpad-net) wrote :
Markus Engel (engelmarkus) wrote :

I think this might be the same problem that is reported in bug #1282342.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1283671

tags: added: iso-testing
Doug Smythies (dsmythies) wrote :

Have a look at bug 1284536
Mine ( bug 1282342 ) has been determined to be the same.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Jens (jens-launchpad-net) wrote :

I did an `apt-get upgrade` yesterday. I also installed the virtualbox guest additions (because my VM only had 640x480 and many utilities don't work properly in that resolution, e.g. Ubuntu Testdrive).

No change - every application still crashes. Anybody working on this yet? Anything I can do to help further?

Thanks!

Stephen M. Webb (bregma) wrote :

Thanks for reporting this problem and trying to make Ubuntu better, but the description is vague and makes it difficult for us to investigate.

Is the problem that applications crash on startup (as in comment #6) or is the problem that the desktop crashes (as in the bug title), which means the Launcher and Panel disappear? If the latter, do they return shortly? Are the symptoms something else entirely?

Since you're running a prerelease version of Ubuntu, a crash normally causes apport (the crash reporter dialog) to include information on the cause, including necessary debug and log information. This clearly did not happen when this bug was reported. Is there any additional information you can supply that might aid us in determining your problem?

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Jens (jens-launchpad-net) wrote :

I installed Ubuntu. It boots and the desktop appears. As soon as I try to start any app from the launcher or menu (eg. Settings app) the desktop freezes. After around 10-20 seconds the window decorations, launcher and top menu bar disappear. Most apps do not even start up (Firefox works though). Occasionally I get an apport window about "compiz" having crashed, sometimes it is also a window informing me about an "internal error" in Ubuntu.

I am running Trusty in a Virtualbox VM from a 12.04 host. I installed the guest additions but this did not change anything.

It is trivial to reproduce this. What other info do you need?

Doug Smythies (dsmythies) wrote :

It is extremely likely that this bug is a duplicate of bug 1284536 , which mine ( bug 1282342 ) was determined to be.
See also my posting number 4 above.
And yes, this bug is driving me crazy. Everything broke on February 17th.

Stephen M. Webb (bregma) wrote :

A fix causing an intermittent crash in Unity was released 2014.02.26 (the fix was in the Nux library). This may or may not fix the problem you're experiencing, but it's worth a try updating to the latest packages to see if it does.

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Doug Smythies (dsmythies) wrote :

Stephen: No that is a different problem, or so I think. I have been updating and testing every day.

Jens (jens-launchpad-net) wrote :

I have updated on March 1 and the problem is still there.

Unfortunately, I cannot test any further because for some strange reason my Ubuntu 14.04 test VM does not even boot any more (it seems the bootdisk UUID has changed. Is this another bug?) I removed it completely and wanted to boot off a current ISO as of March 2, but this won't even boot in my freshly created VM. It complains about "CPU#0 stuck for 22 seconds in migration/9" and does nothing else when booting.

Try to use latest compiz, it should be fixed.

It renders the system temporarily or permanently unusable.

Changed in unity (Ubuntu):
importance: Undecided → Critical
Doug Smythies (dsmythies) wrote :

With the limited information on this one, I think it is a duplicate of previously mentioned bug reports, and it is fixed.

Jens (jens-launchpad-net) wrote :

It works here now (in Virtualbox) - so I think it is fixed.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
importance: Undecided → Critical
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers