After using an LIM menu item it can become hard to open any new menu item

Bug #1283260 reported by Doug McMahon on 2014-02-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Happens here very quickly so basic test case is just to use. Otherwise try,
Test case:
With Application menu option set to "In window title bars" (& maybe a log out in after setting
Open gedit, expose any menu item, dismiss menu by clicking again on menu item
Now re-click on menu item, many times takes multiple attepmts, when failing to open all the menu items flash but nothing happens

Also can occur after using a menu item then attepmting to open a new menu item in that app's winow

*This only occurs when using an externel usb mouse or touchpads left mouse button, if I use 'tap on the touchpad' it seems ok*

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20140220-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-11.31-generic 3.13.3
Uname: Linux 3.13.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Fri Feb 21 16:35:02 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3977]
 NVIDIA Corporation GK107M [GeForce GTX 660M] [10de:0fd4] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:3977]
InstallationDate: Installed on 2014-02-21 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140218)
MachineType: LENOVO 2099
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-11-generic root=UUID=4219d833-6a12-423a-9bee-c73c0f4e80fe ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/10/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 5DCN40WW(V2.07)
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Product Name
dmi.board.vendor: LENOVO
dmi.board.version: Mainboard version
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo IdeaPad Y580
dmi.modalias: dmi:bvnLENOVO:bvr5DCN40WW(V2.07):bd10/10/2012:svnLENOVO:pn2099:pvrLenovoIdeaPadY580:rvnLENOVO:rnProductName:rvrMainboardversion:cvnLENOVO:ct10:cvrLenovoIdeaPadY580:
dmi.product.name: 2099
dmi.product.version: Lenovo IdeaPad Y580
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.11+14.04.20140218-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0~rc1-1ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0~rc1-1ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Fri Feb 21 16:16:14 2014
xserver.configfile: default
xserver.errors:
 Failed to load module "nvidia" (module does not exist, 0)
 Failed to load module "nvidia" (module does not exist, 0)
 NOUVEAU(G0): [XvMC] Failed to initialize extension.
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 489
 vendor LGD
xserver.version: 2:1.15.0-1ubuntu6

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

screen attached
This reflects difficulty when using an external mouse on laptop when lim is enabled & after that a log out/in
(if not doing a log out/in after setting it is even more difficult

When ever the menu flashes indicates an attempt to open a menu

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Doug Collinge (doug-collinge) wrote :

LIM is not really usable with this bug. Whether the menu drops down or the menu bar just flashes seems to just be chance. If it is in flash state it seems that it can always be made to drop down simply by continuing to click on it a few times.

It renders essential functionality of the package (or a dependent one) broken.

Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: Confirmed → Triaged
tags: added: lim
To post a comment you must log in.