[UIFe] The system shutdowns when multiple accounts are open

Bug #1281058 reported by Ara Pulido on 2014-02-17
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
OEM Priority Project
High
Unassigned
Trusty
High
Unassigned
Unity
Fix Released
High
Andrea Azzarone
7.2
Fix Released
Medium
Andrea Azzarone
indicator-session (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
systemd (Ubuntu)
Low
Unassigned
Trusty
Undecided
Unassigned
unity (Ubuntu)
High
Andrea Azzarone
Trusty
Medium
Unassigned
unity-greeter (Ubuntu)
Medium
Robert Ancell
Trusty
Undecided
Unassigned

Bug Description

[Impact]

Other users logged into a system may loose work if another user shuts down/reboots a system. Data loss is not a Good Thing.

[Test Case]

Steps to reproduce:

1) Create a second account in the system
2) While the first account is open, open a session with the second one
3) Try to shutdown the system

Expected results:
The system logs out instead of shutting down (ideally with a warning on why it did that)

Actual results:
The system shutdowns and unsaved data on session1 is lost

[ Regression Potential]

None.

----------------------------------
Desired resolution:

- Add a warning message informing the user that other users are logged in and then shutting down will also close their sessions as proposed in the mockup attached to comment #12
- The warning message should be "Other users are currently logged in to this computer, shutting down now will also close these other sessions"

Related branches

Ara Pulido (ara) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

The org.freedesktop.login1.power-off-multiple-sessions policy is granted by default for local users on the current session. That's currently intended, I think it's generally a good thing on a desktop. However, it should indeed warn you about it, that's the gnome-session part.

Changed in systemd (Ubuntu):
importance: Undecided → Low
status: New → Triaged
affects: unity (Ubuntu) → gnome-session (Ubuntu)
Changed in gnome-session (Ubuntu):
importance: Undecided → Medium
Changed in unity-greeter (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

gnome-session just triggers the shell (unity or unity-greeter) to show the shutdown dialog. So I think this has to be solved in those two places not gnome-session.

We need a design for how to integrate this into the existing dialogs.

Changed in unity-greeter (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
tags: added: ubuntu-desktop-trusty
affects: gnome-session (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Robert Ancell (robert-ancell) wrote :

You can easily find out if there are existing sessions by interrogating logind.

Stephen M. Webb (bregma) wrote :

The session indicator is what's actually used to start the restart/shutdown process. It already tracks the current login sessions (via logind) and either instigates the shutdown dialog via Unity or uses Zenity to display an alternative shutdown dialog. It needs to modify its Zenity dialog and add additional information (userlist?) when sending its request to Unity, and Unity needs to be modified to handle that data,.

Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Robert Ancell (robert-ancell) wrote :

The issue is the interface is from GNOME and doesn't support additional information to be passed. So we either need to extend/replace it or just do the checking in the dialog.

Robert Ancell (robert-ancell) wrote :

lp:~robert-ancell/unity-greeter/shutdown-session-warning contains a proposed solution for this in the greeter. Screenshots to follow.

Robert Ancell (robert-ancell) wrote :

Note I used the LightDM session interface to check if sessions are open. logind keeps sessions around after logout (due to pulseaudio staying alive?) so this leads to a misleading warning.

John Lea (johnlea) on 2014-03-26
description: updated
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → John Lea (johnlea)
Dave Morley (davmor2) wrote :

This now effects the new lock screen too.

Changed in unity-greeter (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 14.04.6-0ubuntu1

---------------
unity-greeter (14.04.6-0ubuntu1) trusty; urgency=medium

  * New upstream release:
    - Add option to hide certain users until alt+ctrl+shift is pressed.
    - Show a warning when shutting down and users are logged in. (LP: #1281058)
    - Drop some fixes that are in Vala 0.22 now.
 -- Robert Ancell <email address hidden> Thu, 27 Mar 2014 10:51:42 +1300

Changed in unity-greeter (Ubuntu):
status: Fix Committed → Fix Released
Ara Pulido (ara) on 2014-04-04
Changed in oem-priority:
status: New → In Progress
Amr Ibrahim (amribrahim1987) wrote :

Is there anyone working on this?

Ara Pulido (ara) on 2014-04-10
Changed in unity (Ubuntu):
importance: Medium → High
Andrea Azzarone (azzar1) on 2014-04-10
Changed in unity (Ubuntu):
status: Triaged → In Progress
Andrea Azzarone (azzar1) on 2014-04-11
Changed in unity:
milestone: none → 7.2.1
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → High
status: New → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2014-04-11
summary: - The system shutdowns when multiple accounts are open
+ [UIFe] The system shutdowns when multiple accounts are open
Gunnar Hjalmarsson (gunnarhj) wrote :

From a docs POV the UIFe is fine. Naturally there is no mentioning of this feature in the desktop docs yet. ;-)

Andrea Azzarone (azzar1) wrote :
Matthew Paul Thomas (mpt) wrote :

"Other users are currently logged in to this computer, shutting down now will also close these other sessions" is a run-on sentence. I've reported bug 1310970 about fixing the grammar and other problems in the text.

Andrea Azzarone (azzar1) on 2014-04-22
description: updated
Sebastien Bacher (seb128) wrote :

One issue with doing a SRU there is the new strings that are going to be displayed in english/non translated in other locales.

One way to deal with that would be to

- upload an updated translation template to launchpad including those strings
- email the translators list to let them know about those strings
- wait a bit for the translations and until we get updated langpacks with those translations
- then only do the code change/upload

Ara Pulido (ara) on 2014-04-23
Changed in oem-priority:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140512.4-0ubuntu1

---------------
unity (7.2.0+14.10.20140512.4-0ubuntu1) utopic; urgency=low

  [ Stephen M. Webb ]
  * lockscreen/LockScreenAccelerators.h: added required header for
    std:vector definition
  * disabled precompiled headers on arm64 Ubuntu package builds (LP:
    #1317276)

  [ Brandon Schaefer ]
  * Set the max width, so our static text wraps. So we don't end up
    rendering text out of the view area. (LP: #1312749)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: toggle activation of all the unity compiz actions when
    locking the screen Also, make sure that the lockscreen views are
    treated as "always-on-front" windows by nux (and this applies to
    both visibility and events).
  * PanelService: emit an invalid EntryActivated signal if the menu
    hasn't actually been shown In addition, if the menu is not visible
    after the first popup call, try to show a menu without keyboard
    focus. This will make possible to see menus also when there's a key-
    grab (although they will be without keyboard support). Finally,
    reset the menu state, if that failed.
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * UnityScreen: don't try to show Dash/Hud if the screen is grabbed
    Also move the dash opening out from LauncherController, and get rid
    of UBus as first initialization source, as it can only slow things
    down here. (LP: #741869)
  * PluginAdapter: make sure we don't try to call an invalid
    initiate/terminate callback function (LP: #1221673)
  * DebugDBusInterface: match properties if they are in the AP array
    form [<type>, <value>] (LP: #1307748)

  [ William Hua ]
  * Add proper support for modifier-only shortcuts on the lock screen.
    (LP: #1291461)

  [ Jinkyu Yi ]
  * Dash: Fix problem at checking blacklisted unicode range (LP:
    #1251193)

  [ Andrea Azzarone ]
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)
 -- Ubuntu daily release <email address hidden> Mon, 12 May 2014 22:03:27 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Ara Pulido (ara) on 2014-05-20
Changed in unity-greeter (Ubuntu Trusty):
status: New → Fix Released
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity:
milestone: 7.2.1 → 7.2.2
Stephen M. Webb (bregma) on 2014-06-17
Changed in unity:
milestone: 7.2.2 → 7.3.0
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
milestone: 7.3.0 → 7.3.1
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium
status: New → Triaged
Changed in unity:
milestone: 7.3.1 → 7.3.0
status: In Progress → Fix Released
description: updated

Hello Ara, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.2+14.04.20140714-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed

The version in trusty-proposed works as per "Desired resolution". The user is warned about other users being logged in and that those other sessions will also be closed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.2+14.04.20140714-0ubuntu1

---------------
unity (7.2.2+14.04.20140714-0ubuntu1) trusty; urgency=medium

  [ Alfred Neumayer ]
  * Restore the launcher position by reversing the animation and
    unsetting the DND_PUSHED_OFF quirk. (LP: #1304882)

  [ Brandon Schaefer ]
  * TextInput: move the warning icon inside the input field, render it
    white (LP: #1307738)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * Lockscreen warning icon needs a tooltip to say what the warning is
    about! (LP: #1308288)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * ApplicationLauncherIcon: Focus and, in case, Spread the windows on
    DnD After 1 second that an user is over an icon, that icon should
    focus the relative application and Spread its windows if it has more
    than one opened. Correctly handle the DnD scale in launcher, and
    apply glow to the icon under pointer. (LP: #607796)
  * ShutdownView: Scale up the Buttons and Text plus Borders of the
    UnityWindowView. (LP: #1308323)
  * SwitcherView: use RawPixel's for the size values and convert them to
    match current scaling (LP: #1317348)
  * PluginAdapter: try to grab the screen to make sure that the screen
    is not grabbed FocusIn event with NotifyGrab mode is not always
    triggered by X when a window takes the grab, then we need to ensure
    that there's no grab by trying to get one. We only care about
    keyboard here, since pointer grabs don't affect us in general.
    (LP: #741869)
  * ShortcutView: use RawPixel's for the size values and convert them to
    match current scaling Plus dinamically allocate horizontal space,
    not to cut the text. (LP: #924840)

  [ Chris Townsend ]
  * Fix issue where scaling the edge illumination up and down with the
    size of the Launcher icons would cause the illumination border to be
    offset and smaller than the icon. (LP: #1309739)
  * Fix issue where the number of Launcher icon pips are not always
    properly updated when a new window of an already running application
    is opened. (LP: #1283775)
  * Fix issue where the Panel shadow would get drawn over drop down
    windows in full screen windows. (LP: #1316005)
  * Bump upstream release to 7.2.2.

  [ Andrea Azzarone ]
  * Clear the clipboard when locking the screen. (LP: #1308911)
  * Disable switcher gestures if screen is locked. Fixed a regression.
    (LP: #1321043)
  * Pass the correct options to showLauncherKeyTerminate in
    UnityScreen::OnLockScreen (LP: #1320438)
  * Fix skype indicator blinking. (LP: #1310200)
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Mon, 14 Jul 2014 14:31:00 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released
Bib (bybeu) wrote :

The warning (1st sentence) is not localized into ... at least french.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu Trusty):
status: New → Confirmed
Changed in systemd (Ubuntu Trusty):
status: New → Confirmed
Ara Pulido (ara) on 2014-07-30
Changed in oem-priority:
status: In Progress → Fix Released
Martin Pitt (pitti) on 2014-08-04
Changed in systemd (Ubuntu):
status: Triaged → Invalid
Changed in systemd (Ubuntu Trusty):
status: Confirmed → Invalid
Bruno Nova (brunonova) wrote :

The warning is shown when another user is logged in graphically (via lightdm).

But what about when the other user is logged in a virtual console (Alt+F1) or via SSH, RDP, etc?
From what I've seen, the warning isn't shown in these cases.

tags: removed: ubuntu-desktop-trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers