Unity could use "export UNITY_LOW_GFX_MODE=1" option in low hardware or VM

Bug #1273005 reported by Sergio Benjamim on 2014-01-26
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Trying to run Ubuntu in a low hardware (any hardware weaker than one core 2 duo, i think) or in a virtual machine is painful. Even in a new hardware, with core i7 for example, it is slow with Unity, if it uses Intel graphics onboard.

There is a simple workaround, put "export UNITY_LOW_GFX_MODE=1" in .xprofile, in your home. If the hardware is weak, ubuntu could run Unity with this option. This greatly improves performance.

"Linux for human beings", so, only for human that have new and top hardware? I know a lot of people that have a modest hardware (here in Brazil is common to have a hardware from 3 or more years ago).

Yeah, i know that there are xubuntu and lubuntu, but people normally knows Ubuntu, not others flavors. And as i said before, Unity is slow in new hardware too (if you don't have a nvidia or amd graphic card installed...).

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.1.2+14.04.20131106.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic i686
.tmp.unity.support.test.1:

ApportVersion: 2.13.1-0ubuntu1
Architecture: i386
CasperVersion: 1.336ubuntu1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDmesg:
 [ 14.401565] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
 [ 14.401577] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 14.736136] init: udev-fallback-graphics main process (1892) terminated with status 1
 [ 15.952719] init: plymouth-upstart-bridge main process (1023) killed by TERM signal
Date: Sun Jan 26 23:23:56 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140124)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash --
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.10+13.10.20131011-0ubuntu1
version.libdrm2: libdrm2 2.4.51-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.0.1-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.0.1-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.5-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu11
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.907-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu1
xserver.bootTime: Sun Jan 26 23:23:12 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Sleep Button KEYBOARD, id 7
 input VirtualBox USB Tablet TOUCHSCREEN, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
 input ImExPS/2 Generic Explorer Mouse MOUSE, id 10
xserver.errors:
 Failed to load module "vboxvideo" (module does not exist, 0)
 Failed to load module "vboxvideo" (module does not exist, 0)
 open /dev/dri/card0: No such file or directory
 open /dev/dri/card0: No such file or directory
 open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.5-1ubuntu2

Related branches

Sergio Benjamim (sergio-br2) wrote :
summary: - Unity may use "export UNITY_LOW_GFX_MODE=1" option in low hardware or VM
+ Unity could use "export UNITY_LOW_GFX_MODE=1" option in low hardware or
+ VM
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

- Development releases are mostly tested under Virtual Machines.
- Ubuntu Virtual Machines doesn't work well in most machines.
- So this bug renders the ability of properly testing Ubuntu broken for most users.
- So this has a great impact in overall Ubuntu quality; making bugs to be discovered when installing the final release, instead when testing a development one under a Virtual machine.

Because this bug is estimated to have a moderate impact on a large portion of Ubuntu users, it has a priority of "high".

Changed in unity (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in unity:
status: New → Confirmed
no longer affects: unity
Changed in unity (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers