Unable to upgrade Unity due to libxi6 dependency

Bug #1267665 reported by Andy Smith on 2014-01-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libxi (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Dimitri John Ledkov
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

As of Thursday 9th January I am unable to upgrade packages without being offered to remove unity and Ubuntu desktop:

http://paste.ubuntu.com/6723064/

"apt-get install ubuntu-desktop^" complains that a version of libxi6 is to be installed which doesn't meet unity's dependencies:

http://paste.ubuntu.com/6724056/

"apt-get policy" outputs for libxi6 and unity:

http://paste.ubuntu.com/6724078/
http://paste.ubuntu.com/6724082/

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.20.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-35.50~precise1-generic 3.8.13.13
Uname: Linux 3.8.0-35-generic i686
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,imgpng,mousepoll,vpswitch,unitymtgrabhandles,text,resize,gnomecompat,snap,grid,place,move,regex,resizeinfo,wall,session,animation,workarounds,expo,fade,scale,ezoom,scalefilter,unityshell]
Date: Fri Jan 10 01:23:18 2014
MarkForUpload: True
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-05-01 (618 days ago)

Andy Smith (grifferz) wrote :
Changed in libxi (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Maarten Lankhorst (mlankhorst)
status: Confirmed → New
assignee: Maarten Lankhorst (mlankhorst) → nobody
importance: Critical → Undecided
Changed in libxi (Ubuntu):
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Dimitri John Ledkov (xnox) wrote :

libxi 2:1.7.1.901-1ubuntu1~precise1 was published in precise-updates pocket on the 6th of January

https://launchpad.net/ubuntu/+source/libxi/2:1.7.1.901-1ubuntu1~precise1

It appears as if on your system there are non standard pinning levels, and thus instead of installing from -updates pocket, libxi6 from -security pocket is installed. (990, 900)

Please note, that generally one does not need to rank -security pocket, higher than -updates pocket. As security updates always "trump" updates pocket, by strict version number comparison.

Changed in libxi (Ubuntu Precise):
status: New → Incomplete
Changed in unity (Ubuntu Precise):
status: New → Invalid
Changed in libxi (Ubuntu Precise):
assignee: nobody → Dimitri John Ledkov (xnox)
Dimitri John Ledkov (xnox) wrote :

Please correct apt-pinning levels on the affected system.

Andy Smith (grifferz) wrote :

Hi Dmitri,

Thanks, that appears to have fixed it.

Content of /etc/apt/preferences was:

http://paste.ubuntu.com/6724511/

I have no recollection of ever having personally edited that file, but it is possible.

After removing it and doing an apt-get update, I was offered a large number of upgrades with no removals.

Changed in libxi (Ubuntu Precise):
status: Incomplete → Invalid
David Gleich (dgleich) wrote :

This bug issue also affected me -- thanks so much for posting the fix.

I had the same pinning levels as Andy, except I had the file

/etc/apt/preferences.d/99-proposed

with the same contents as Andy's file.

Once I removed that file (which had a creation date of Sept 12 - 2012)

rm /etc/apt-preferences.d/99-proposed

then things worked after I did a

apt-get dist-upgrade

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers