compiz crashed with SIGSEGV in unity::ui::EdgeBarrierController::Impl::SetupBarriers()

Bug #1228965 reported by Steve Langasek on 2013-09-22
150
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Andrea Azzarone
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

This crash happened when I disconnected my external monitor.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: unity 7.1.0+13.10.20130920-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic x86_64
ApportVersion: 2.12.4-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sun Sep 22 15:28:54 2013
ExecutablePath: /usr/bin/compiz
InstallationDate: Installed on 2010-09-24 (1094 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MarkForUpload: True
ProcCmdline: compiz --sm-client-id 10f36c25ff9ff47035137124123089641000000038000043
SegvAnalysis:
 Segfault happened at: 0x478fc80: addb $0x0,(%rax)
 PC (0x0478fc80) in non-executable VMA region: 0x023b6000-0x049c7000 rw-p [heap]
 source "$0x0" ok
 destination "(%rax)" (0x03c93160) ok
SegvReason: executing writable VMA [heap]
Signal: 11
SourcePackage: unity
StacktraceTop:
 ?? ()
 unity::ui::EdgeBarrierController::Impl::SetupBarriers(std::vector<nux::Rect, std::allocator<nux::Rect> > const&) () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
 unity::glib::Source::SourceCallback(void*) () from /usr/lib/libunity-core-6.0.so.7
 g_main_dispatch (context=0x23c9170) at /build/buildd/glib2.0-2.37.93/./glib/gmain.c:3065
Title: compiz crashed with SIGSEGV in unity::ui::EdgeBarrierController::Impl::SetupBarriers()
UpgradeStatus: Upgraded to saucy on 2013-05-06 (139 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin mythtv plugdev sambashare src sudo

Related branches

Steve Langasek (vorlon) wrote :
information type: Private → Public

StacktraceTop:
 ?? ()
 unity::ui::EdgeBarrierController::Impl::SetupBarriers (this=0x2f4e870, layout=...) at /build/buildd/unity-7.1.0+13.10.20130920/launcher/EdgeBarrierController.cpp:204
 emit (impl=0x2fa85a0) at /usr/include/sigc++-2.0/sigc++/signal.h:776
 emit (this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:2673
 operator() (__closure=<optimized out>) at /build/buildd/unity-7.1.0+13.10.20130920/launcher/LauncherOptions.cpp:52

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-09-23
Changed in unity (Ubuntu):
importance: Medium → High
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Andrea Azzarone (andyrock)
milestone: none → 7.1.2
Andrea Azzarone (azzar1) on 2013-09-23
Changed in unity:
importance: High → Critical
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2013-09-24
Changed in unity:
milestone: 7.1.2 → 7.1.1
Jérôme Poulin (jeromepoulin) wrote :

Disconnected monitor while screen was locked.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-09-25
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.1.1+13.10.20130927.1-0ubuntu1

---------------
unity (7.1.1+13.10.20130927.1-0ubuntu1) saucy; urgency=low

  [ Michal Hruby ]
  * Add a property to the Scope class
  * Add parameters to Preview::PerformAction
  * Bump ABI version

  [ Brandon Schaefer ]
  * restart the ibus daemon wit hthe right args for tests.
  * Change sleep from 5 to 10, in hopes of appeasing jenkins.
  * If we are switching view ports tell nux to process the events. Even
    though the viewport switcher does grab the mouse, we will still feed
    nux the events so we can correctly update where the mouse is for the
    launcher. (LP: #1231679)

  [ chris.gagnon ]
  * BlackListDriverError moved to Display. (LP: #1227882)

  [ Marco Trevisan (Treviño) ]
  * UBusMessages: remove useless messages (and relative emission).
  * PanelService: set proper priority for floating position-less NG
    indicators. (LP: #1229460)
  * Unity: Use WindowManager average_color property for getting the
    desktop color Having to deal with UBus here was a mess and caused us
    to re-store the same value too many times. Using a nux property
    gives us all the features we need easily while WindowManager is
    already enough shared to be used for this task.
  * VScrollBarOverlayWindow: add quick fade animation on show/hide.

  [ Chris Townsend ]
  * A regression caused by revno. 3515 breaks the recently fixed
    Quicklist and Tooltip active blur. This fixes it by checking if the
    View is a ViewWindow and if so, use QueueDraw() instead of
    NeedSoftRedraw(). (LP: #1228308)
  * The ShowDesktopHandleWindowInterface teardown was missing it's call
    to DeleteHandler() in a recent commit that refactored the handling
    of some Show Desktop code. (LP: #1228915)

  [ Andrea Azzarone ]
  * Don't use sigc::bind with a static value that should be dynamic.
    (LP: #1228965)

  [ Jeremy Bicha ]
  * recommend telepathy-indicator.

  [ Łukasz 'sil2100' Zemczak ]
  * No new recommends/depends now, since at this point of the cycle it's
    not allowed for this project
  * Re-add the telepathy-indicator recommends as it got dropped from
    Main without any valid reasons

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3540
 -- Ubuntu daily release <email address hidden> Fri, 27 Sep 2013 12:44:54 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers