Visual corruption of Dash

Bug #1224340 reported by Simplehuman on 2013-09-12
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

Dash has a visual corruption on the bottom.

I attached video to see it clearly.

In Ubuntu 13.04 there were no such problems.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: unity 7.1.0+13.10.20130903.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-7.13-generic 3.11.0
Uname: Linux 3.11.0-7-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Это каталог: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 319.32 Wed Jun 19 15:51:20 PDT 2013
 GCC version: gcc version 4.8.1 (Ubuntu/Linaro 4.8.1-10ubuntu1)
.tmp.unity.support.test.0:

ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Thu Sep 12 11:20:32 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
GraphicsCard:
 NVIDIA Corporation GF110 [GeForce GTX 580] [10de:1080] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ZOTAC International (MCO) Ltd. Device [19da:1203]
InstallationDate: Installed on 2013-07-31 (42 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130730)
JockeyStatus:
 kmod:nvidia_319_updates - nvidia_319_updates (Проприетарные, Активирован, Не используется)
 kmod:nvidia_304 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Проприетарные, Выключен, Не используется)
 kmod:nvidia_304_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Проприетарные, Выключен, Не используется)
 kmod:nvidia_319 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Проприетарные, Выключен, Не используется)
MachineType: System manufacturer System Product Name
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-7-generic root=UUID=69cd82a7-9a60-46b8-b39a-0985ac8652aa ro noresume ipv6.disable=1
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/09/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: SABERTOOTH X58
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1402:bd08/09/2012:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnSABERTOOTHX58:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.10+13.10.20130828.2-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.2-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.2-1ubuntu1
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu6
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.9-2ubuntu1
xserver.bootTime: Wed Sep 11 22:58:10 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Ruling Technologies Sdn. Bhd. SteelSeries Gaming Device MOUSE, id 8
 input Ruling Technologies Sdn. Bhd. SteelSeries Gaming Device KEYBOARD, id 9
 input AT Translated Set 2 keyboard KEYBOARD, id 10
xserver.errors: open /dev/fb0: No such file or directory
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.2.901-2ubuntu4

Related branches

Simplehuman (simplehuman) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-09-12
Changed in unity:
importance: Undecided → Medium
status: New → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in unity:
milestone: none → 7.1.1
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.1.1

Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 7.1.0+13.10.20130920-0ubuntu1

---------------
unity (7.1.0+13.10.20130920-0ubuntu1) saucy; urgency=low

  [ Stephen M. Webb ]
  * render the Dash frame all the way to the bottom of the screen (lp:
    #1100120). (LP: #1100120)

  [ Brandon Schaefer ]
  * Ignore mouse movements if the mouse starts over a switcher icon.
    Clicking still works fine, we just wont steal focus from the alt+tab
    work. (LP: #1215630)
  * Make sure we ignore mouse movement over detail icons if the mouse
    starts over it at start. Let the mouse take selection control once
    it moves outside of any icon, vs having to enter a different icon.
    (LP: #1223037, #1223039)
  * Add an option to disable the mouse in the switcher. (LP: #1224048)
  * When the shortcut is open, and we receive a ButtonPress or KeyPress
    hide it. As this causes problems else where, and it really should
    close if the user attempts to do anything (even while holding
    super!). (LP: #932718)
  * Set an upper bound on the amount of icons we go through to check
    tooltips. As the accordion effect was causing the mouse to go
    through the icons to fast, making the test fail.
  * Make sure we move the mouse over the target icon while we are
    dragging the source icon.
  * Get the real shortcut to activate ibus. (LP: #1227056)
  * Only accept focus if the mouse moves in 3 directions on switcher
    start up if the mouse starts over the switcher window. This is an
    attempt to tell the difference between a bump and intentional
    movement. (LP: #1223630)

  [ Marco Trevisan (Treviño) ]
  * DesktopApplicationManager: added new app manager layer so that we
    can emit app events.
  * Application: add desktop_id method, and implement in
    desktop::Application.
  * Launcher: only fade the launcher when in auto-hide and dash is
    opened. (LP: #1223979, #1044926)
  * ApplicationLauncherIcon: log unity zeitgeist events on stick,
    unstick, removal and delete. (LP: #779449)
  * UnityScreen: add support for Super+Arrows shortcuts to manage the
    focused window Super+Arrows shortcut allows to move and maximize /
    restore / minimize the focused window on the screen. (LP: #992697,
    #751050)
  * Launcher: use nux::Animation for all the launcher animations This
    allows to do these when compiz requests to prepare painting, instead
    of using only an idle to perform this. (LP: #1226114, #1224766)
  * ShortcutView: use StaticCairoText instead of StaticText for
    rendering the View Improves the text alignment and visual quality.
  * UnityShell: redraw the dash also if a non-blurred area is damaged If
    the dash is damaged, but not the blurred area, it won't redraw. We
    need to draw it, in order to avoid flickering of its border. Also,
    add the redraw_view_if_damaged utility function to redraw a view if
    really needed. (LP: #1224340)
  * AnimationUtils: add utility functions to handle nux::Animation's
    start and reversion Update the whole code using nux::animation to
    use these facility functions.
  * Launcher: fix style to use postfixed-underscore for private members
    Also remove some tabs and useless members.
  * ...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Unity 7.1.1.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.