Ubuntu

Eclipse menu won't open in Ubuntu 13.10 (beta1)

Reported by john ferrier on 2013-09-06
392
This bug affects 86 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I am using Eclipse-CDT (Kepler Linux 64bit) for some development and it worked perfectly on Ubuntu 13.04 X86_64.

However, after upgrading to Ubuntu 13.10 (beta 1) yesterday I found I could not have Eclipse menus (located on Unity's top-panel ) droped down. I also tried to download a new copy of Eclipse but it was the same.

It looks like something wrong in 13.10.

Hans Joachim Desserud (hjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1208019, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
chautran (zaracattle) wrote :

I have the same issue on Ubuntu 13.10. It doesn't work for the latest version of Eclipse as well.

Basher Aobasher (aobasher) wrote :

it work fro me now, here is how to

sudo gedit /usr/share/applications/eclipse.desktop

update it to :

[Desktop Entry]
Version=1.0
Name=Eclipse
Exec=env UBUNTU_MENUPROXY= eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Type=Application
Categories=IDE;Development
X-Ayatana-Desktop-Shortcuts=NewWindow
[NewWindow Shortcut Group]
Name=New Window
Exec=env UBUNTU_MENUPROXY= eclipse
TargetEnvironment=Unity

fish (rohit0286) wrote :

This is the ubuntu version i'm using :
3.11.0-14-generic #21-Ubuntu SMP Tue Nov 12 17:04:55 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
I've installed eclipse as per steps defined here :
http://askubuntu.com/questions/26632/how-to-install-eclipse
Later I update eclipse.desktop file as mentioned above. However, this isn't working for me.

Filiprino (filiprino) wrote :

I'm also affected by this bug. Confirmed on two computers I own.

Michał Darda (michaldarda) wrote :

This affects me also on Ubuntu 14.04 daily 64 bit with latests updates and Eclipse 4.3.2

tanvir (crypted-hex) wrote :

thank you Basher your solution worked for me

i am using ubuntu 13.10 32bit version

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers