compiz crashed with SIGSEGV in CompAction::initiate()

Bug #1221673 reported by Tiago Carrondo on 2013-09-06
206
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Marco Trevisan (Treviño)
7.2
Fix Released
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Trusty
Undecided
Marco Trevisan (Treviño)

Bug Description

[Impact]
at boot

ProblemType: CrashDistroRelease: Ubuntu 13.10
Package: unity 7.1.0+13.10.20130903.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic x86_64
ApportVersion: 2.12.1-0ubuntu3
Architecture: amd64
CrashCounter: 1
Date: Fri Sep 6 10:38:05 2013
ExecutablePath: /usr/bin/compiz
InstallationDate: Installed on 2013-09-04 (1 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130904)
MarkForUpload: True
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=pt:pt_BR:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=pt_PT.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fe02b8d169d <_ZN10CompAction8initiateEv+13>: mov 0x8(%rdi),%rdx
 PC (0x7fe02b8d169d) ok
 source "0x8(%rdi)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rdx" ok
SegvReason: reading NULL VMA
Signal: 11SourcePackage: unity
StacktraceTop:
 CompAction::initiate() () from /usr/lib/libcompiz_core.so.ABI-20130415
 unity::MultiActionList::Initiate(std::string const&, std::vector<CompOption, std::allocator<CompOption> > const&, int) const () from /usr/lib/compiz/libunityshell.so
 unity::MultiActionList::InitiateAll(std::vector<CompOption, std::allocator<CompOption> > const&, int) const () from /usr/lib/compiz/libunityshell.so
 unity::PluginAdapter::InitiateExpo() () from /usr/lib/compiz/libunityshell.so
 unity::launcher::LauncherIcon::Activate(unity::launcher::ActionArg) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in CompAction::initiate()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

[Test Case]
Unclear: this is an intermittent crash problem.

[Regression Potential]
The worst case is that session would continue to crash on startup.

Related branches

Tiago Carrondo (tcarrondo) wrote :

StacktraceTop:
 CompAction::initiate (this=0x149ec10) at /usr/include/boost/function/function_template.hpp:904
 unity::MultiActionList::Initiate (this=0x0, this@entry=0x16af470, name=..., extra_args=..., state=0) at /build/buildd/unity-7.1.0+13.10.20130903.1/unity-shared/PluginAdapter.cpp:283
 unity::MultiActionList::InitiateAll (this=0x16af470, extra_args=..., state=state@entry=0) at /build/buildd/unity-7.1.0+13.10.20130903.1/unity-shared/PluginAdapter.cpp:309
 unity::PluginAdapter::InitiateExpo (this=<optimized out>) at /build/buildd/unity-7.1.0+13.10.20130903.1/unity-shared/PluginAdapter.cpp:427
 unity::launcher::LauncherIcon::Activate (this=0x1c79380, arg=...) at /build/buildd/unity-7.1.0+13.10.20130903.1/launcher/LauncherIcon.cpp:210

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Stephen M. Webb (bregma) on 2013-09-17
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → Medium
information type: Private → Public
Sebastien Bacher (seb128) wrote :

error bucket for that issue, https://errors.ubuntu.com/problem/24c9ba23fb469a953e7624b1dfb8fdae97c45618

it's one of the most reported unity errors

Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
importance: Medium → High
milestone: none → 7.2.1
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Stephen M. Webb (bregma) on 2014-05-07
description: updated
Stephen M. Webb (bregma) on 2014-05-07
Changed in unity:
milestone: 7.2.1 → 7.3.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.0+14.10.20140512.4-0ubuntu1

---------------
unity (7.2.0+14.10.20140512.4-0ubuntu1) utopic; urgency=low

  [ Stephen M. Webb ]
  * lockscreen/LockScreenAccelerators.h: added required header for
    std:vector definition
  * disabled precompiled headers on arm64 Ubuntu package builds (LP:
    #1317276)

  [ Brandon Schaefer ]
  * Set the max width, so our static text wraps. So we don't end up
    rendering text out of the view area. (LP: #1312749)

  [ Marco Trevisan (Treviño) ]
  * UnityScreen: toggle activation of all the unity compiz actions when
    locking the screen Also, make sure that the lockscreen views are
    treated as "always-on-front" windows by nux (and this applies to
    both visibility and events).
  * PanelService: emit an invalid EntryActivated signal if the menu
    hasn't actually been shown In addition, if the menu is not visible
    after the first popup call, try to show a menu without keyboard
    focus. This will make possible to see menus also when there's a key-
    grab (although they will be without keyboard support). Finally,
    reset the menu state, if that failed.
  * UnityScreen: always paint the lockscreen above, just add menu and
    onboard as exceptions Some code cleanup, factorizing similar code.
    (LP: #1313280)
  * UnityScreen: don't try to show Dash/Hud if the screen is grabbed
    Also move the dash opening out from LauncherController, and get rid
    of UBus as first initialization source, as it can only slow things
    down here. (LP: #741869)
  * PluginAdapter: make sure we don't try to call an invalid
    initiate/terminate callback function (LP: #1221673)
  * DebugDBusInterface: match properties if they are in the AP array
    form [<type>, <value>] (LP: #1307748)

  [ William Hua ]
  * Add proper support for modifier-only shortcuts on the lock screen.
    (LP: #1291461)

  [ Jinkyu Yi ]
  * Dash: Fix problem at checking blacklisted unicode range (LP:
    #1251193)

  [ Andrea Azzarone ]
  * Add a warning in the session dialog if other sessions are still
    open. (LP: #1281058)
 -- Ubuntu daily release <email address hidden> Mon, 12 May 2014 22:03:27 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released

Hello Tiago, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Tiago, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/7.2.1+14.04.20140513-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I will keep an eye on https://errors.ubuntu.com/problem/24c9ba23fb469a953e7624b1dfb8fdae97c45618 to see if this trusty-proposed version of Unity shows up. If it doesn't after a week or so, then I feel quite confident the issue is fixed. Also, seeing as this fix is in Utopic and no new bugs or reports in e.u.c, it stands to reason the fix is holding up as well.

Sebastien Bacher (seb128) wrote :

looks to e.u.c the issue seems to be resolved, setting as verification-done

tags: added: verification-done
removed: verification-needed
Stephen M. Webb (bregma) on 2014-06-04
Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Trusty):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Stephen M. Webb (bregma) on 2014-06-20
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.